Jump to content


Photo

Server on Shield TV


  • Please log in to reply
3 replies to this topic

#1 brianbsmith OFFLINE  

brianbsmith

    Member

  • Members
  • 18 posts
  • Local time: 09:49 PM

Posted 07 November 2019 - 09:30 AM

Here the the difficulties I’ve encountered on my 1st experience with Emby server on Shield TV.

@EMBY: please make the server available in the Google store. It’s not easy finding a way to download the package to Shield. I had to install multiple file Mgr apps before I found one that worked - via google drive. Couldn’t get various other methods to work. (Have an in progress Shield support case regarding their “Yransfer files over local network” feature)

The server does not boot after Shield reboot. You need to open the Server app and flick the switch. This is really annoying and should be a persistent setting.

Configuring a library on USB storage is difficult. Again you need a file Mgr app to create a folder. And it needs to be configured in 2 places: library settings and DVR settings. (This is not unique to Shield - but more difficult to trouble shoot than Windows or Linux)

It’s does not seem as reliable as my Windows server. For example, attempting to view previous recordings while another show is recording seems to interrupt/cancel the current recording. I have multiple recordings that are a partial segment of the full show. 4 mins of a 30 min show.

I just reinstalled and rebooted - hoping that might stabilize things. Also not going to view past recordings while actively recording to see if the problem goes away.

Basically - I want to use my Shield like a TiVo. But it’s requiring too much intervention out of the box.

FWIW

#2 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 458 posts
  • Local time: 09:49 PM

Posted 07 November 2019 - 12:52 PM

Cant speak for Emby Server on the Shield.....I only use it as a client and it has pausing/stuttering issues streaming Live TV for me, everything else works.

I don't like the idea of server is also on client idea. Always seems to me most stable and best performing to have a dedicated powerful enough computer or device to run as server.

 

Far as I can tell, the Shield is clearly optimized/designed for use with Plex server, as that is pre-installed.

Many many folks use the Shield since 2015 for Plex server and it is well rated and stable, from what i have read.

Never tried it my self...i don't really care for Plex.

 

As far as Live TV and DVR ability and experience alone, I find Channels DVR the best on Shield.

But it lack any form of "home media server" ability that Emby/Plex/Kodi offers.

But again, even that is best setup with a dedicated server device....


Edited by speedingcheetah, 07 November 2019 - 12:52 PM.


#3 EODCrafter OFFLINE  

EODCrafter

    Advanced Member

  • Members
  • 795 posts
  • Local time: 09:49 PM
  • LocationSouthEastern USA

Posted 07 November 2019 - 01:09 PM

Here the the difficulties I’ve encountered on my 1st experience with Emby server on Shield TV.

@EMBY: please make the server available in the Google store. It’s not easy finding a way to download the package to Shield. I had to install multiple file Mgr apps before I found one that worked - via google drive. Couldn’t get various other methods to work. (Have an in progress Shield support case regarding their “Yransfer files over local network” feature)

The server does not boot after Shield reboot. You need to open the Server app and flick the switch. This is really annoying and should be a persistent setting.

Configuring a library on USB storage is difficult. Again you need a file Mgr app to create a folder. And it needs to be configured in 2 places: library settings and DVR settings. (This is not unique to Shield - but more difficult to trouble shoot than Windows or Linux)

It’s does not seem as reliable as my Windows server. For example, attempting to view previous recordings while another show is recording seems to interrupt/cancel the current recording. I have multiple recordings that are a partial segment of the full show. 4 mins of a 30 min show.

I just reinstalled and rebooted - hoping that might stabilize things. Also not going to view past recordings while actively recording to see if the problem goes away.

Basically - I want to use my Shield like a TiVo. But it’s requiring too much intervention out of the box.

FWIW

Most of your statements I have found to not be true....true, it's not a Emby App, it's a full-blown Emby Server but I have found it works quite well until you start adding a lot of tv channels and guide info. Emby itself is not quite ready for Live TV (IPTV) and this has already been addressed as a "future" update by @Luke. "Side Loading" on the Shield is about a basic task as it gets, and the Server has always restarted for me on Power down/restart. I don't use TiVo, so I can't speak to how that App works.


Edited by EODCrafter, 07 November 2019 - 01:15 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139859 posts
  • Local time: 10:49 PM

Posted 07 November 2019 - 11:51 PM

 

 

The server does not boot after Shield reboot. You need to open the Server app and flick the switch. This is really annoying and should be a persistent setting.

 

Hi, it is, once you flick the switch, just leave the switch on. Does this answer your question?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users