Jump to content
yarez0

ANSWERED MIBOX S can't change volume

Recommended Posts

yarez0

Hi Luke, 

 

I'm trying XIAOMI MIBOX S android tv box and the amby app is great (better than LG tv app and iOS I think) but I have a volume control issue. 

 

The mibox is connected through SPDIF to a sound bar, on all video apps on the box I can control the volume with the mibox controler but not on the emby app ! I tryied to look for an option but I can't find anything.

 

also it seems like there is a sound issue : I noticed that the sound is a littlte bit bad, acute (aigue [FR] ?) are too high / saturated, low seems to be great (but it is maybe because of my sound bar)

 

all parameters are by default

 

 

andoid tv : xiaomi mibox s

android tv app : 1.7.54g

server : synology up to date

sound bar : freebox player devialet

 

is there a parameters that I missed ? 

 

I can't find the app logs

 

 

thanks

Share this post


Link to post
Share on other sites
ebr

Hi.  If the audio is bitstreaming, the volume has to be controlled by the outboard equipment.  It sounds like that is probably what is happening.

 

Can you provide the info from the "Stats for Nerds" screen during playback?

Share this post


Link to post
Share on other sites
yarez0

infos lecture : 

  • lecteur : ExioPlayer
  • mode d'affichage : 1080/60,00
  • méthode de lecture : Direct play
  • type de flux : mkv

infos flux :

  • resolution video : 1920x1080
  • codec audio : H264 (direct)
  • débit : 12,30 Mbps
  • codec audio Dolby (direct)

info du media d'origine : 

  • conteneur : mkv
  • codec video : H264
  • debit video : 12,30 Mbps
  • frame rate : 23,98 fps
  • codec audio : Dolby
  • debit audio : 448,00 Kbps
  • canaux audio : 5.1

Share this post


Link to post
Share on other sites
yarez0

another one : 

 

infos lecture : 

  • lecteur : ExoPlayer
  • mode d'affichage : 1080/60,00
  • méthode de lecture : Direct stream
  • type de flux : HLS

infos flux :

  • resolution video : 1920x1080
  • codec video : H264 (direct)
  • codec audio : Dolby
  • cannaux audio : 5.1
  • débit : 10,20 Mbps
  • debit maximum : 80 Mb/s
  • vitesse de transcodage : 708,00 fps
  • motif du transcodage : audio non supporté
  • etat du trasncodage : 36,78%

info du media d'origine : 

  • conteneur : mkv
  • codec video : H264
  • debit video : 10,01 Mbps
  • frame rate : 23,98 fps
  • codec audio : Dolby+
  • debit audio : <inconnu>
  • canaux audio : 

 

 

 

 

and another one wich is controlled by the remote : audio with AAC stereo

 

infos lecture : 

  • lecteur : ExoPlayer
  • mode d'affichage : 1080/60,00
  • méthode de lecture : Direct play
  • type de flux : mkv

infos flux :

  • resolution video : 1920x1080
  • codec audio : H264 (direct)
  • débit : 8,03 Mbps
  • codec audio : AAC (direct)

info du media d'origine : 

  • conteneur : mkv
  • codec video : H264
  • debit video : 8,03 Mbps
  • frame rate : 23,98 fps
  • codec audio : AAC
  • debit audio : 448,00 Kbps
  • canaux audio : stereo

Share this post


Link to post
Share on other sites
ebr

The two that are fixed volume are bitstreamed compressed audio.  There is no volume control for that.

  • Like 1

Share this post


Link to post
Share on other sites
yarez0

Ok so this is a normal behavior.

 

If I understand every files with DTS or Dolby sound cannot be controlled by the remote whereas stereo can

Share this post


Link to post
Share on other sites
yarez0

to my knowledge : why bistream track cannot be managed by the remote ? 

 

I understand that AAC track is decoded by the client, so the volume control can be managed by the client because the audio track is managed by the emby app whereas bitstream strack are not managed at all by the client, the emby app just passthrough the track to the sound bar without any control. 

 

the client is not design to just control the track output volume, only for those managed by the app

 

am I right ? 

 

If I am, I saw an option to "downstream audio" (if I remember well) if I want to control the volume for bitstream tracks I have to activate the option but in that case the client will transcode the Dolby/DTS/whatever tracks to PCM but I will lose the benefits of x.1 tracks right ? 

Share this post


Link to post
Share on other sites
Luke

 

 

to my knowledge : why bistream track cannot be managed by the remote ? 

 

It can, if your remote can control the audio of your receiver. Does it do that?

  • Like 1

Share this post


Link to post
Share on other sites
ebr

It can, if your remote can control the audio of your receiver. Does it do that?

 

He doesn't have a receiver but the same would apply to the TV (which should be controlling sound for the sound bar).  In short, you are much better off using the outboard audio equipment to control volume than the Android system.

  • Like 1

Share this post


Link to post
Share on other sites
yarez0

It can, if your remote can control the audio of your receiver. Does it do that?

 

 oh ok, but no the remote is bluetooth to the mibox, the mibox is connected through SPDIF to the sound bar and the sound bar has infrared remote. 

 

sound cannot be controlled by SPDIF or I have to find a universal remote that can control the mibox by bluetooth AND the sound bar by infrared.

 

if the sound bar has HDMI port I can control it by CEC but this not my case

 

 

He doesn't have a receiver but the same would apply to the TV (which should be controlling sound for the sound bar).  In short, you are much better off using the outboard audio equipment to control volume than the Android system.

 

yep, I just ask. I'm thinking of it because the sound bar has only 2.1 channel, I'm wondering if there a gain to keep it that way or not but yes I be used to have 2 remotes

 

 

thank you guys

Edited by yarez0

Share this post


Link to post
Share on other sites
ebr

yep, I just ask. I'm thinking of it because the sound bar has only 2.1 channel, I'm wondering if there a gain to keep it that way or not but yes I be used to have 2 remotes

 

I would just set the app to downmix and then you can control everything.  Unless this produces inferior sound, that should solve your problem.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...