Jump to content

Possible fallback with reverse proxy?


Spooky83
 Share

Go to solution Solved by darkassassin07,

Recommended Posts

Hey there,

 

I've been using emby for quite some time with a reverse proxy which works flawlessly except for one thing. I'm also using a Chromecast and when I configure the app to connect through the reverse proxy Chromecast doesn't work.

 

Is it be possible to directly connect to the server (with IP or hostname) at home and just use the reverse proxy while not connected to the home network? Or as a work around it would be ok if you could give them different names.

 

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

Link to comment
Share on other sites

Oh, hadn't tried to change the external address in the settings as the remote connection worked without that. I will try and and see if that helps. Thanks for the quick reply.

 

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

Edited by Spooky83
Link to comment
Share on other sites

OK, strange behavior here. Yesterday it seemed to work, but today the app isn't connecting remotely. Remote access via web GUI works without problems.

One thing i've noticed is that when changing the remote address it says http://[mydomain].com:8096. In my configuration I don't need the port (forwarding is handled by the reverse proxy) and it's also an https connection. Does this matter?

 

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

Link to comment
Share on other sites

  • Solution
darkassassin07

For external connections handled by a reverse proxy, dont forget to set: (in the emby server network settings)

 

"public https port number:" should be the port the reverse proxy is accepting connections on.

 

"secure connection mode:" should be "handled by reverse proxy"

 

 

 

From there the dashboard of your server should display the exact url you would use to connect via a browser: "remote (WAN) access: https://yourdomain.com:443"

(the port on the end should match the port the proxy accepts connections on)

  • Like 2
Link to comment
Share on other sites

Thanks. What a stupid mistake. That seems to work now.

 

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...