Jump to content


Photo

how to remove big logo EMBY


  • Please log in to reply
9 replies to this topic

#1 CarlosLima OFFLINE  

CarlosLima

    Advanced Member

  • Members
  • 672 posts
  • Local time: 09:37 PM
  • LocationSao Paulo

Posted 21 October 2019 - 11:01 PM

Hi
I noticed that in the beta version of embyserver, 4.3.0.15, before the login screen, a large EMBY logo has been added which is shown, it's like a splash image.

Is it possible to use CSS code to remove or replace the image?

Thanks


  • CBers likes this

#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19116 posts
  • Local time: 05:37 PM
  • LocationWashington State

Posted 22 October 2019 - 05:35 PM

Haven't figured out how to target this so it doesn't affect other areas

body > div.mainAnimatedPages.skinBody > div

But it is in the index.html.

    <div class="mainAnimatedPages skinBody">

        <div style="background-image:url(bower_components/emby-webcomponents/themes/logowhite.png);background-position: center top; background-repeat:no-repeat; background-size:contain;position:fixed;top:25%;left:30%;right:30%;height:20%;"></div>
    </div>


#3 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 529 posts
  • Local time: 07:37 PM

Posted 22 October 2019 - 06:57 PM

yea...i now see this splash screen whenever i load web app or theater....i dont really mind it, however, i do know a few users who absolutely hate and despise such splash screens.

It tends to make things load slower, or at least, give the impression that it is.

Kinda surprised i don't see that as a use option to enable/disable.

Many software that have splash or load up screens are user toggleable.


  • daedalus and JAJ like this

#4 CarlosLima OFFLINE  

CarlosLima

    Advanced Member

  • Members
  • 672 posts
  • Local time: 09:37 PM
  • LocationSao Paulo

Posted 22 October 2019 - 10:19 PM

It was simple.
Just replace the image logowhite.png
  • Happy2Play likes this

#5 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19116 posts
  • Local time: 05:37 PM
  • LocationWashington State

Posted 22 October 2019 - 10:30 PM

To me this would appear to load before custom css so it can't really be target via css.

 

You can see it happen if you apply this custom css.  Default loads then custom css.

html.preload {background-color: green;}
html.preload div div {display: none;}

Edited by Happy2Play, 22 October 2019 - 10:39 PM.

  • CarlosLima likes this

#6 makarai OFFLINE  

makarai

    Advanced Member

  • Members
  • 549 posts
  • Local time: 02:37 AM

Posted 29 October 2019 - 04:14 AM

Also here to find a way to "unbrand" my web login. i dont want some randoms who happen to scrape my login screen knowing what this login screen is about.

I really dislike that we cant set the title and now we have a big splashscreen that tells randoms what they are looking at.

 

@Luke


Edited by makarai, 29 October 2019 - 04:14 AM.

  • daedalus likes this

#7 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1380 posts
  • Local time: 02:37 AM

Posted 29 October 2019 - 04:35 AM

It was simple.
Just replace the image logowhite.png

it has to be redone with every update



#8 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 19116 posts
  • Local time: 05:37 PM
  • LocationWashington State

Posted 29 October 2019 - 05:03 AM

it has to be redone with every update

Yep I run a script with every update to copy a new image to that location.



#9 makarai OFFLINE  

makarai

    Advanced Member

  • Members
  • 549 posts
  • Local time: 02:37 AM

Posted 29 October 2019 - 05:45 AM

Yep I run a script with every update to copy a new image to that location.

however, this does not take the reference to emby away. If you scrape the index file you still get things like 

     url(bower_components/emby-webcomponents/themes/logowhite.png);
    <meta name="application-name" content="Emby">
    <meta property="og:title" content="Emby">
    <meta property="og:site_name" content="Emby">
    <meta property="og:url" content="https://emby.media">




#10 cochize1 OFFLINE  

cochize1

    Advanced Member

  • Members
  • 146 posts
  • Local time: 02:37 AM

Posted 27 November 2019 - 11:39 AM

Hi all, I managed to change the logowhite.png file and now it is set to my custom one but this seems to only work in PC web browsers i.e. Chrome or Firefox, but when accessing my servers url via Android Chrome from my phone I still get Emby logo splash, any ideas?

 

EDIT: clearing cache helped:)

 

And another thing, I managed to change the Tital from Emby to MyDomain in index.html file but this just shows MyDomain for a moment and when the login page loads it goes back to Emby, can I somehow set it permanently to MyDomain on every subdomain (like dashboard, login screen etc.)?


Edited by cochize1, 27 November 2019 - 11:48 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users