Jump to content

Subtitle/Language selection only works with Auto Speed ON.


vra1974
 Share

Recommended Posts

When playing a dual audio (Spanish/English) movie using the "Auto Speed", The proper audio and subtitle gets played. 

But problem is that "Auto Speed" always gives a speed of about 850kb. My server upstream is 10mb. 

So, I have to manually set the speed. The problem is that doing this I get the movie played in Spanish audio track. Even if I select the English audio track, it keeps playing it with spanish audio.

 

I already tried selecting English as default languag on Emby Server and Emby User Prefrences.

 

Link to comment
Share on other sites

Happy2Play

Do you have this user playback option enabled "Play default audio track regardless of language"?  And what is the default language for the media?

Link to comment
Share on other sites

-No, the  "Play default audio track regardless of language" is not active.
-Attached you will find a log file where I first played a movie in "Auto" speed. Everything ok (English language with spanish subs. but 850kb speed, low quality) 
  Then played the same movie selecting 1080p/5mb speed. And got stuck with Spanish Audio with no subtitles. And no way to change it. 

embyserver.txt

Edited by vra1974
Link to comment
Share on other sites

hi there @@vra1974, can you please attach the complete emby server log? and if there was an ffmpeg log, please attach that too.

 

Did you try using the pre-playback subtitle selection on the video detail screen?

Link to comment
Share on other sites

Hi!
Yes I did, but does not work.

Last night I made tests playing the same movie at different speeds and resolutions. 
It played well on slow speeds ( bellow 5mb) regardless the resolution (480,720 or 1080) 
I saw that this problem exists when the movie is played on Direct mode instead of Transcoding.

But still, when played on direct mode, it gets played on spanish with no subtitles. Even if I wanted tis particular movie on French with Spanish subtitles.

Attached you will find the server log and transcode logs of this tests.

Edited by vra1974
Link to comment
Share on other sites

Hi!

Yes I did, but does not work.

 

Last night I made tests playing the same movie at different speeds and resolutions. 

It played well on slow speeds ( bellow 5mb) regardless the resolution (480,720 or 1080) 

I saw that this problem exists when the movie is played on Direct mode instead of Transcoding.

 

But still, when played on direct mode, it gets played on spanish with no subtitles. Even if I wanted tis particular movie on French with Spanish subtitles.

 

Attached you will find the server log and transcode logs of this tests.

 

Apologies. This is not how things should work.

 

Do you have a sample you can share with us so we can reproduce this behavior? Playback issues are #1 priority and you are next up if we can get a sample. A link to googledrive, dropbox, or similar.. You can PM either myself (@speechles) or Eric (@ebr) (or both of us) and both of us can work together to resolve this. Thanks. :)

Edited by speechles
Link to comment
Share on other sites

@@vra1974 Thank you very very much for the sample. The issue appears to be related to that file. For some reason both the English and Spanish audio streams are marked as default. This confuses the Roku when it direct plays because it will only accept the first with default as the actual default. The Spanish audio stream is first and given default every time regardless of how we try to change this because it is using default flags on both audio streams.

 

You can remux this file with MKVToolNix GUI and fix the file. It just needs to be remuxed and the app will know to only set the default flag on one of the audio streams instead of both. That is the problem here. Whoever encoded that file made a mistake.

 

There may be something we can do in the app when we notice multiple default flags on audio streams and force a transcode of the audio to get the stream correct. We would have to investigate this. But in the meantime a remux with MKVToolNix will fit it. It is an issue with the header of that mp4 and incorrectly marking both audio streams with default when that cannot be possible. Most modern media players will choose the first default found which is what the Roku is doing in this case.

 

image.png

 

You can also use the video player OSD to fix this. Press down to open the OSD. Choose the gear icon and then choose Playback Correction from that menu. This will cause a remux and now you can change audio streams. Since Emby/ffmpeg is in control during this and not the Roku this will now work correctly.

Edited by speechles
Link to comment
Share on other sites

 

 

You can remux this file with MKVToolNix GUI and fix the file. It just needs to be remuxed and the app will know to only set the default flag on one of the audio streams instead of both. That is the problem here. Whoever encoded that file made a mistake.

Our media conversion feature can also help with this:

https://emby.media/community/index.php?/blog/1/entry-423-emby-server-34-released/

Link to comment
Share on other sites

Yes. I used MKVTool to make a new file with the right "default audio channel" flag. 
Because it was either not set or both channels checked as default. 

This corrected the audio streaming when played on Direct mode.

Other solution was to select "Transcoding" on the play setup option. 

And also, selected my default speed to 1080p - 5mp. Because on Auto mode I only get between 850kb to 1mb speeds. 
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...