Jump to content


Photo

Unable to Connect to Emby Server From Shield TV


Best Answer elmerF , 08 November 2019 - 07:30 PM

Just to revisit this, it was caused by the antivirus program Bitdefender, which like all the current antivirus software out there, seems to want to try to do a bit of everything whether you want it to or not. In this case, it runs it's own firewall that android tv couldn't seem to get through. It's odd that apple tv, roku, and regular browsers could login, but not nvidia shield tv. My Emby server is located in a deep corner of the basement and I didn't see the pop-up that was activated until I had someone else try to login for me. 

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 elmerF OFFLINE  

elmerF

    Newbie

  • Members
  • 6 posts
  • Local time: 10:46 PM

Posted 10 October 2019 - 12:42 PM

Okay, I have emby server running on a windows machine (firewall allows emby public/private). I am only concerned with local connections - I have remote blocked. I have no problem connecting to emby server using a browser on a pc or with apple tv.  When I try to connect with either of my shield tvs I get the opening screen with the user. I click on the user and I get invalid id/password. The logs show this:

 

HTTP GET http://192.168.1.247...nfo?format=json. UserAgent: Dalvik/2.1.0 (Linux; U; Android 9; SHIELD Android TV Build/PPR1.180610.011)
Error HttpServer: Access token is invalid or expired.

 

I have deleted the app on the shield, including cache/data deletion and reinstalled. Same behavior.

  



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47472 posts
  • Local time: 10:46 PM

Posted 10 October 2019 - 01:42 PM

Hi.  What version is your server?

 

Can you please attach the entire server log file from when this happens?



#3 elmerFx OFFLINE  

elmerFx

    Newbie

  • Members
  • 1 posts
  • Local time: 11:46 PM

Posted 10 October 2019 - 06:26 PM

Latest beta - but it's been this way for a while. Just forget it. VLC works great.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139859 posts
  • Local time: 10:46 PM

Posted 11 October 2019 - 01:32 AM

@elmerF, we're happy to help. Can we look at the emby server log? Thanks !



#5 elmerF OFFLINE  

elmerF

    Newbie

  • Members
  • 6 posts
  • Local time: 10:46 PM

Posted 08 November 2019 - 07:30 PM   Best Answer

Just to revisit this, it was caused by the antivirus program Bitdefender, which like all the current antivirus software out there, seems to want to try to do a bit of everything whether you want it to or not. In this case, it runs it's own firewall that android tv couldn't seem to get through. It's odd that apple tv, roku, and regular browsers could login, but not nvidia shield tv. My Emby server is located in a deep corner of the basement and I didn't see the pop-up that was activated until I had someone else try to login for me. 


  • Luke likes this

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139859 posts
  • Local time: 10:46 PM

Posted 08 November 2019 - 11:35 PM

That's great info about BitDefender, thanks for the feedback !






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users