Jump to content


Photo

Live TV Unable To Record On Schedule

dvr live tv recording

  • Please log in to reply
43 replies to this topic

#21 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 12:32 AM

Was Emby Server running at the time, or were you relying on the windows scheduled task to launch it?

 

Always running, the service is set to start automatically and does.



#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 12:52 AM

Ok then let's look at the server log. thanks.



#23 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 01:00 AM

Ok then let's look at the server log. thanks.

 

These are three logs recorded today from when schedules should have/were kicked off.

Attached Files



#24 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 01:25 AM

Is it possible you've managed to launch multiple simultaneous instances of the server?

2019-10-09 10:54:08.887 Error Main: Error in appHost.Init
	*** Error Report ***
	Version: 4.2.1.0
	Command line: C:\Users\AdminDRL\AppData\Roaming\Emby-Server\system\EmbyServer.dll -service -noautorunwebapp
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/AdminDRL/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	Processor count: 4
	Program data path: C:\Users\AdminDRL\AppData\Roaming\Emby-Server
	Application directory: C:\Users\AdminDRL\AppData\Roaming\Emby-Server\system
	SQLitePCL.pretty.SQLiteException: Busy: database is locked - PRAGMA journal_mode

When you see this error:

Busy: database is locked

9 times out of 10 that is the reason why.



#25 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 09:27 AM

Is it possible you've managed to launch multiple simultaneous instances of the server?

 

I highly doubt it. There are two entries for Emby Server as a service in the service list but one is disabled and not running since very early in v3 (if not towards the end of v2). There is only one instance running.



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 12:48 PM

Are you sure it's not also running as an application at the same time?

#27 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 01:02 PM

Are you sure it's not also running as an application at the same time?

 

Positive, I'm not even logged in to the server at the time it is scheduled to run.



#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 01:03 PM

So then those are logs of the server trying to start when it is already running.

So those are ok, but there should be another main server log with more activity.

#29 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 01:55 PM

So then those are logs of the server trying to start when it is already running.

So those are ok, but there should be another main server log with more activity.

 

Do you have a file name I can lookup? The log page in the web console is filled with examples that I posted.



#30 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 02:03 PM

Just the most recently modified log file. But since the recording was X number of hours ago, you'd have to grab all of the ones that were modified during that time.



#31 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 02:10 PM

Just the most recently modified log file. But since the recording was X number of hours ago, you'd have to grab all of the ones that were modified during that time.

 

The two most recent log files attached, changed only to obfuscate personal information.

Attached Files



#32 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 10 October 2019 - 02:32 PM

What recording was supposed to happen, and when?



#33 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 02:49 PM

What recording was supposed to happen, and when?

 

Night Court at 10:54am (11am program start). Attached are 2 more for a random I scheduled just to see what would happen and it *DID* record. Bewitched at 11:24am (11:30am program start). The only difference that I can see is that I left the web browser window open?

Attached Files



#34 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 04:32 PM

What recording was supposed to happen, and when?

 

So I don't know what the hell has happened here, but I just had another pre-scheduled one-off recording succeed. I have deleted ALL of the scheduled Series Recordings but they are still in the Scheduled Tasks list on the server itself. I am going to delete those by hand, reboot the server, then re-schedule the series and see what happens...



#35 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 10 October 2019 - 10:26 PM

What recording was supposed to happen, and when?

 

So there was a recording that was supposed to go off at 7:02pm tonight but it failed. My suspicion was that the original Series Schedules were done before the version update from 3 to 4 and maybe something got tweaked in the translation. My reasoning behind this was that the test recordings I had run this afternoon scheduled and ran as expected, so I deleted all of the original series schedules and reset them. The first of those is what failed. 

 

I have deleted the Series Schedules again and set individual record for the next couple episodes available and the next one runs at 5am Pacific tomorrow morning. In the mean time, attached is the most recent log.



#36 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 11 October 2019 - 12:15 AM

Did you forget to attach the log?



#37 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 11 October 2019 - 12:20 AM

Did you forget to attach the log?

 

I know I clipped it to the response, I must not have given it enough time to process before hitting submit.

Attached Files



#38 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 11 October 2019 - 12:22 AM

Perhaps try rebooting your HDHR. It is returning an error when trying to open a stream from it.



#39 Theodore OFFLINE  

Theodore

    Advanced Member

  • Members
  • 157 posts
  • Local time: 09:40 AM

Posted 13 October 2019 - 01:35 PM

Perhaps try rebooting your HDHR. It is returning an error when trying to open a stream from it.

 

I rebooted the HDHR and no joy. I had a show scheduled to record at 5pm last night (log extract attached). But to add insult to injury, after failing to record Emby then removed *ALL* scheduled shows from the upcoming registry.

Attached Files



#40 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140182 posts
  • Local time: 11:40 AM

Posted 13 October 2019 - 08:21 PM

Your tuner is still returning a 503 unavailable error so something is wrong there:

Http response 503 from http://192.168.1.33:5004/auto/v10.1

To see what i mean, try putting this url into a browser to reproduce it without even using Emby:

http://192.168.1.33:5004/auto/v10.1






Also tagged with one or more of these keywords: dvr, live tv, recording

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users