Jump to content
alleyes

ANSWERED CC always on

Recommended Posts

alleyes

I have a Tizen TV with latest firmware. I had installed the USB version of Emby Theater (1.0.62), and just now upgraded to the latest (the TV won't tell me the new version!), but there is still a problem with media that has embedded closed captions.

 

The closed captions are always being displayed on the TV, even after turning subtitles/cc off. If I turn on subtitles/cc inside Emby, I get new subtitles (created by Emby) and also the embedded cc subtitles. When playing the media on the web interface, they do *not* appear. The PC version of Theater also does not show them. Only the TV!

 

Info:

Samsung UN65RU8000FXZA FLAT 65'' 4K UHD 8 Series Smart TV (2019)

65" TV details:
MN : UN65RU8000FXZA
PD : --/--/----
SN : 08953CCM303711T
FW : T-MSMAKUC-1065.0
FC : SWU-OU_T-MSMAKUC_1065_190416
MI : T-MSMAKUC
LS : US
DI : BDCD36PSYNY6A
MA : 24FCE5505C0C
SC : 10101_AC1_Z_Z

Emby Server 4.2.1.0

 

The only web media info I found was "stats for nerds", and I posted the screen cap here.

 

Using VLC, you can see the embedded subtitles and closed captions in a screen cap.

 

Also, I have a screen cap of what the embedded cc looks like in VLC.

 

Edit: The app version is 1.0.64. I attached the media info screen cap from the web interface. Also, I tried turning off subtitles when watching the video by navigating to the CC dialog and selecting no subtitles. "No subtitles" is also selected on the screen for the show where Resume/Play from beginning shows.

 

Edit: It just occurred to me that I could use my phone to take a photo of the tv screen for any useful information, if anyone wants it.

 

Edit: Added photos of tv. The photos showing subtitles are the *embedded* closed captions. Added the emby server logs.

 

Edit: Added screen cap of vlc media info, showing Stream 6 is where the unwanted subtitles are coming from.

post-476061-0-56660200-1567702580_thumb.png

post-476061-0-72898000-1567702712_thumb.png

post-476061-0-31758100-1567702727_thumb.png

post-476061-0-16346800-1567706741_thumb.png

post-476061-0-17766100-1567709858_thumb.jpg

post-476061-0-98200700-1567709864_thumb.jpg

post-476061-0-54968300-1567709876_thumb.jpg

post-476061-0-04968800-1567709886_thumb.jpg

emby-logs.txt

emby-logs2.txt

post-476061-0-37420800-1567716469_thumb.jpg

Edited by alleyes

Share this post


Link to post
Share on other sites
FrostByte

Could you screen shot the media info from the server?  It's at the bottom of the details page for every movie.  That will show us all the subtitles, etc

 

FYI the newest version 1.0.64 of the app should show the version in settings now.

Edited by FrostByte

Share this post


Link to post
Share on other sites
Luke

How did you try turning off subtitles in Emby?

Share this post


Link to post
Share on other sites
alleyes

Could you screen shot the media info from the server?  It's at the bottom of the details page for every movie.  That will show us all the subtitles, etc

 

FYI the newest version 1.0.64 of the app should show the version in settings now.

Thanks! I added the screen cap and see that the app version is 1.0.64

Share this post


Link to post
Share on other sites
alleyes

Can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !

I added some photos showing the various screens on the tv, and the emby logs. Thank you!

Share this post


Link to post
Share on other sites
alleyes

Can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !

I also added another emby server log file that may have some better clues. AFAIK, I have no way to get logs from the tv app.

Share this post


Link to post
Share on other sites
Luke

The ffmpeg log you provided is from Firefox. Was there one from Tizen?

Share this post


Link to post
Share on other sites
alleyes

The ffmpeg log you provided is from Firefox. Was there one from Tizen?

Not that I see. There are a bunch of HTTP GET records in the first log file (embyserver.txt). The second log file is ffmpeg-remux-a46fbf8a-bb5c-42ca-84ff-93ea9a3b0dfd_1.txt. I grepped the log directory for "tizen" and the only hits come from the first log file (the HTTP requests).

Share this post


Link to post
Share on other sites
Luke

Ok it may be direct playing. @@SamES will look at this. Thanks.

Share this post


Link to post
Share on other sites
FrostByte

SFN says it's direct streaming/converting the AC3 track to AAC

Edited by FrostByte

Share this post


Link to post
Share on other sites
alleyes

SFN says it's direct streaming/converting the AC3 track to AAC

I don't know what SFN means. I did more testing on the tv and watched the log directory. There were updates to the main log file, but no new remux log files. I found some more info about the media file from vlc. I added a screen cap to the main post, but I want to point out that Stream 3 has the captions that are showing up even when no subtitles is selected.post-476061-0-40767300-1567716411_thumb.jpg

Share this post


Link to post
Share on other sites
SamES

From the screenshots, these are closed-captions, not subs.  Is this is a live tv recording you made?  

Share this post


Link to post
Share on other sites
alleyes

From the screenshots, these are closed-captions, not subs.  Is this is a live tv recording you made?  

It could have been made from a live recording. But the closed-captions can be turned off with vlc and they don't show when using emby/firefox.

Share this post


Link to post
Share on other sites
SamES

Not that I see. There are a bunch of HTTP GET records in the first log file (embyserver.txt). The second log file is ffmpeg-remux-a46fbf8a-bb5c-42ca-84ff-93ea9a3b0dfd_1.txt. I grepped the log directory for "tizen" and the only hits come from the first log file (the HTTP requests).

 

 

Don't search for Tizen,  The remux/transcode log will look like this at the top (but with your TV model number).  It should say Samsung SmartTV

 

App: Emby Theater 1.0.65

Samsung SmartTV (QA75Q9FAM)

Share this post


Link to post
Share on other sites
FrostByte

Can you turn off or select individual CC files?  They are't even listed in the media info or the drop down box within the app.

Share this post


Link to post
Share on other sites
alleyes

Can you turn off or select individual CC files?  They are't even listed in the media info or the drop down box within the app.

Thanks, but what does it mean to "turn off or select individual CC files"? The app apparently does not recognize the cc streams in the media file; VLC certainly does. And the other Emby clients (Emby PC Theater, Firefox/Emby) do not have this problem. So why the Tizen app?

 

A simple workaround would be great, but I don't see one yet. Re-encoding every media file to remove specific streams is not simple. In any case this is a problem that needs fixing, or I am doing something wrong (always a possibility).

Share this post


Link to post
Share on other sites
FrostByte

Thanks, but what does it mean to "turn off or select individual CC files"? The app apparently does not recognize the cc streams in the media file; VLC certainly does. And the other Emby clients (Emby PC Theater, Firefox/Emby) do not have this problem. So why the Tizen app?

 

A simple workaround would be great, but I don't see one yet. Re-encoding every media file to remove specific streams is not simple. In any case this is a problem that needs fixing, or I am doing something wrong (always a possibility).

 

yes, I'm agreeing with you.  It looks like there is no way to turn off the CC files.  That comment should have been directed toward to SamES

  • Like 1

Share this post


Link to post
Share on other sites
alleyes

Can you please check that closed captions are turned off in the TV setup menu under accessibility?

 

https://www.tomsguide.com/us/samsung-tv-settings-guide,review-4663-16.html

Ok, that was it! It was set on with defaults. Turning it off makes the captions disappear, but the subtitles can be turned on by the media player (they display the same info, but differently). I'm relieved that it was my own ignorance and not a problem. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites
SamES

Great, thanks for the feedback.  That setting is the master switch for closed captions, so even though the app doesn't see the closed captions, if they're in the file they can be enabled by the user.  We can override this to force them off, but since the user already controls them from the TV settings, it makes sense to me to keep it consistent and not override it with the app.

  • Like 1

Share this post


Link to post
Share on other sites
FrostByte

Great, thanks for the feedback.  That setting is the master switch for closed captions, so even though the app doesn't see the closed captions, if they're in the file they can be enabled by the user.  We can override this to force them off, but since the user already controls them from the TV settings, it makes sense to me to keep it consistent and not override it with the app.

 

 

The only issue I see is that if you wanted CCs there is no way of selecting which one you want to play if more than one.  It seems like it's automatically playing the last one in the file

Edited by FrostByte

Share this post


Link to post
Share on other sites
SamES

I must admit I’ve never really played with cc as for a while they didn’t work at all. Not sure how the TV decides which one to play

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...