Jump to content


Photo

Can we get the emby package in a different extension so we can manually install it using the applications window?


  • Please log in to reply
34 replies to this topic

#1 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 11:35 AM

5d5d643728478_tnas_emby.jpg

This is the error I get when trying to install emby manually. Apparently, terramaster does not like the extension for the package.

It looks like it wants the file in a TKP or BZ2 extension. Can we get the file redistributed on the emby downloads page with one of those extensions? I wouldn't remove the tar.xz file however, as people may still need to side load.

Thanks!

**I currently have it side loaded to 4.2.1, but it crashes a lot and I have to log back into the tnas through putty and start the service again. would much rather be able to do all of it from the dashboard.


Edited by zachattack83, 21 August 2019 - 11:49 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 11:52 AM

See my comments in this topic about it:
https://emby.media/c...view=getnewpost
Thanks.

#3 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 11:58 AM

I already have. I did not see anything that resulted in success there. Renaming the files does not work. It gives a different error when renaming. Most likeliy because the xz has a different compression than the bz2. Much like renaming a zip to a rar in windows.

5d5d69c3a3844_tnas_emby2.jpg

The last comment I seen in regards to the issue was your statement that you did hear back from terramaster about the newer version,  That was about 13 days ago. They don't seem to be very fast about updating it.

I was looking into converting the file using:

gunzip < file.gz | bzip2 > file.bz2

but, my terramaster says it can't work this magic, and its the only access i have to a linux system.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:06 PM

But in that topic we left it as an open issue. That is still where things stand. Thanks.



#5 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:07 PM

Ah gotcha.

Can I ask what is preventing you guys from just recompressing it in the other format?



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:08 PM

We don't even know if that's what needs to be done yet. We will get to it. Thank you for your patience.



#7 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:11 PM

Have you guys tried it? Because the manual app installer seems to accept it, where it wasn't before.

5d5d6ce312a1b_tnas_emby3.jpg

5d5d6cebbd960_tnas_emby.jpg

 

It clearly does not like the xz extension, but seems to accept the bz2 one.


I'm sorry if I am being  a paint about this, but my side load keeps randomly crashing, and its getting really annoying. At least once a day, I am having to go in and manually start the service again.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:16 PM

It is assigned to one of our developers. You can always install from the Terramaster app store. Thanks.



#9 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:18 PM

Yes, I have installed it from the app store, but that version does not have a working cinema mode. And this makes the $120 I spent on Emby Premiere seem like a waste of money.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:20 PM

Yes, I have installed it from the app store, but that version does not have a working cinema mode. And this makes the $120 I spent on Emby Premiere seem like a waste of money.

Why do you feel that way? if the version numbers are the same then it is the exact same thing.



#11 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:22 PM

The version numbers are not the same.

5d5d6f9c6f711_tnas_emby4.jpg

This is the version currently in the app store. And the cinema mode does not work on it. However, 4.2.1, it works fine. Which is what I have side loaded, and is what keeps crashing each day.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:24 PM

Ok yes that's an older version, i didn't realize they hadn't released 4.2.1 yet. Yes we will get to looking at the side-load package. For now instead of reinstalling i would just report your issue so that we can look at it. Thanks.



#13 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:26 PM

I'm not sure what to report exactly. The only information I have is that it crashes each day, and I have to manually go restart it. Not sure why its crashing or anything. Just happens.

Also, with the speed in which terra master updates emby in their store, I would like to believe that the manually installed app option is the better way for most emby users to keep their emby up to date. If you guys can get that squared away, users would not have to side load, and they wouldn't have to wait months for terramaster to get off their butts and put the newest versions in the store.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:28 PM

Please report by providing the information requested in how to report a problem. Thanks.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:28 PM

hey wouldn't have to wait months for terramaster to get off their butts and put the newest versions in the store.

 

While you wait, please also send them an email at 

support@terra-master.com

In the past, having users email them has helped to spur them into action to release the update.



#16 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:38 PM

I've already sent them an email asking them to speed this process up. That was a couple months ago. Doesn't seem to matter to them. Not sure if they have a very limited staff, or if they just don't feel like allotting many resources to handle the emby stuff, but either way. They're slow. Too slow. Thats why I think the manual installation option is the best for emby users. You guys should get a team focusing on that. Then we don't have to worry as much about terramaster's slow process.

I'm guessing my crash issue falls under general issues, but I have no logs to post in regards to it.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:46 PM

Why do you not have log files?



#18 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 12:50 PM

what log files would I have? Its the service stopping on the system, not sure if emby would have any logs regarding that? I only see logs about video playback.

.



#19 zachattack83 OFFLINE  

zachattack83

    Advanced Member

  • Members
  • 80 posts
  • Local time: 09:01 AM

Posted 21 August 2019 - 01:15 PM

I have a hardware detection log, and an embyserver.txt log



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135879 posts
  • Local time: 09:01 AM

Posted 22 August 2019 - 01:12 AM

I have a hardware detection log, and an embyserver.txt log

 

Can you please attach those? thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users