Jump to content

Subtitles always show


stefgun

Recommended Posts

Hi there!

 

After the problems with changing audio track, I noticed another severe problem with Emby on my webOS-TV: I cannot turn off subtitles. I can SELECT them to be turned off (and also have turned them off generally in the options), but they still show, which is super-annoying, because I usually don't want them to.

 

So far, this has happened with all files I tried that have subtitles. Webplayer does not have this issue.

 

My TV:

LG 55LB674V-ZB

webOS version 1.4.0-2529 (the TV says it is on the latest version)

firmware is 5.5.70

Emby app is 1.0.17

Emby server is 4.2.1.0

 

Log:

embyserver.txt

 

File info from webplayer for one of the files I have tested:

ffmpeg-remux-1039c54a-c02b-4269-8349-a90ac979c1a2_1.txt

 

Link to post
Share on other sites

Hi, this is due to a defect in older versions of WebOS where it always plays subtitles no matter what we tell it to do. We're going to have to resolve this by forcing a conversion on the server to strip out the subtitles. We just haven't gotten to this yet but we'll get it into an upcoming update. Thanks.

Link to post
Share on other sites

If it is just remuxing then the load won't be too heavy. It is what it is. Not much choice unless we just want to live with users constantly reporting this.

Link to post
Share on other sites
  • 10 months later...

Hi,

Any updates on this issue? Any workaround we could test?

When playing any Live TV channel whose stream includes subtitles, they are always shown by the LG Web player and can't be disabled. No matter what configuration you select on client or server side.

LG Smart TV (55EG920V-ZA)
webOS TV 2.2.3-1353 (beehive-biscayne)
Emby Theater 1.0.24
Emby Server Versión 4.5.0.13 beta

 

Thank you.

Edited by Slennox
Link to post
Share on other sites

Not yet, sorry. We have to build a special hack for this and we haven't completed it yet. Hopefully soon. Thanks for the feedback.

  • Like 2
Link to post
Share on other sites
  • 3 months later...
19 hours ago, rrserver said:

I have this prloblem too,i can fix now this??

Hi, we're still looking into it. It's a hack workaround we're going to have to incorporate in order to skirt around a WebOS defect.

Link to post
Share on other sites
  • 5 months later...
MAX92
On 8/15/2019 at 8:31 PM, Luke said:

Hi, this is due to a defect in older versions of WebOS where it always plays subtitles no matter what we tell it to do. We're going to have to resolve this by forcing a conversion on the server to strip out the subtitles. We just haven't gotten to this yet but we'll get it into an upcoming update. Thanks.

How is it possible to force conversion on the server ? 

 

Link to post
Share on other sites
Luke
5 hours ago, MAX92 said:

How is it possible to force conversion on the server ? 

 

Hi, not yet. We still need to add the workaround that I mentioned above.

  • Sad 1
Link to post
Share on other sites
  • 5 months later...
cetrespeo

Same problem here with an up to date LG Smart TV (OLED55E9PLA)

Any solution ?

I cannot use the emby premiere if i always get those anoying captions....

Link to post
Share on other sites
Luke
1 hour ago, cetrespeo said:

Same problem here with an up to date LG Smart TV (OLED55E9PLA)

Any solution ?

I cannot use the emby premiere if i always get those anoying captions....

Hi, we still have not yet added this workaround to the server but it is on our to do list. Thanks.

Link to post
Share on other sites
On 9/14/2021 at 11:19 PM, Luke said:

Hi, we still have not yet added this workaround to the server but it is on our to do list. Thanks.

Many thanks for your answer, Luke.

Your product is really good, but is useless with the captions always on, and as far as I see you have been for years like that.

I hope you reconsider investing some resources in finding the solution so you allow LG users to use your nice software. Meanwhile I will step down from your premiere service until solved. 

Please let us posted of any change.

Best

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...