Jump to content
Samua

Emby app en TV it is automatically deleted

Recommended Posts

Samua

Hi, I have a Samsung JS8500 TV (I think it's from 2015). I install the Emby app from a USB downloaded from the indicated site (https://emby.media/community/index.php?/topic/74969-samsung-tizen-smarttv-2015-present-install-from-usb/) and it installs me correctly. I enter the app, configure it and it works perfectly. But ... when I turn the TV off and on again, there is a moment when the TV starts up, when a very fast message appears at the bottom of the screen (which does not give me time to read), after which, the Emby app is deleted and disappears.

 

Does anyone know what happens and how can I prevent it from being eliminated?

 

Thank you.

Share this post


Link to post
Share on other sites
SamES

Can you take a video of it with your phone and see if you can determine what the message says?

Share this post


Link to post
Share on other sites
Samua

The following message comes out:

Update apps
It's time to update your applications and services.

(0 installed. 1 expired applications will be deleted).

Wait while the expired apps are deleted.

 

The installed app is the last one of the previous link.

Add that my country is Spain, in case it had something to do.

Thank you.

Share this post


Link to post
Share on other sites
Samua
Hello, I have done the SmartHub reset and it remains the same, when I turn on the TV again it eliminates it.

Any new ideas?

Share this post


Link to post
Share on other sites
Luke

Hi, I'm not sure yet as we haven't seen this happen before. @@CBers, does this happen to you?

Share this post


Link to post
Share on other sites
Samua

It is very rare. Ultimate firmware 1530, smart hub reset, ... and keep deleting it. The strange thing is that it says that the app has expired, it is as if in the app it put an expiration date somewhere and that it is lower than today and that is why I deleted it.

Let's see if someone who understands says something else, why install the app every time you have to use it and also configure it is not a plan.

Share this post


Link to post
Share on other sites
FrostByte

This seems to be an issue with a lot of J-series TVs from all the links I'm reading

 

I found a coders site where someone got around the issue by blocking a bunch of domains if you want to try that

 

https://www.bountysource.com/issues/24160636-support-for-2015-tvs

 

If you search for "delete" the third hit user "xgoldpt" lists in step 2 the domains he blocked.  I wouldn't bother with the netflix domains if you use that, maybe just the Samsung ones.

Share this post


Link to post
Share on other sites
FrostByte

I bet you wouldn't have this issue if you could install from the store, it appears to only happen when installing from SDK, USB, etc

Edited by FrostByte

Share this post


Link to post
Share on other sites
Samua

This seems to be an issue with a lot of J-series TVs from all the links I'm reading

 

I found a coders site where someone got around the issue by blocking a bunch of domains if you want to try that

 

https://www.bountysource.com/issues/24160636-support-for-2015-tvs

 

If you search for "delete" the third hit user "xgoldpt" lists in step 2 the domains he blocked.  I wouldn't bother with the netflix domains if you use that, maybe just the Samsung ones.

Thanks for the information, but I see that it blocks domains up to netflix so I'm afraid to do all that.

 

I begin to think that Sansumg does not allow you to enter apps that are not in your store and everything that is installed from the outside marks it in some way and eliminates it at startup.

Share this post


Link to post
Share on other sites
Samua

I bet you wouldn't have this issue if you could install from the store, it appears to only happen when installing from SDK, USB, etc

It's what I think too, but it has a solution?

Share this post


Link to post
Share on other sites
FrostByte

Thanks for the information, but I see that it blocks domains up to netflix so I'm afraid to do all that.

 

I begin to think that Sansumg does not allow you to enter apps that are not in your store and everything that is installed from the outside marks it in some way and eliminates it at startup.

 

 

Yes, I would skip everything that has "netflix" in it.  You should be safe blocking the Samsung ones.  If not, then you could always unblock them.  It would be interesting to see if it actually worked though

Share this post


Link to post
Share on other sites
FrostByte

How many apps do you have on your Samsung?  You could change the region of your TV to UK and install from the store.  Unfortunately, you would lose any local apps you have and be restricted to the ones in the UK store then

Share this post


Link to post
Share on other sites
Samua

How many apps do you have on your Samsung?  You could change the region of your TV to UK and install from the store.  Unfortunately, you would lose any local apps you have and be restricted to the ones in the UK store then

I thought about the post

 

https://emby.media/community/index.php?/topic/74969-samsung-tizen-smarttv-2015-present-install-from-usb/

 

That the app should work on all TVs from 2015 or is it only for specific regions?

Share this post


Link to post
Share on other sites
Luke

It should work on all Tizen TV's.

Share this post


Link to post
Share on other sites
Samua

It should work on all Tizen TV's.

It works ... but it's removed hahaha.

 

The issue is knowing why it eliminates it and how to fix it, and it seems to be complicated. Maybe the developers of the app are the ones who could contribute something.

Share this post


Link to post
Share on other sites
FrostByte

It works ... but it's removed hahaha.

 

The issue is knowing why it eliminates it and how to fix it, and it seems to be complicated. Maybe the developers of the app are the ones who could contribute something.

 

Luke is a developer :)  SamES is the other

Share this post


Link to post
Share on other sites
Luke

We are the developers of the app. I'm just saying that we've never heard of this before so right now we don't know the reason this is happening.

Share this post


Link to post
Share on other sites
Samua

We are the developers of the app. I'm just saying that we've never heard of this before so right now we don't know the reason this is happening.

Ah, I didn't know the developers were around. Thanks for the app, it's a great job, although it doesn't work for me as it should, possibly not for the app but for Samsung.

 

As said, see if you can help me.

Share this post


Link to post
Share on other sites
FrostByte

Hopefully @@CBers or someone else with a 2015 can share their experience.  I've been looking at recent threads and can't find anyone else with a 2015 that has posted recently. 

 

Meanwhile I'll keep looking on the developer sites.  The folks at the tech support sites will make you want to poke your eyes out :)

Share this post


Link to post
Share on other sites
Samua

Hopefully @@CBers or someone else with a 2015 can share their experience.  I've been looking at recent threads and can't find anyone else with a 2015 that has posted recently. 

 

Meanwhile I'll keep looking on the developer sites.  The folks at the tech support sites will make you want to poke your eyes out :)

Yes, I'm afraid I've given them a good headache hahaha. To see what they say.

Share this post


Link to post
Share on other sites
FrostByte

@SamES lives down under so we can ask him also when he awakes

Edited by FrostByte

Share this post


Link to post
Share on other sites
FrostByte

Yes, I'm afraid I've given them a good headache hahaha. To see what they say.

 

Oh, I'm sure the first thing they would say is that only apps installed from the store are supported.  They don't deal with the development side of the company at all and if it's not on their script you might as well just start pulling your hair out.

Share this post


Link to post
Share on other sites
FrostByte

Just another link saying 2015 will delete developer apps on reboot.

 

https://developer.samsung.com/forum/thread/tizen-2015-app-deleted-after-reboot/201/306906?boardName=SDK&listLines=30&startId=zzzzz~&startPage=71&curPage=73

 

I wonder if it would help if you put your TV into developer mode, or can 2015s even be put into developer mode

Edited by FrostByte
  • Like 1

Share this post


Link to post
Share on other sites
SamES

OK, I'm awake now. :lol:

 

So if you've made sure you have the latest version of the firmware, and the most recent version of the USB app then that's a good step.

 

I've never owned a J series but I'm certain this series initially supported Orsay and Tizen apps, it was a bit of a hybrid.  I think eventually they dropped the Orsay support, but I get the impression that the Tizen OS that was left is not as fully featured as the later models.   For example, the development emulator is quite different on the 2015 models from what I can recall.

 

When the USB app is created, it is possible that it does have an expiry built in.  Can you double check that the date and time is set correctly on the TV (from inside the TV settings menu).  Do you set this manually or automatically?  If this is wrong it would cause a problem.   

 

Are you able to get it to load and run at all?  We do have our own reminder notice to update the app after a period, but we don't delete the app.  If you can get the app to run at all, do you receive any 'Emby' styled messages about updating?  We hope to release a version of this every month or two. It will be interesting to see if the next version causes you the same problem.

 

Other than that I don't really have any new ideas.  I keep my eyes out in case there is any related issues for USB loading on this model

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...