Jump to content

Library scan - System.IO.IOException: Permission denied


webpostkastl
 Share

Go to solution Solved by FrostByte,

Recommended Posts

webpostkastl

Hi,

 

I'm fighting with a really strange permission issue since one of the last server updates

 

in folder /volume3/AUDIO/ALEX there are almost 300 sub folders (each a different artist) again with multiple subfolders (1 per album)

 

e.g.

/volume3/AUDIO/ALEX

     /THE DARKNESS

          /[2012] Hot Cakes

               - 01. Every Inch of You.mp3

               - 02. Nothin's Gonna Stop Us.mp3

               - etc.

 

although everything was working fine before I can now only see 7 albums in my "ALEX" library - for all other folders I'm getting a System.IO.IOException: Permission denied error (see log below)

I already tried to completely remove emby server and installed it from scratch - even tried with a different user name and gave read/write permission for user embysvr to folder AUDIO

but that didn't work out either

 

any idea why the library scan is only working for 7 random folders but not for the rest?

 

(I'm running emby server on a Synology Diskstation)

 

e.g.

 

2019-07-29 19:26:17.696 Error LibraryMonitor: Error watching path: /volume3/AUDIO/ALEX
    *** Error Report ***
    Version: 4.2.0.40
    Command line: /volume1/@appstore/EmbyServer/releases/4.2.0.40/EmbyServer.dll -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -ffdetect /var/packages/EmbyServer/target/ffmpeg/bin/ffdetect -restartexitcode 121 -ignore_vaapi_enabled_flag
    Operating system: Unix 3.10.105.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: True
    Runtime: file:///volume1/@appstore/EmbyServer/3rdparty/netcore/2.2.1/runtime/System.Private.CoreLib.dll
    Processor count: 4
    Program data path: /var/packages/EmbyServer/target/var
    Application directory: /volume1/@appstore/EmbyServer/releases/4.2.0.40
    System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path '/volume3/AUDIO/ALEX/THE DARKNESS' is denied. ---> System.IO.IOException: Permission denied
       --- End of inner exception stack trace ---
       at System.IO.Enumeration.FileSystemEnumerator`1.CreateDirectoryHandle(String path, Boolean ignoreNotFound)
       at System.IO.Enumeration.FileSystemEnumerator`1..ctor(String directory, EnumerationOptions options)
       at System.IO.Enumeration.FileSystemEnumerable`1..ctor(String directory, FindTransform transform, EnumerationOptions options)
       at System.IO.Enumeration.FileSystemEnumerableFactory.UserDirectories(String directory, String expression, EnumerationOptions options)
       at System.IO.Directory.InternalEnumeratePaths(String path, String searchPattern, SearchTarget searchTarget, EnumerationOptions options)
       at System.IO.FileSystemWatcher.RunningInstance.AddDirectoryWatchUnlocked(WatchedDirectory parent, String directoryName) in /source/corefx/src/System.IO.FileSystem.Watcher/src/System/IO/FileSystemWatcher.Linux.cs:line 438
       at System.IO.FileSystemWatcher.RunningInstance.AddDirectoryWatchUnlocked(WatchedDirectory parent, String directoryName) in /source/corefx/src/System.IO.FileSystem.Watcher/src/System/IO/FileSystemWatcher.Linux.cs:line 445
       at System.IO.FileSystemWatcher.RunningInstance..ctor(FileSystemWatcher watcher, SafeFileHandle inotifyHandle, String directoryPath, Boolean includeSubdirectories, NotifyFilters notifyFilters, CancellationToken cancellationToken) in /source/corefx/src/System.IO.FileSystem.Watcher/src/System/IO/FileSystemWatcher.Linux.cs:line 306
       at System.IO.FileSystemWatcher.StartRaisingEvents() in /source/corefx/src/System.IO.FileSystem.Watcher/src/System/IO/FileSystemWatcher.Linux.cs:line 77
       at Emby.Server.Implementations.IO.LibraryMonitor.<>c__DisplayClass37_0.<StartWatchingPath>b__0()
    Source: System.IO.FileSystem
    TargetSite: IntPtr CreateDirectoryHandle(System.String, Boolean)
    InnerException: System.IO.IOException: Permission denied
    Source:
    TargetSite:

Link to comment
Share on other sites

Hi, the above error is for the real-time monitor. It won't affect the library scan, although if you have general permissions problems then that might. Have you checked the permissions of all sub-folders?

 

@@FrostByte may have some tips on this.

Link to comment
Share on other sites

webpostkastl

thanks a lot Luke & FrostByte. It was indeed a permissions issue. Don't know why, but somehow my embysvr user lost its permissions for almost all of my subfolders although I didn't change anything. Maybe this was due to some emby server updates? Nevertheless, everything is working fine again. Thanks for your help!!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...