Jump to content

Ass direct play


Recommended Posts

Hi, so today I updated the emby app on my LG tv and now it always wants to transcode the media, whereas before the update it was direct play even with ass subtitles. Thai feature was of the things I chose Emby. Please help resolve this issue, or does anyone know how to rollback to previous emby version on lg tv? Thanks

Link to post
Share on other sites

Sure, sorry for the missing infos.
Server version: 4.1.1.0

 

Before when I launched a media with ass subtitle, in most cases it could direct play and play the subtitle separately (even though it wasn propperly shown on the screen, for instance some texts were missing when there are multiple texts in one frame, but that was okay for me because the direct play is more important to me)

It only happens on the tv so I cant make screentshots, hopefully I described the issue properly.

Link to post
Share on other sites

Actually according to this we were initially direct playing, then automatically switched to transcoding when the video player reported an error with the file. It also could have been the ass subtitle renderer reporting an error with the subtitles.

Link to post
Share on other sites

But the same media was direct playing a day before. Nothing changed except that i upgraded the app on the lg tv. How could it be resolved then?

Link to post
Share on other sites

I downloaded the sample mkv in post #9.

For me, it plays first 2 seconds and Emby App restarts.

 

I have the latest Emby App on my LG OLED55B8 TV.

 

Workaround: Use mkvextract to extract the ASS subtitle from the mkv into an external ASS file and keep it the in same folder as the mkv file.

Then, select that ASS file from the Emby App GUI and the whole Episode plays fine.

Link to post
Share on other sites
CrappyUserName
Workaround: Use mkvextract to extract the ASS subtitle from the mkv into an external ASS file and keep it the in same folder as the mkv file.

Then, select that ASS file from the Emby App GUI and the whole Episode plays fine.

 

I'm having an issue playing files with ASS subtitles since the latest update. But mine are already stored as a separate file in the same folder. I tried putting the movie and subtitle file into it's own folder but that did not solve the issue.

Link to post
Share on other sites
admirdante

I am having THIS EXACT problem too. I had an older version of Emby on my TV and server. Updated the app and wanted to watch anime and it just works for a few seconds and then it throws me back to the main screen. Tried movies and whatnot and that works just fine.

 

BUT, i mainly use Emby to watch anime and your new udpate broke it completely. Either just upload the old version or fix this ASAP. It beats the whole point of having it on my TV.

Link to post
Share on other sites
sfboender

Same issue, even with roll back of emby server it wont work. The LG tv app is the root cause as I have two LG oleds C8 and C7 and the one I updated with the new version isnt working anymore.

Link to post
Share on other sites

Same issue, even with roll back of emby server it wont work. The LG tv app is the root cause as I have two LG oleds C8 and C7 and the one I updated with the new version isnt working anymore.

 

Well I wouldn't roll the server back unless you have a complete backup handy. The previous version of the server will not be able to handle the database changes made by 4.2.

Link to post
Share on other sites
sfboender

Well I wouldn't roll the server back unless you have a complete backup handy. The previous version of the server will not be able to handle the database changes made by 4.2.

 

I did fortunately but again it isn't the server which is causing the issue but the TV app from LG which is unable to handle the subs. Even with the MKV extraction tooling it wont play longer than 3 seconds.

 

Any idea what the ETA will be for the TV update and is there a way we can send logs from the LG TV app?

Link to post
Share on other sites
sfboender

Yes we're able to reproduce this. Thanks for the feedback.

Any idea what we should do? just wait for the new update and if so any idea when this will be pushed?

Link to post
Share on other sites
  • 2 weeks later...

I have been having the same issue. most of all my files are anime with subs. any idea if you can push the old app through LG if we can fix it server side?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...