Jump to content


Photo

Nvidia GPU transcoding comparison data.


  • Please log in to reply
10 replies to this topic

#1 lightsout OFFLINE  

lightsout

    Advanced Member

  • Members
  • 825 posts
  • Local time: 07:26 AM

Posted 16 July 2019 - 11:02 AM

This is not my work but it is very impressive and what I think many of us have been looking for. 

 

Your going to want to use the site on a desktop browser, was too much for my phone to handle.

 

https://www.elpamsof...are-Transcoding


  • pir8radio, arche and ShadowKindjal like this

#2 Jdiesel OFFLINE  

Jdiesel

    Advanced Member

  • Members
  • 2936 posts
  • Local time: 08:26 AM
  • LocationRegina, SK

Posted 16 July 2019 - 11:27 AM

Thanks for the link. This somewhat confirms what I suspected, minimal difference between a 1060 and a top end Titan V. There seems to be a greater improvement between the 2060 and 2080's but I'm not familiar enough with Nvidia's architecture and pricing to determine if that is a fair comparison.

 

Seems like for the average person running a "personal" server a 1060 is a pretty sweet spot for price/performance.


Edited by Jdiesel, 16 July 2019 - 11:33 AM.


#3 lightsout OFFLINE  

lightsout

    Advanced Member

  • Members
  • 825 posts
  • Local time: 07:26 AM

Posted 16 July 2019 - 03:43 PM

Thanks for the link. This somewhat confirms what I suspected, minimal difference between a 1060 and a top end Titan V. There seems to be a greater improvement between the 2060 and 2080's but I'm not familiar enough with Nvidia's architecture and pricing to determine if that is a fair comparison.

 

Seems like for the average person running a "personal" server a 1060 is a pretty sweet spot for price/performance.

Indeed it looks like the 1060 6gb is the sweet spot. I have a 1050ti in mine and it does plenty for one family. Probably overkill.



#4 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 16 July 2019 - 04:29 PM

I just pulled my 1060 out my server. It's not working the way I want.
  • Sammy likes this

#5 lightsout OFFLINE  

lightsout

    Advanced Member

  • Members
  • 825 posts
  • Local time: 07:26 AM

Posted 16 July 2019 - 04:38 PM

I just pulled my 1060 out my server. It's not working the way I want.

I saw your post in the other thread, something is up with it. Never seen those issues your having, seems like we would see more threads with similar problems if GPU transcoding wasn't stable.



#6 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 16 July 2019 - 05:00 PM

I saw your post in the other thread, something is up with it. Never seen those issues your having, seems like we would see more threads with similar problems if GPU transcoding wasn't stable.


No, it's ffmpeg, more specifically CUDA. I was testing specific things that I know can be troublesome. As mpv runs on ffmpeg, I was comparing things from experience. The issues I was having, everyone would have them. It mostly centers around HDR stuff. CUDA has issues with a bunch of that stuff. I've been through all of that with the mpv devs. It just needs to mature and be refined. NVDEC can be handled differently to circumvent the CUDA issues. These guys will get there, but right now my Threadripper kicks the 1060's ass. So it's just a problem I don't need to deal with :)

Edited by Doofus, 16 July 2019 - 05:01 PM.


#7 lightsout OFFLINE  

lightsout

    Advanced Member

  • Members
  • 825 posts
  • Local time: 07:26 AM

Posted 16 July 2019 - 06:25 PM

No, it's ffmpeg, more specifically CUDA. I was testing specific things that I know can be troublesome. As mpv runs on ffmpeg, I was comparing things from experience. The issues I was having, everyone would have them. It mostly centers around HDR stuff. CUDA has issues with a bunch of that stuff. I've been through all of that with the mpv devs. It just needs to mature and be refined. NVDEC can be handled differently to circumvent the CUDA issues. These guys will get there, but right now my Threadripper kicks the 1060's ass. So it's just a problem I don't need to deal with :)

You go all software? What threadripper cpu do you have?



#8 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 16 July 2019 - 06:47 PM

You go all software? What threadripper cpu do you have?


Yup! A 1920X. I was interested in trying the 1060 because I thought it would be faster than the TR, but it's pretty close to being exactly the same. There's 5-10 fps difference (sometimes). I even threw subs burn in at the 1060. It was the same as the TR. And no issues with decoding anything, unlike the 1060. Even if I unlocked the 1060, the TR can still do more than it.

#9 lightsout OFFLINE  

lightsout

    Advanced Member

  • Members
  • 825 posts
  • Local time: 07:26 AM

Posted 16 July 2019 - 06:55 PM

Yup! A 1920X. I was interested in trying the 1060 because I thought it would be faster than the TR, but it's pretty close to being exactly the same. There's 5-10 fps difference (sometimes). I even threw subs burn in at the 1060. It was the same as the TR. And no issues with decoding anything, unlike the 1060. Even if I unlocked the 1060, the TR can still do more than it.

You talking about one stream or total? I have a 1st gen Ryzen in my sever (1800x) one of the reasons I wanted a gpu was to free up the CPU for the stuff. I noticed sometimes when transcoding hammering the CPU emby dashboard would be unresponsive. I haven't experienced the issues you had but I don't do much HDR, actually when I do it through Emby the few UHD remuxes I have HDR is hit and miss, even when its not cropped. But I am talking about on my Shield.



#10 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 16 July 2019 - 07:01 PM

You talking about one stream or total? I have a 1st gen Ryzen in my sever (1800x) one of the reasons I wanted a gpu was to free up the CPU for the stuff. I noticed sometimes when transcoding hammering the CPU emby dashboard would be unresponsive. I haven't experienced the issues you had but I don't do much HDR, actually when I do it through Emby the few UHD remuxes I have HDR is hit and miss, even when its not cropped. But I am talking about on my Shield.


I posted about it.

https://emby.media/c...s/?fromsearch=1

#11 Sammy OFFLINE  

Sammy

    Beta Tester

  • Members
  • 3583 posts
  • Local time: 07:26 AM

Posted 14 November 2019 - 09:41 AM

I just pulled my 1060 out my server. It's not working the way I want.

I saw your post in the other thread, something is up with it. Never seen those issues your having, seems like we would see more threads with similar problems if GPU transcoding wasn't stable.

I've been using it for a couple of months now without issue. I just did that hack yesterday to allow more streams and that seems to be working just fine as well. Maybe it was a hardware incompatibility with your motherboard?

EDIT

OOPs TL/DR. Now I did.

LOL

Sent from my SM-G960U1 using Tapatalk

Edited by Sammy, 14 November 2019 - 09:45 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users