Jump to content


Photo

Backup and restore problem

server backup and restore plugin

Best Answer Happy2Play , 18 July 2019 - 10:40 PM

Yes. Library Scan ran overnight and completed, but no playstate information was retained. Restore process brought over Library Structure and Users. But, all Users settings were not retained. All Library Access defaulted to ALL and all Passwords were empty. Nice that I could move my COLLECTIONS folder over and have all of it work properly. I can use the TRAKT plugin to push my playstate information out and then import it back in after the creation of new Library.db file. I just wondered if creating a new clean install with a new Library.db file was the issue.

 

I just nuked a portable and did a restore and it restored all library restrictions, passwords and played statuses for the users.
 
Windows
4.1.1.0 server
1.3.4.0 plugin
 
Have you tried just restoring the "Users and User Playstate, Favorites, Resume, etc." again?

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 hearingaid OFFLINE  

hearingaid

    Newbie

  • Members
  • 1 posts
  • Local time: 09:07 PM

Posted 02 July 2019 - 04:57 PM

I have never installed the backup and restore plugin before as I am new to emby.

I have acquired a newer computer and wanted to migrate over to the better system.

I installed the plugin and it said that the trial was over. within 5 minutes of install.

 

How is this possible.

 

Please help.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135740 posts
  • Local time: 09:07 PM

Posted 03 July 2019 - 01:03 PM

Hi there, sorry for the confusion. We need to adjust the message. The plugin requires Emby Premiere. We also have manual backup instructions here:

https://github.com/M...iki/wiki/Backup

 

Please let us know if this helps. thanks.



#3 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 702 posts
  • Local time: 08:07 PM

Posted 18 July 2019 - 08:22 PM

Hi there, sorry for the confusion. We need to adjust the message. The plugin requires Emby Premiere. We also have manual backup instructions here:

https://github.com/M...iki/wiki/Backup

 

Please let us know if this helps. thanks.

@Luke

 

Does User playstate (Watched, Resume, Favorites) information transfer over if you use the Backup Plugin to save your Configuration and User information and Restore to a completely new installation and Library.db file? I am guessing that User playstate information only transfers over if you are restoring from an installation that already has an existing Library.db file to work from. Just wanted to double check before attempting a Backup and completely clean install using the Backup Plugin. 



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15287 posts
  • Local time: 06:07 PM
  • LocationWashington State

Posted 18 July 2019 - 08:42 PM

Everything that has providerids (TMDB, IMDB, TVDB ids) will transfer over whether the item still exists or not.  If those ids do not exist then all statuses for the item will be lost as it will have a new uniqueid in the new database.



#5 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 702 posts
  • Local time: 08:07 PM

Posted 18 July 2019 - 09:30 PM

Everything that has providerids (TMDB, IMDB, TVDB ids) will transfer over whether the item still exists or not.  If those ids do not exist then all statuses for the item will be lost as it will have a new uniqueid in the new database.

 

All TV and Movie items have NFO files stored locally in folder and have Provider IDs. I tried an initial test by restoring from the last configuration backup to a new fresh install of Emby and let it build out a new Library.db file. My Library Structure and Users moved over as expected with restore. I backed up my Collections folder and moved it into the new install and it worked. But, all Library Access settings for Users were not honored and no playstate information was restored for any users. I am guessing that if a new Library.db file is created that new uniqueID's are created, even if the corresponding media have Provider ID's stored in their local NFO files.


Edited by blade005, 18 July 2019 - 09:33 PM.


#6 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15287 posts
  • Local time: 06:07 PM
  • LocationWashington State

Posted 18 July 2019 - 09:37 PM

You will probably have to post a server log with the restore process.  So a initial library scan has finished?



#7 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 702 posts
  • Local time: 08:07 PM

Posted 18 July 2019 - 10:14 PM

You will probably have to post a server log with the restore process.  So a initial library scan has finished?

 

Yes. Library Scan ran overnight and completed, but no playstate information was retained. Restore process brought over Library Structure and Users. But, all Users settings were not retained. All Library Access defaulted to ALL and all Passwords were empty. Nice that I could move my COLLECTIONS folder over and have all of it work properly. I can use the TRAKT plugin to push my playstate information out and then import it back in after the creation of new Library.db file. I just wondered if creating a new clean install with a new Library.db file was the issue.



#8 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15287 posts
  • Local time: 06:07 PM
  • LocationWashington State

Posted 18 July 2019 - 10:40 PM   Best Answer

Yes. Library Scan ran overnight and completed, but no playstate information was retained. Restore process brought over Library Structure and Users. But, all Users settings were not retained. All Library Access defaulted to ALL and all Passwords were empty. Nice that I could move my COLLECTIONS folder over and have all of it work properly. I can use the TRAKT plugin to push my playstate information out and then import it back in after the creation of new Library.db file. I just wondered if creating a new clean install with a new Library.db file was the issue.

 

I just nuked a portable and did a restore and it restored all library restrictions, passwords and played statuses for the users.
 
Windows
4.1.1.0 server
1.3.4.0 plugin
 
Have you tried just restoring the "Users and User Playstate, Favorites, Resume, etc." again?


Edited by Happy2Play, 18 July 2019 - 10:41 PM.

  • ebr and blade005 like this

#9 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 702 posts
  • Local time: 08:07 PM

Posted 18 July 2019 - 11:26 PM

I just nuked a portable and did a restore and it restored all library restrictions, passwords and played statuses for the users.
 
Windows
4.1.1.0 server
1.3.4.0 plugin
 
Have you tried just restoring the "Users and User Playstate, Favorites, Resume, etc." again?

 

Good call. Just restored Users and User Playstate from previous install backup again and this time all is well. Sometimes the simplest (try again) is the best option. Many thanks, my friend!!







Also tagged with one or more of these keywords: server backup and restore, plugin

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users