Jump to content
Sign in to follow this  
JohnnyM

Roku Transcoding Turn off Subtitles

Recommended Posts

JohnnyM

I have finally saw why the Roku app is trans-coding some of my movies. It doesn't like subtitles.

 

OK I go to the detail screen of the movie in the Roku app and for subtitles I select NONE but the movie is still trans-coding when played. I quit the movie, quit the Roku Emby app and go back into the detail screen and find that subtitles are defaulted as on not NONE.

 

1. How do I get the subtitle default back to NONE?

 

2. How are other members dealing with subtitles or are they just letting it transcode.

 

JohnnyM

 

 

Share this post


Link to post
Share on other sites
Luke

Hi there, did  you explore the server dashboard during playback to learn why it was still transcoding?

Share this post


Link to post
Share on other sites
ebr

This depends on your subtitle format.  Text-based subs should not cause transcoding on the Roku.

Share this post


Link to post
Share on other sites
speechles

Try changing them to "Off (None)" as the video plays. Press down to open the OSD and use the subtitle icon (looks like a box with a triangle under it). That should let you turn them off if they are on during playback.

Share this post


Link to post
Share on other sites
JohnnyM

I have attached a image of the Dashboard giving the reason for the transcoding.

 

5d1a669b8ace2_Dashboard.jpg

 

I am attaching a screen capture of the web client since I can't screen capture from the TV.

5d1a670e60b53_MainMoviePage.jpg

 

I'll try your suggestion speechles but I want to PERMANENTLY change it of NONE.

Share this post


Link to post
Share on other sites
ebr

 

I'll try your suggestion speechles but I want to PERMANENTLY change it of NONE.

 

Click your user icon in that screenshot you posted and then select "subtitles" and set your "subtitle mode" to "No subtitles" 

Share this post


Link to post
Share on other sites
JohnnyM

speechles

 

I did as you said by turning them off as they played and it DID permanently change it to OFF.

 

Thank you

Share this post


Link to post
Share on other sites
JohnnyM

EBR I tried your using the web client to turn the sub off and that worked also. It also changed the transcoding to direct stream when I did it.

 

Thanks

 

Now why does ROKU using a streaming stick or ROKU premiere like DVDSubs.

 

JohnnyM

Share this post


Link to post
Share on other sites
JohnnyM

Just looked at the subs using MediaInfo and VOBSUBs are picture based, Not text like I thought.

 

More exploring.

 

JohnnyM

Share this post


Link to post
Share on other sites
ebr

Just looked at the subs using MediaInfo and VOBSUBs are picture based, Not text like I thought.

 

Correct and devices like the Roku do not support them because they only exist on disc based media and these devices have never seen and never will see a disc  :P.

Share this post


Link to post
Share on other sites
speechles

speechles

 

I did as you said by turning them off as they played and it DID permanently change it to OFF.

 

Thank you

 

I just submitted some fixes for the detail screen and video player not respecting turning off subtitles and sometimes not turning them on.

 

References:

Fix #508: [DetailsView] Fix Subtitles

Fix #509: [VideoPlayer] Fix Subtitles (allow them to turn off ALL THE TIME)

Edited by speechles
  • Like 1

Share this post


Link to post
Share on other sites
JohnnyM

Thanks all for the help

 

JohnnyM

Share this post


Link to post
Share on other sites
Marc_G

Interestingly, I just encountered a subtitle problem on my Roku that may be what is described a few posts above.

 

When I ripped the title (Bugs Bunny in "Bugs and Thugs") I didn't realize I needed to explicitly tell MKVToolNix to create the default flag and set it to "No." It seems that lack of a default flag is interpreted as YES and the subtitles are shown.

 

Anyway, given the subs were showing when playing on Roku, I went back to the metadata screen and changed it from showing VobSub english subs to OFF. It still played the subtitles though... I found no way to turn them off.

 

Later, I went in and used the header editor in Toolnix to create the default flag and set it to No. Presumably this turns them off.

Share this post


Link to post
Share on other sites
Luke

 

 

It seems that lack of a default flag is interpreted as YES and the subtitles are shown.

 

Not necessarily. Have you explored the subtitle preferences for your Emby user?

Share this post


Link to post
Share on other sites
speechles

Do you have a sample of that file you can share on dropbox/google-drive or similar?

 

You should always be able to turn off the subtitles. If that isn't happening something is wrong. There was recent work done in the area of subtitles to make them able to turn off correctly.

 

Are you using the Emby beta of the Roku app? This should have the fixes already. I do not think these fixes have been pushed to the store version of the app yet since that requires Roku approval.

Share this post


Link to post
Share on other sites
ebr

The latest subtitle fixes are in the released app so we'll need to investigate exactly what is happening here.

Share this post


Link to post
Share on other sites
blade005

I just submitted some fixes for the detail screen and video player not respecting turning off subtitles and sometimes not turning them on.

 

@@speechles

 

Emby Roku Version 3.0 - Build 175

 

Is there a technical reason that the Emby Roku app turns Close Captioning field to OFF for any video that does not have Forced Flag on for subtitles? If a video has Forced Subtitles then it changes to ALWAYS ON while playing. That makes sense so that any forced subtitle dialogue is displayed without intervention.

 

I tend to keep Closed Captioning set to ON REPLAY in the Roku global menu settings in order to use the REPLAY button to rewind and turn Close Captioning on for missed dialogue on any app I may be streaming from. It would be nice if the Emby Roku app honored that global CC setting for any video that does not have a FORCED subtitle flag set. Currently, it always sets CC to OFF and I have to remember to set it to ON REPLAY if I want to use this feature in Emby. And if I forget and exit Emby, my global CC setting is now set to OFF, which I normally realize when I am in another app and attempt to use it and nothing appears. Simple to adjust with asterisk button in apps that honor this, but unfortunately Prime Video does not and requires that you stop stream, exit app and return to Home Screen to adjust and then return to Prime Video. Not a big deal. Just wondering if there was a way for global CC settings to be honored unless FORCED subtitles require a change.

Edited by blade005

Share this post


Link to post
Share on other sites
ebr

Is there a technical reason that the Emby Roku app turns Close Captioning field to OFF for any video that does not have Forced Flag on for subtitles? If a video has Forced Subtitles then it changes to ALWAYS ON while playing. That makes sense so that any forced subtitle dialogue is displayed without intervention.

 

That is not exactly what it is doing.  It is turning the option "on" whenever our logic says that you want subtitles displayed.  We have to do this in order for them to be seen.

 

An improvement we could probably make would be to restore the previous setting after playback instead of just turning them off - assuming we can capture what the setting was.

Share this post


Link to post
Share on other sites
blade005

That is not exactly what it is doing.  It is turning the option "on" whenever our logic says that you want subtitles displayed.  We have to do this in order for them to be seen.

 

An improvement we could probably make would be to restore the previous setting after playback instead of just turning them off - assuming we can capture what the setting was.

I understand.

 

It would be nice if ON REPLAY would be honored in Emby unless the video has a FORCED subtitle flag set. But, I can set it to ON REPLAY once video is streaming and it works nicely with embedded or external SRT subtitles. It would be an improvement if global CC settings could be restored to what they were as you entered the Roku app upon exit.

 

Thank you for the explanation.

Share this post


Link to post
Share on other sites
blade005

An improvement we could probably make would be to restore the previous setting after playback instead of just turning them off - assuming we can capture what the setting was.

 

Perhaps an option in SETTINGS of Emby Roku app to select CC default of OFF, ON ALWAYS, ON REPLAY or ON MUTE unless the media has a FORCED flag set and then ON ALWAYS would be set. That would allow an ON REPLAY option by default that would remain after exiting the app. It would also keep whatever Subtitle settings you have set in Web UI separate.

 

Just a thought.

Share this post


Link to post
Share on other sites
ebr

Whether subs are forced or not is irrelevant in this situation.  If you select subs to be shown either manually through the interface or by default based on your subtitle settings, then we need to turn the CC feature on the device to "on" during that playback.  Whether the subs in question are forced or not makes no difference.  We don't need an app setting for this. Just a little more intelligence in the app.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...