Jump to content

Question about my folder permissions


UnderMiner
 Share

Go to solution Solved by UnderMiner,

Recommended Posts

UnderMiner

Hello,

 

Yesterday we began to receive an error oops something went wrong, document not found on the stack.

We have an Apple TV 4k and we can play recorded TV shows but if we play a movie from our library we receive the error immediately after selecting play for the movie.

 

I'm not 100% certain but I believe that the only changes to the system that we applied were some Windows 10 updates on the Emby server. The two updates were:

  • KB4465065: Intel microcode updates
  • June 11, 2019—KB4503327 (OS Build 17763.557)

I placed the logs in the following location.

https://1drv.ms/u/s!AnfmLnbQksWOhysE7PwqLMPXo24y?e=zcnEcv

 

Let me know if there are any steps I can take to fix the error.

Thanks.

Link to comment
Share on other sites

Permissions problem?

	System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path 'N:\Movies - Variety\Animated\DVDs\VeggieTales Pistachio (2010)' is denied.

Link to comment
Share on other sites

UnderMiner

Hello ebr,

I tested the example you provide using Emby on a windows computer and there are no issues with playback.

I understand that there may be an issue in the log and I will check the file permissions but at the moment, it plays correctly in Emby on windows.

Link to comment
Share on other sites

I tested the example you provide using Emby on a windows computer and there are no issues with playback.

 

Using what app and what playback method?

Link to comment
Share on other sites

Hello,

I used the Emby App on a windows 10 computer.

 

You mean Emby Theater Desktop?

 

if so, it may have direct played your item which would mean the server wouldn't have needed direct access to  your media.

 

In any case, the first step will be to fix those permission problems for the server. Once that is done, if the problem still exists, please post a new log.

 

Thanks.

Link to comment
Share on other sites

  • Solution
UnderMiner

Hello,

Windows update found and applied one more .NET update and I rebooted the server.

I allowed full privileges to all library folders for the local administrator account (was previously read, write, and execute).

The playback on Apple TV is now corrected.

Thanks.

 

For reference, I was using windows PC software Emby Theater version 1.1.253.0 with 22.2MB

Edited by UnderMiner
  • Like 1
Link to comment
Share on other sites

UnderMiner

Hello,

 

The system has been operating with no issues for a few days but today the same error returned oops something went wrong, document not found on the stack.

I was playing a local national news recording when we received the error. I updated link above with the current Emby log files, let me know if there are any troubleshooting steps.

Thanks.

Link to comment
Share on other sites

UnderMiner

Hello,

At the time that I posted, the ffmpeg log was more than 24 hours older than the other logs.

We watched programs after the initial post and I added the current ffmpeg log to the same location.

Link to comment
Share on other sites

UnderMiner

Thanks for following up Luke.

I have not had a repeat of this issue, everything has been working as expected.

Always looking forward to the next updates.

Keep up the great work.

Link to comment
Share on other sites

UnderMiner

Hello Luke,

Perhaps we celebrated too soon because the same error returned today "oops something went wrong, document not found on the stack".

 

The Apple TV app was updated and I tried the new music features for a few moments and a brief error appeared as well as an incorrect menu (it was for another folder but I was still in the music folder, a little strange).

 

When we went back to watch a movie, we received the error "oops something went wrong, document not found on the stack".

 

I refreshed the logs in the following location to help with troubleshooting.

https://1drv.ms/f/s!AnfmLnbQksWOhysE7PwqLMPXo24y

Link to comment
Share on other sites

Hello Luke,

Perhaps we celebrated too soon because the same error returned today "oops something went wrong, document not found on the stack".

 

The Apple TV app was updated and I tried the new music features for a few moments and a brief error appeared as well as an incorrect menu (it was for another folder but I was still in the music folder, a little strange).

 

When we went back to watch a movie, we received the error "oops something went wrong, document not found on the stack".

 

I refreshed the logs in the following location to help with troubleshooting.

https://1drv.ms/f/s!AnfmLnbQksWOhysE7PwqLMPXo24y

 

@@corey are you able to reproduce?

Link to comment
Share on other sites

corey

I wonder if it's an issue of missing metadata. We'd have to see that in order to troubleshoot further.

Link to comment
Share on other sites

UnderMiner

Hello,

A quick update to let you know that the system has worked without a repeat incident for the week.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...