Jump to content


Photo

Can't figure out how to direct play with Emby Theater


  • Please log in to reply
5 replies to this topic

#1 Mike-G OFFLINE  

Mike-G

    Member

  • Members
  • 24 posts
  • Local time: 07:27 AM

Posted 25 June 2019 - 08:37 AM

I've been using Plex and wanted to give Emby a try.  My test scenario is for a movie I encoded to H.264 with the server and desktop versions of Plex & Emby on the same Windows 10 box.  Plex Media Player plays this movie by direct play, but Emby transcodes when using Emby Theater (but direct streams when using Firefox).  I can't figure out why.

 

I believe I've set all settings in Emby Theater to auto, and from what I've read in the forums, I thought that would minimize any reason to transcode.  But I'm confused why a browser-based playback wouldn't need to transcode, but a desktop-playback would.

 

I suppose I could play it in the browser to avoid the transcoding, but I don't want to use the browser for playback and I'm doing my best to do an apples-to-apples comparison to Plex.

 

Can anyone point me in the right direction so I can get Emby Theater to play without transcoding? (I haven't signed up for Emby Premiere at this point, if that makes a difference)

 

5d12133211b30_Emby.png


Edited by Mike-G, 25 June 2019 - 08:57 AM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:27 AM

Posted 25 June 2019 - 09:06 AM

Hi.  Did you click the "i" on that panel to learn why it is transcoding?

 

Best guess will be that the bitrate is too high for the setting in the app.



#3 Mike-G OFFLINE  

Mike-G

    Member

  • Members
  • 24 posts
  • Local time: 07:27 AM

Posted 25 June 2019 - 09:34 AM

Hi.  Did you click the "i" on that panel to learn why it is transcoding?

 

Best guess will be that the bitrate is too high for the setting in the app.

Thanks for the response.

 

Yes, it said bitrate was too high.  So I did a couple tweaks in Theater in playback settings:

 

(1) Changed Home Network Quality to 4k - 120 Mbps (internet quality is auto).  This did nothing; still transcoding.

(2) Changed Internet Quality to 4k - 120 Mbps (home network quality is auto).  This eliminated the transcoding and the window now shows "Direct playing"

 

So this is a good step forward.  But I have two concerns:

 

1. Why isn't "auto" taking care of this automatically? Why do I need to set an explicit quality?  The fact that it starts out in direct play and then switches to transcoding when both quality settings are in "auto" is strange, to me.

2. The theater player and server are on the same box.  I would think this should be detected as "home network", not "internet", so I'm confused why adjusting network quality affects transcoding and adjusting home network quality doesn't.

 

Are there some other settings I need to adjust, perhaps? Maybe the way I told Theater about my server causes Theater to think it's not part of the home network? (but that still doesn't explain why the auto setting seems to not be detecting transcode not necessary).

 

Any thoughts?


Edited by Mike-G, 25 June 2019 - 09:37 AM.


#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:27 AM

Posted 25 June 2019 - 10:02 AM

Exactly how did you "tell theater about your server"?

 

You are correct that the app believed it was on a remote connection.

 

What is the bitrate of the item in question?



#5 Mike-G OFFLINE  

Mike-G

    Member

  • Members
  • 24 posts
  • Local time: 07:27 AM

Posted 25 June 2019 - 11:57 AM

I re-added the server and now I get direct play with both settings on "auto".  I must have set up something wrong/partially and re-adding fixed it.

 

The overall bitrate of the movie (from MediaInfo) is 13.8 Mbps.



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:27 AM

Posted 25 June 2019 - 11:58 AM

Okay, glad you got it working properly.

 

Thanks and welcome!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users