Jump to content
BP_Tec

Network Path Problems

Recommended Posts

BP_Tec

Hi all,

 

So I'm having problems setting up my library on only one of my drives. I know this is probably a permissions issue, but I just cant figure out what the problem is.

 

5d0f60c22bf6e_Screenshotfrom201906231220

 

These are my media locations, the first two work fine, but the USER_DATA drive does not, and i get the error.

All locations are accessible from my Linux machine.

 

/home/alex/Videos

/mnt/BACKUP_DRIVE/media

/mnt/USER_DATA/media1

 

/home/user/Videos

drwxr-xr-x 6 alex alex 4096 Jun 22 15:43 Videos :D

 

/mnt/BACKUP_DRIVE/media

drwxr-xr-x  2 root    root    4096 Jun 23 12:23 media :D

 

/mnt/USER_DATA/media1

drwxr-xr-x   2 root    root     4096 Jun 23 12:23 media1 :angry:

 

 

If i change the owner and group on media1 to alex, i still get the same issue

chown alex:alex media1

 

drwxr-xr-x   2 alex alex  4096 Jun 23 12:23 media1
 

If I change it to emby:emby still exactly the same error. I also restated the emby service after each attempt.

So any help at all in understanding what is happening here would be awesome.

 

 

Kind regards

 

 

Share this post


Link to post
Share on other sites
mastrmind11

are all 3 shared the same way?  mounted the same way?  network shares?

Share this post


Link to post
Share on other sites
BP_Tec

Ah I think i discovered the issue...

 

on the root of /mnt/USER_DATA there was no (group) and (all) permissions set.

drwx------ 16 alex alex 4096 Jun 23 12:23 USER_DATA

 

After trying different restrictive permissions, it looks like at the very minimum, the permissions need to be 755

/mnt/USER_DATA/media1

 

Could someone confirm that the emby account lies under the (all) group?

Share this post


Link to post
Share on other sites
BP_Tec

Actually those permission needed to be applied to /mnt/USER_DATA

Share this post


Link to post
Share on other sites
Luke

Did that resolve it?

Share this post


Link to post
Share on other sites
BP_Tec

Yes it all worked out, thanks :-)

Share this post


Link to post
Share on other sites
BP_Tec

What are the minimum permissions that the emby group requires for a library it to operate?

It obviously needs read permission, but does it also need write and execute?

 

I'm guessing write is only needed if it need to store metadata or thumbs...

Edited by BP_Tec

Share this post


Link to post
Share on other sites
Luke

I'm guessing write is only needed if it need to store metadata or thumbs...

 

Correct. If not, then read is enough. Please let us know if this helps. Thanks.

Share this post


Link to post
Share on other sites
BP_Tec

When I remove the execute permission I cant play my files, so I guess it needs at a minimum, Read and Execute ?

Edited by BP_Tec

Share this post


Link to post
Share on other sites
Q-Droid

The emby user needs access to every directory along the path to the final directory with the media files. This comes up often enough that it should be included in bold letters in a sticky.

 

All directories need 'r' and 'x' in order for any user to access them.

 

If you want emby to be able to create files in the directory then write permissions are also needed in the specific directory. This could be done with ownership or group access or everyone access.

Edited by Q-Droid

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...