Jump to content


Photo

Emby on FreeNAS guide?


  • Please log in to reply
8 replies to this topic

#1 Misinthe OFFLINE  

Misinthe

    Advanced Member

  • Members
  • 69 posts
  • Local time: 04:29 PM

Posted 22 June 2019 - 06:08 PM

Hello everyone, I am having a really rough time trying to decipher how to install Emby on FreeNAS and get it up and running. I installed the pulgin but I don't know how to set it up for it to work. Does anyone know about a guide on how to do this? I've been trying for about 3 days now and I have no idea what's going on. Thank you. 



#2 busthead OFFLINE  

busthead

    Newbie

  • Members
  • 1 posts
  • Local time: 01:29 PM

Posted 22 June 2019 - 09:23 PM

I also installed the Emby plugin today and cannot connect to the web interface: http://192.168.0.236:8096

 

I'm able to ssh to the host. How do I begin to troubleshoot?

 

FreeBSD emby_1 11.1-STABLE FreeBSD 11.1-STABLE #0 r321665+79f05c3dd3d(HEAD): Wed Jan 23 12:02:34 EST 2019     root@nemesis.tn.ixsystems.com:/freenas-releng/freenas/_BE/objs/freenas-releng/freenas/_BE/os/sys/FreeNAS.amd64  amd64

 

Thx



#3 Misinthe OFFLINE  

Misinthe

    Advanced Member

  • Members
  • 69 posts
  • Local time: 04:29 PM

Posted 22 June 2019 - 09:26 PM

I also installed the Emby plugin today and cannot connect to the web interface: http://192.168.0.236:8096

I'm able to ssh to the host. How do I begin to troubleshoot?

FreeBSD emby_1 11.1-STABLE FreeBSD 11.1-STABLE #0 r321665+79f05c3dd3d(HEAD): Wed Jan 23 12:02:34 EST 2019 root@nemesis.tn.ixsystems.com:/freenas-releng/freenas/_BE/objs/freenas-releng/freenas/_BE/os/sys/FreeNAS.amd64 amd64

Thx


I had set static IP for my emby server and apparently it didn't like it, so it worked once I turned DHCP on. Another thing that happened to me before was that I had to whitelist it on my antivirus. I was going to use FreeNAS but it's such a problem to set up and very little documentation out there. I'm switching my machine to windows tomorrow and saving me all the trouble.

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131280 posts
  • Local time: 04:29 PM

Posted 23 June 2019 - 04:19 PM

@Misinthe, can you please describe the issue that you're having? thanks !



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131280 posts
  • Local time: 04:29 PM

Posted 23 June 2019 - 04:20 PM

I also installed the Emby plugin today and cannot connect to the web interface: http://192.168.0.236:8096

 

I'm able to ssh to the host. How do I begin to troubleshoot?

 

FreeBSD emby_1 11.1-STABLE FreeBSD 11.1-STABLE #0 r321665+79f05c3dd3d(HEAD): Wed Jan 23 12:02:34 EST 2019     root@nemesis.tn.ixsystems.com:/freenas-releng/freenas/_BE/objs/freenas-releng/freenas/_BE/os/sys/FreeNAS.amd64  amd64

 

Thx

 

Hi, how did you install? Our latest versions require FreeBSD 11.2+.



#6 Misinthe OFFLINE  

Misinthe

    Advanced Member

  • Members
  • 69 posts
  • Local time: 04:29 PM

Posted 23 June 2019 - 04:22 PM

@Misinthe, can you please describe the issue that you're having? thanks !


I wasn't able to set the libraries. I don't know how the jails have to be set up so Emby was never able to recognize them. I switch to Windows now but I'm having all different problems with that now.

#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131280 posts
  • Local time: 04:29 PM

Posted 23 June 2019 - 06:31 PM

I wasn't able to set the libraries. I don't know how the jails have to be set up so Emby was never able to recognize them. I switch to Windows now but I'm having all different problems with that now.

 

Ok, we'll answer your question about that in your original topic:

https://emby.media/c...iew=getlastpost

 

Thanks.



#8 MRobi ONLINE  

MRobi

    Advanced Member

  • Members
  • 248 posts
  • Local time: 05:29 PM

Posted 24 June 2019 - 11:50 AM

I wasn't able to set the libraries. I don't know how the jails have to be set up so Emby was never able to recognize them. I switch to Windows now but I'm having all different problems with that now.

In FreeNAS you have to mount your storage to your jail and then set permissions to allow Emby to have access to your mounted storage. There's not much documentation on how to do that on the Emby side of things since that's standard jail management through FreeNAS and there are multiple ways to achieve the same result. There's a bit of a learning curve with FreeNAS as a whole and it's not the OS for everyone.



#9 Misinthe OFFLINE  

Misinthe

    Advanced Member

  • Members
  • 69 posts
  • Local time: 04:29 PM

Posted 24 June 2019 - 08:05 PM

In FreeNAS you have to mount your storage to your jail and then set permissions to allow Emby to have access to your mounted storage. There's not much documentation on how to do that on the Emby side of things since that's standard jail management through FreeNAS and there are multiple ways to achieve the same result. There's a bit of a learning curve with FreeNAS as a whole and it's not the OS for everyone.

 

I thought I did what I needed to do, I did research online and saw their videos and everything but couldn't get it to work. In the end I decided to just run it on Windows 10 Pro so I can remote into it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users