Jump to content


Photo

Stopping idle chromecasts


  • Please log in to reply
5 replies to this topic

#1 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 746 posts
  • Local time: 12:17 AM

Posted 12 June 2019 - 02:24 AM

I have recently expanded my servers user list, and the new users have begun to use chromecast devices controlled via the web app on chrome. Since then I have noticed several times they have paused playback and disconnected from chrome, but the chromecast stays connected with a stream running but paused.

The odd part is unlike every other stream I have seen show up on the server dash, the chromecast doesn't have server side controls like play/pause, message, and stop. Why is this? Is there no good way to stop this stream as a server owner?

Even if I restart the server, the chromecast just re-connects and sits idle again. The only way I have found to get it to disconnect is to disable the user that is streaming through it, then re-enabled that account after a couple min.

Edited by darkassassin07, 12 June 2019 - 02:33 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138272 posts
  • Local time: 03:17 AM

Posted 12 June 2019 - 02:26 AM

 

 

the chromecast doesn't have server side controls like play/pause, message, and stop. Why is this?

 

Only the casting app can communicate with it.



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138272 posts
  • Local time: 03:17 AM

Posted 12 June 2019 - 02:27 AM

If they idle it without any playback, it will eventually go away, but perhaps not if they pause playback. That's something that can be looked at. Thanks.



#4 darkassassin07 ONLINE  

darkassassin07

    Advanced Member

  • Members
  • 746 posts
  • Local time: 12:17 AM

Posted 12 June 2019 - 02:35 AM

Alright, thanks for the response.
I've asked them to be more careful to not leave idle devices, but will definitely be looking for a solution for when it does happen.

Added a related feat request:
https://emby.media/c...view=getnewpost

#5 cptlores OFFLINE  

cptlores

    Advanced Member

  • Members
  • 44 posts
  • Local time: 09:17 AM

Posted 14 June 2019 - 05:01 PM

Got the same problem, sessions stays in a semi active state (even after a Emby server restart) until the user starts playing something else. Only way I have found is to go into "Devices" section and delete the device that is holding the session active.



#6 pwhodges OFFLINE  

pwhodges

    Advanced Member

  • Members
  • 267 posts
  • Local time: 08:17 AM
  • LocationOxford, UK

Posted 14 June 2019 - 06:02 PM

Before I learnt how to turn the Chromecast off properly from Emby, it sometimes stayed in a state that prevented the TV switching to another imput until I removed it...


Edited by pwhodges, 14 June 2019 - 06:03 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users