Jump to content

Multi-segment episode NFO issue ?


duffydake
 Share

Recommended Posts

duffydake

Hi,

I have an issue with all (aside one) my multi-segment episodes, their are displayed as one episode.
I use the format : tvshow - S01E01-E02(-E0N) - title.ext

OS : debian stretch Linux 5.0.21 x86_64
Emby version: 4.1.1.0


In the database data field of MediaItems does not contains IndexNumberEnd except for the working one.
The only difference I see is the Kodi NFO (I didn't see something helpful in debug log btw), I forgot to set details of the second segment.

Not working : (Two or more root)

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<episodedetails>
    <title>TITLE EP 1</title>
    <showtitle>TVSHOW</showtitle>
    <season>1</season>
    <episode>1</episode>
...
<episodedetails>
<episodedetails>
    <title>TITLE EP 2</title>
    <showtitle>TVSHOW</showtitle>
    <season>1</season>
    <episode>2</episode>
...
<episodedetails>

Working one : (Only one root)

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<episodedetails>
    <title>TITLE EP 1</title>
    <showtitle>TVSHOW</showtitle>
    <season>1</season>
    <episode>1</episode>
...
<episodedetails>

Usually XML parser doesn't like multiple root (and their are right), so it's maybe the issue here but unfortunately it's how Kodi wants them.
Do you support Kodi multi-segment NFO ? (or maybe it's something else ?)

Note : I just discover Emby and aside this small detail I really enjoy it. You are doing a great job.

Edited by duffydake
Link to comment
Share on other sites

Hi, yes for now you'd have to edit the metadata manually for this one. We haven't implemented this feature of nfo files yet. Thanks for the feedback.

Link to comment
Share on other sites

duffydake

I may be wrong but it looks like a bug, the fact that the NFO is not supported should not change the behavior of parsing E.g S01E01-E02 from the filename and set IndexNumberEnd accordingly.
I mean with the supported NFO multi-segment works, IndexNumberEnd and the episode on the web app is shown as "1-2" but with the unsupported only  "1" is displayed and IndexNumberEnd is not set.

Link to comment
Share on other sites

duffydake

Yes of course.
I will try to find a workaround like run a script on library scan start/end event, or stop emby and "fix" the database, ...
If I end-up with something not too dirty I will share it here but it will be Linux only.

EDIT :

I get it now, the NFO is parsed but since there is no <episodenumberend> "custom tag" only the first segment number is set.
Indeed it's a choice (trust the NFO more than the filename) and not a bug.

 

You just need to add <episodenumberend> in your multi-segment NFO, Kodi parser doesn't mind of unknown tags, its not a problem.

This thread is a duplicate of Reading and writing of nfo for multi-part episodes is wrong
Sorry about that I should have searched more.
 

Thanks for your reply.

Edited by duffydake
Link to comment
Share on other sites

laie_techie

XML does NOT allow for multiple roots; I don't know how we would store information about multiple episodes in the same NFO file.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...