Jump to content


Photo

OPPO 203 no longer showing as DLNA option


  • Please log in to reply
7 replies to this topic

#1 Galvaneal OFFLINE  

Galvaneal

    Member

  • Members
  • 18 posts
  • Local time: 01:59 AM

Posted 21 May 2019 - 05:43 PM

Hi

 

First off my apologies if i am asking noob questions, i am a noob when it comes to this  :)

 

The setup i use is:

Synology 1817+ as NAS with emby server installed there

OPPO UDP 203 as media player

LG C7 OLED

Browsing through the OPPO is not the best, so for that i used an IPAD with Emby app to browse and then let it play on OPPO using DLNA option

In the top right the OPPO would always show. I havent used in a while, and there have been firmware updates on both Oppo as well as Emby server

But now the OPPO no longer shows up on Emby (on IPAD app)

 

Any suggestions what could cause this and how to solve?

 

Regards

Galva



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129475 posts
  • Local time: 07:59 PM

Posted 21 May 2019 - 05:44 PM

Hi there, try restarting the Oppo while Emby Server is running. Please see if that helps, thanks.



#3 Galvaneal OFFLINE  

Galvaneal

    Member

  • Members
  • 18 posts
  • Local time: 01:59 AM

Posted 21 May 2019 - 05:48 PM

Hi there, try restarting the Oppo while Emby Server is running. Please see if that helps, thanks.

Hi Luke

 

I have tried that but it still doesnt show



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129475 posts
  • Local time: 07:59 PM

Posted 21 May 2019 - 05:49 PM

Can you please attach the emby server log? thanks.



#5 Galvaneal OFFLINE  

Galvaneal

    Member

  • Members
  • 18 posts
  • Local time: 01:59 AM

Posted 21 May 2019 - 05:56 PM

Can you please attach the emby server log? thanks.

i have several log files to choose from but 2 with emby server in it with date today. I will add both

Attached Files



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129475 posts
  • Local time: 07:59 PM

Posted 22 May 2019 - 03:57 PM

See this error in your log:

/var/packages/EmbyServer/target/ffmpeg/bin/ffdetect -restartexitcode 121
Operating system: Unix 3.10.105.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime:
file:///volume1/@appstore/EmbyServer/3rdparty/netcore/2.2.1/runtime/System.
Private.CoreLib.dll
Processor count: 4
Program data path: /var/packages/EmbyServer/target/var
Application directory:
/volume1/@appstore/EmbyServer/releases/4.1.1.0
System.Net.Sockets.SocketException:
System.Net.Sockets.SocketException (98): Address already in use
 at
System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(Soc
ketError error, String callerName) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
5157
 at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot,
SocketAddress socketAddress) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
761
 at System.Net.Sockets.Socket.Bind(EndPoint localEP) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
704
 at
Rssdp.SsdpCommunicationsServer.CreateUdpMulticastSocket(IPAddress
localAddress, Int32 multicastTimeToLive, Int32 localPort)
 at Rssdp.SsdpCommunicationsServer.ListenForBroadcastsAsync()
 at
Rssdp.SsdpCommunicationsServer.BeginListeningForBroadcasts(CancellationToke
n cancellationToken)
Source: System.Net.Sockets
TargetSite: Void
UpdateStatusAfterSocketErrorAndThrowException(System.Net.Sockets.SocketErro
r, System.String)

This is unfortunately a defect in the .NET Core runtime. It will be resolved later this year in .NET Core 3.0. If you're interested in the technical explanation, you can find it here:

https://emby.media/c...e-2#entry670391

 

In the meantime, to workaround this issue, you need to shutdown all other dlna software on the server machine, and then start Emby Server after that.



#7 Galvaneal OFFLINE  

Galvaneal

    Member

  • Members
  • 18 posts
  • Local time: 01:59 AM

Posted 23 May 2019 - 02:55 AM

See this error in your log:

/var/packages/EmbyServer/target/ffmpeg/bin/ffdetect -restartexitcode 121
Operating system: Unix 3.10.105.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime:
file:///volume1/@appstore/EmbyServer/3rdparty/netcore/2.2.1/runtime/System.
Private.CoreLib.dll
Processor count: 4
Program data path: /var/packages/EmbyServer/target/var
Application directory:
/volume1/@appstore/EmbyServer/releases/4.1.1.0
System.Net.Sockets.SocketException:
System.Net.Sockets.SocketException (98): Address already in use
 at
System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(Soc
ketError error, String callerName) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
5157
 at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot,
SocketAddress socketAddress) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
761
 at System.Net.Sockets.Socket.Bind(EndPoint localEP) in
/source/corefx/src/System.Net.Sockets/src/System/Net/Sockets/Socket.cs:line
704
 at
Rssdp.SsdpCommunicationsServer.CreateUdpMulticastSocket(IPAddress
localAddress, Int32 multicastTimeToLive, Int32 localPort)
 at Rssdp.SsdpCommunicationsServer.ListenForBroadcastsAsync()
 at
Rssdp.SsdpCommunicationsServer.BeginListeningForBroadcasts(CancellationToke
n cancellationToken)
Source: System.Net.Sockets
TargetSite: Void
UpdateStatusAfterSocketErrorAndThrowException(System.Net.Sockets.SocketErro
r, System.String)

This is unfortunately a defect in the .NET Core runtime. It will be resolved later this year in .NET Core 3.0. If you're interested in the technical explanation, you can find it here:

https://emby.media/c...e-2#entry670391

 

In the meantime, to workaround this issue, you need to shutdown all other dlna software on the server machine, and then start Emby Server after that.

Hi Luke

 

Thanks for looking into this. I dont understand the technical explanation, but happy to read you will be fixing this in the future. I have found a workaround today that also worked, which was turning off VPN on the NAS

For some reason that blocks the DLNA. 



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 129475 posts
  • Local time: 07:59 PM

Posted 23 May 2019 - 12:58 PM

Thanks for the feedback.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users