Jump to content

Emby for Kodi not working anymore after latest beta update (4.0.21a)


Guest zecakeh
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Guest zecakeh

Hi all,

 

It seems like the Kodi addon doesn't want to do anything anymore.

 

First of all, my setup is :

 

Client

OS : Arch Linux

Kodi version 18.2 (locally built from source for Wayland)

Emby for Kodi version 4.0.21a

 

Server

Asustor NAS with ADM

Emby Server version 4.1.1.0 installed from the official store

 

When I launched Kodi today I got an Error Notification for the Emby addon. I guess it was during the update, since in the kodi logs it showed just as :

RuntimeError: Unknown addon id 'plugin.video.emby'

After that, it wouldn't launch any movie or tvshow, there wasn't even a BusyDialog like usual. I then opened the addon and nothing happened when I clicked on Movies or TV Shows. Nothing happened either in "Manage libraries" when I clicked on add, refresh, repair or remove.

The thing that seems to work is "Add a server".

 

So then I tried to reboot Kodi, then to remove and reinstall the addons, nothing changed, and the addon doesn't show the Emby Welcome Notification at startup. As a last resort I tried to clear the local database from the addon configuration, remove all Emby settings and reinstall.

The process to add a server then launches as usual and I manage to re-add my server and connect to it. However, the Welcome Notification still doesn't show and I can't add libraries anymore nor explore them "dynamically".

 

In the server logs, the connexion from the Kodi addon appears everytime.

 

You'll find my latest Kodi log attached.

 

For the info, I also use Kodi on Android TV on my Nvidia Shield. It's on the beta channel but right now it's on par with the stable releases (so 18.2). I had the same Emby Error Notification at startup, and the videos wouldn't play. However I quit Kodi and opened it again and it seems to work fine now.

Link to comment
Share on other sites

  • Solution
Angelblue05

Can you update to 4.0.22. There was an error in 4.0.21 that prevented the service from starting after signing in to your server. I thought I was pretty quick to replace it, but apparently not quick enough.

 

Thanks.

Edited by Angelblue05
Link to comment
Share on other sites

Guest zecakeh

Yep that fixes it. Thanks!

 

I didn't realize my Nividia Shield didn't update to the same version of the addon. That's why it worked…

 

Keep up the great work!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...