Jump to content


Photo

Problems with Playback of DD+


  • Please log in to reply
37 replies to this topic

#21 mikeB2210 OFFLINE  

mikeB2210

    Advanced Member

  • Members
  • 135 posts
  • Local time: 08:07 AM

Posted 30 May 2019 - 05:06 AM

@Luke

 

Here are a few Samples

 

The sample files contain soundtracks with normal DD 5.1 and DD + 7.1. The movies play without jerking with DD 5.1, when switching to 7.1, the jerking occurs. The same movies can be played under Kodi with 7.1 without juddering.


  • IceBoosteR likes this

#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138067 posts
  • Local time: 02:07 AM

Posted 30 May 2019 - 11:33 AM

Great thanks. @ebr will try those out.

#23 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 30 May 2019 - 02:29 PM

This only occurs on a Shield, correct?

 

Can someone with the experimental Shield firmware image please try one of these...?



#24 mikeB2210 OFFLINE  

mikeB2210

    Advanced Member

  • Members
  • 135 posts
  • Local time: 08:07 AM

Posted 31 May 2019 - 10:04 AM

This only occurs on a Shield, correct?

Can someone with the experimental Shield firmware image please try one of these...?

I tried it allready, but the problem is not solved on my shield.

Only playing this files in Kodi solved the problem. So I think its not shield problem.

Edited by mikeB2210, 31 May 2019 - 10:07 AM.

  • Yog-Sothoth likes this

#25 cordo79 OFFLINE  

cordo79

    Newbie

  • Members
  • 1 posts
  • Local time: 08:07 AM

Posted 01 June 2019 - 04:06 PM

same problem here with all DD+ Movies. 

 

When i use alternate player vlc or mx there is no stutter. 

 

Exoplayer problem? 


  • Yog-Sothoth likes this

#26 IceBoosteR OFFLINE  

IceBoosteR

    Advanced Member

  • Members
  • 96 posts
  • Local time: 08:07 AM

Posted 12 June 2019 - 04:02 PM

@ebr

Any update on this? The files from @mikeB2210 are great - it also includes the movie I have problems with.



#27 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 12 June 2019 - 04:03 PM

Sorry, I'm not sure what to do other than transcode them.  I have a number of items with DD+ soundtracks though that play fine.  I think maybe it is only 7.1...



#28 Yog-Sothoth OFFLINE  

Yog-Sothoth

    Newbie

  • Members
  • 1 posts
  • Local time: 08:07 AM

Posted 28 June 2019 - 09:37 AM

Sorry, I'm not sure what to do other than transcode them.  I have a number of items with DD+ soundtracks though that play fine.  I think maybe it is only 7.1...

 

Any solution? I have the same problem and I put the beta version of SHIELD... With KODI, no problem...



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138067 posts
  • Local time: 02:07 AM

Posted 28 June 2019 - 12:59 PM

Any solution? I have the same problem and I put the beta version of SHIELD... With KODI, no problem...

 

@Yog-Sothoth can you please go over an example? thanks !



#30 BillOatman OFFLINE  

BillOatman

    Advanced Member

  • Members
  • 473 posts
  • Local time: 02:07 AM

Posted 28 June 2019 - 01:51 PM

same problem here with all DD+ Movies. 

 

When i use alternate player vlc or mx there is no stutter. 

 

Exoplayer problem

If that's the thought, and it does seem plausible, maybe checking with the players devs might make sense.

 

And I'll also be "that guy" :)  From the exoplayer site

 

The FFmpeg extension supports decoding a variety of different audio sample formats. You can choose which decoders to include by passing command line arguments to FFmpeg’s configure script:

TrueHD –enable-decoder=mlp –enable-decoder=truehd

 

 


Edited by BillOatman, 28 June 2019 - 01:56 PM.


#31 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 28 June 2019 - 03:20 PM

If that's the thought, and it does seem plausible, maybe checking with the players devs might make sense.

 

I have to try and pull together an example and see if it can be reproduced with their demo app before consulting them.

 

 

And I'll also be "that guy" :)  From the exoplayer site

 

This isn't really relevant to this situation as we are passing thru this codec for outbound processing by a receiver - not using the ffmpeg extension for software decoding.



#32 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 28 June 2019 - 03:21 PM

@Yog-Sothoth can you please go over an example? thanks !

 

I think we fully understand the issue at this point.  It can be reproduced but only with certain content.



#33 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 29 June 2019 - 05:45 PM

I tried it allready, but the problem is not solved on my shield.

Only playing this files in Kodi solved the problem. So I think its not shield problem.

 

@mikeB2210 I just want to confirm that you were running the experimental Shield firmware image you have to request from Nvidia directly - the one that fixes the other stuttering problems.

 

Thanks.



#34 mikeB2210 OFFLINE  

mikeB2210

    Advanced Member

  • Members
  • 135 posts
  • Local time: 08:07 AM

Posted 30 June 2019 - 12:28 AM

@ebr yes I‘m running the experimental Firmware from NVidia. Stuttering Problem is gone, DD+ 7.1 still there.
  • ebr likes this

#35 mikeB2210 OFFLINE  

mikeB2210

    Advanced Member

  • Members
  • 135 posts
  • Local time: 08:07 AM

Posted 01 July 2019 - 03:31 PM

@ebr
have just played a movie with dd + 7.1 with the current 1.7.33g. the jerking is gone, but only 5.1 channels are played as sound.

#36 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 01 July 2019 - 03:39 PM

Correct.  That is the workaround until we can get with Google to try and find out what the problem is.

 

Thanks.


  • mikeB2210 likes this

#37 mikeB2210 OFFLINE  

mikeB2210

    Advanced Member

  • Members
  • 135 posts
  • Local time: 08:07 AM

Posted 21 August 2019 - 04:35 AM

Correct.  That is the workaround until we can get with Google to try and find out what the problem is.

 

Thanks.

Any news solving this DD+ problem??


  • rechner123 likes this

#38 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46989 posts
  • Local time: 02:07 AM

Posted 21 August 2019 - 03:08 PM

Not at this time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users