Jump to content

Collection listing is not as expected


Xuvin
 Share

Recommended Posts

Hey guys,

 

I am running into a problem for several days now and I tried a lot, but did not come to a solution.

Hope you can help or give me some advice. :D

 

 

I have noticed that one off my collection (movie collection organized by auto box sets plugin) is not brought together correctly. - I guess at least.

 

There should be two movies in that collection. They are both listed in the collection.xml, but while looking at that collection, it is only the first movie of the two shown. In the movie library overview - with group all media in a collection checked - is the collection present as an item and right next to it the second movie, which should normally be in that collection.

 

 

I removed both movies, added them back to the library and did a complete library scan + refreshed the collections via the auto box sets plugin.

-> Still the same outcome.

I reinstalled the auto box sets plugin.

-> Still the same outcome.

I created a collection manually and scanned / refreshed everything.

-> Collection folder has been created including a collection.xml that has movie items in it, but the whole collection is not showing up.

 

 

Am I doing something wrong or am I misunderstanding something ?

Link to comment
Share on other sites

Xuvin

Hey Luke, I can for sure.

 

I tinkered a bit to day and made an kind of interesting observation.

A new collection was added as expected.

So I thought the plugin should be working and there is maybe something different going on here and observed something during a test:

 

I tried to create a demo collection manually for example for the The Fantastic Beasts Collection.

Right after the creation, both movies are listed (Fantastic Beasts and Where to find them and Fantastic Beasts: The Crimes of Grindelwald) within the collection.

And at that exact moment there are no metadata fetched yet. But if I click instantly on "Edit Metadata", there is the right collection id (435259) entered.

Now if I leave the "Edit Metadata" window and go back Emby continues with fetching the metadata and right after the cover, etc. shows up the second movie disappears.

 

Nevertheless, the movies are still both listed as individual <CollectionItem> in the collection.xml.

 

Any idea whats going on here ?

Link to comment
Share on other sites

sproon

I also have noticed the exact issue with collections. For example the cars collection exist and contains all three movies in the xml file but when the movies are displayed cars 2 is in the collection but cars 3 and cars 1 are outside the collection. I have had multiple examples of this issue as many collections are created, but do not contain all the movies as expected.

Link to comment
Share on other sites

Happy2Play

I have not seen or been able to reproduce this issue.  Do any of these movies have "multi-versions"?  Do you save metadata with media?  Have you verified paths in the collection.xml are correct?

 

When did this start?  If this happening from a migrated database 3.5 to v4+ or new database?

Edited by Happy2Play
Link to comment
Share on other sites

Xuvin

Hey @@Happy2Play,

 

during rechecking everything to be sure to give the right answers, I found the error.

 

I label my movies Iike: /path/to/library/moviename - subtitle (year)/moviename - subtitle (year) - version.ext

 

And somehow autoboxsets creates a faulty link or emby doesn't understand it correctly, because of the "(" or ")" character.

After removing the (year) from the folder and file name, it is correctly showing up.

 

But on the other hand it is working with the (year) in other collections.

So just a faulty link was generated for this specific collection ? Don't think so.

 

But not all have a "- subtitle". So maybe that is it ?

 

However it is back in the collection, so I leave it as it is.

 

EDIT:

Found this thread:

https://emby.media/community/index.php?/topic/68506-some-movies-wont-add-into-a-collection/

Seeing some parallels here.

Edited by Xuvin
Link to comment
Share on other sites

sproon

This could be related to a multi version problem. I have a process that compresses new media on the server which would have a second copy of video file until the process is complete. After which it replaces the uncompressed file. In my case i do save metadata to the movie folders and i have seen this issue for quite a while. 3.2 and on i believe. When 4.0 came out i did a fresh install as well. All the information in the collection xml is correct with the file names

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...