Jump to content

Incorrect Audio Track and Incorrect Meta Data


NOLA_DireWolff
 Share

Recommended Posts

NOLA_DireWolff

Thanks for taking the time to assist me.  I just set up my media server, so I'm at the fork in the road where I need to choose between Plex and Emby.  I heard good things about Emby, so I decided to try that first.

 

Samsung Model - QN75Q9FNA

Samsung Firmware - 1202

Emby Server - 4.1.0.26

Client App on TV - Emby Theater 1.0.29

Media Info from Server

 

5cb9c2b4f0d3d_Mediainfo.jpg

 
I am just setting my system up and trying to decide on the best media server and ecosystem to get involved with.  I'm only looking to choose between the big two.  I put a single movie file on my server - The Hobbit Battle of Five Armies.  It is in a  .m2ts container.  It is the English, DTS version.  
 
The Main Problem
---
When I play in it in VLC on my computer, it starts the English audio track and can output perfect to my home theater via HDMI.  Looking in the VLC Media Information it shows H264 movie, 1080p, 23.97 and 2x DTS audio streams, 2x AC3 streams and 7 Subtitle tracks.
 
VLC Audio Track 1 - English
VLC Audio Track 2 - French
VLC Audio Track 3 - Italian
VLC Audio Track 4 - Director Commentary
----
When I play the same file on the Emby web client, DTS 1 = English, DTS 2 = French, AC3 = Italian and finally director commentary.
----
The same file on the Samsung TV App:
 
It shows 4 audio tracks but no matter which one I select, there is no english DTS, and each track is not mapped to a unique audio stream.  It is like they are all offset from the file.
 
DTS 7.1 - Plays as the Italian 5.1 tracks above.
DTS 7.1 - Plays as the stereo directors commentary above.
DD 5.1 - Plays as the stereo directors commentary above.
DD Stereo - Plays as the stereo directors commentary above.
 
Secondary Problem
-------
I didn't have any metadata associated with the file.  I put it in a folder called "The Hobbit - 2004 - The Battle of Five Armies\2004.Battle Of Five Armies.m2ts"   The scan resulted in the associated images and displayed name being from "The Hobbit:  An Unexpected Journey"  This could obviously be quite confusing over a whole library.  What did I do wrong here?
Link to comment
Share on other sites

NOLA_DireWolff

Hi, what version of the Samsung app?

 

 

I'm unable to find a way to verify the app version on my Samsung TV.  While logged into the server, I see the following:

 

5cba0b3498a7c_EmbyDevices.jpg

 

Does that mean the Samsung App is version 1.0.29?  

 

Also while doing subsequent testing: 

**If I select other audio tracks on the, I can randomly move through them and use all of the 4 options.  English never plays.  I have had it get "stuck" on the directors commentary more than once, where selecting other audio tracks results in the menu showing a different selection but no change in the audio stream.  The app is getting randomly stuck in certain streams.

**If I browse to the server using direct file browsing on the TV and play the hobbit file, the audio is in English right away and shows no problems when the TV is the player.

**I would prefer to get Emby working correctly vs. using a file browser to find the movies.

 

Regarding the Metadata - the Identify feature worked great to fix it.  Was there something I could have done differently regarding initial upload to the server to give it a better shot?

Link to comment
Share on other sites

 

Regarding the Metadata - the Identify feature worked great to fix it.  Was there something I could have done differently regarding initial upload to the server to give it a better shot?

 

For best results in getting Emby to identify movies correctly use the 'moviename (year)' folder format specified in the wiki and names according to tmdb

 

https://github.com/MediaBrowser/Wiki/wiki/Movie-naming

 

https://www.themoviedb.org/movie/122917-the-hobbit-the-battle-of-the-five-armies?language=en-US

 

So for the movie in your example the folder would look like this:

 

\The Hobbit The Battle of the Five Armies (2014)\

Edited by FrostByte
Link to comment
Share on other sites

NOLA_DireWolff

Also of note:

 

Most of the settings and menus in the app - the setting title is more of a draft header or placeholder vs. a "finished" name of the setting.

 

Many of the variables "default audio track" checkbox, show the box, can be highlighted, but can't be clicked.

 

Is the wrong version of the app in the Samsung App store?  Can I force load a better one locally?  I couldn't find a place to check the latest version.

Link to comment
Share on other sites

All of this is resolved for the next update to the Samsung app, thanks.

Thats not really much help if we still cannot get the app for Premium 2018 models!!!

 

I know - you are working on it!

 

Krs

 

Mark

Link to comment
Share on other sites

It has been a year now and this model has never gotten an update since the initial release while all other models and years including 2019s are getting the "next update".  Something is wrong

Link to comment
Share on other sites

NOLA_DireWolff

All of this is resolved for the next update to the Samsung app, thanks.

 

 

Thank you for that guidance - what is the development timeline?  Are there any ways I can workaround this?  This is a $5k TV, and it is the primary method used to watch video for entertainment in the household.  If Emby isn't going to work, I'll unfortunately have to move on.

Link to comment
Share on other sites

NOLA_DireWolff

It has been a year now and this model has never gotten an update since the initial release while all other models and years including 2019s are getting the "next update".  Something is wrong

 

Do you have the same issues I am having?  It seems we are both running 1.0.29.  Is there a later Tizen version of the app that our TVs aren't downloading?

Link to comment
Share on other sites

Samsung tests and releases updates after testing each model group / year separately.  By group I mean what Samsung calls standard, premium, etc sets.  So the app can pass and get released for one group and not another which is why everyone is on a different release.  When you go to the Samsung store and view the Emby app details it should show what version you have installed and the latest version approved for your TV.  Not much else you can do, but wait for Samsung to hopefully approve the next update for your set.

 

To find which model group you have you can see the table here:

 

https://developer.samsung.com/tv/develop/specifications/tv-model-groups

 

For 2018 premium sets we have been at version .29 which was the latest when they first came out.  Right now we are about 30 releases behind a lot of the others including even 2018 standard models

 

As far as the problems you are seeing with audio selection I always mux out what I don't need (unneeded audio, subs, etc) and all my containers are mkv.  So I would only have one audio track and at the most one subtitle track for non-English parts.  All the other things like the weird headers, and the black box for subtitles which never goes away I do see.

Edited by FrostByte
Link to comment
Share on other sites

Oh, btw there was a firmware update about a week ago.  I got version 1251, though I'm not sure what it fixed since it's not on Samsung's website yet.  I would assume the Q9s got it also.

Link to comment
Share on other sites

NOLA_DireWolff

I checked my TV firmware before I posted on the forum.  I just logged into my TV again, it still says 1202 is the latest, and Samsung's site doesn't show 1251.

 

Are you in a different region?  I'm USA.

Link to comment
Share on other sites

I'm in the US also. 

 

Strange as many users of all the 2018 Qleds and NU8000 have reported getting 1251 in the US, though others say they haven't seen it yet.  I guess it's on the UK website now, so it must be trickling down slowly.

 

https://www.avsforum.com/forum/166-lcd-flat-panel-displays/2963950-2018-samsung-q9fn-owners-thread-no-price-talk-306.html

Link to comment
Share on other sites

NOLA_DireWolff

This is quite the frustrating predicament.  I almost wish I had not purchased my Samsung Q9 now.  I should have purchased something running Android.

 

I contacted Samsung support today and complained and asked for a ticket to be opened regarding witholding the Emby app update.  

 

I can't use Emby on my primary TV, so I'll likely have to go to a different media server ecosystem if there is no real solution.

  • Like 1
Link to comment
Share on other sites

It's not much help but there is a work around - I have a cheaper one of the 2018 premium TVs.

 

The issue with the audio track is Samsung no longer including DTS decoding in their products, so whatever file you are selecting it is reverting to an AC3 feed for the audio.

 

Largely because of this I am using a fire TV. However there is a work around... If you restrict the stream bitrate in the app the audio is transcoded server side and plays fine.

 

So to work with the current app you would need to either limit the stream to something less than the file being played, or convert all DTS audio streams.

 

When the new app is released I believe it includes code to not bother attempting DTS with new Samsung's and transcodes by default (so won't need to limit the video bitrate.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...