Jump to content


Photo

HEVC UHD titles not recognizing HDR

HDR UHD

  • Please log in to reply
19 replies to this topic

#1 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 11 April 2019 - 10:33 PM

I recently bought a one month license for Emby to kick the tires on it as I am having issues with Plex on an Nvidia Shield when trying to play back UHD HDR content consistently.  Of course I am having issues with Emby, too.  My problem is that some of my UHD Blu Ray MKV files will play fine and HDR is recognized and properly displayed, other movies appear washed out and will NOT play properly with Emby.  Here are two that will not and one that does.  Can someone tell me if they see a reason why they would not?
 
Aquaman - washed out HDR and app doesn't recognize the file type
Saving Private Ryan - washed out HDR and app doesn't recognize the file type
Infinity War - plays ok except for all green blockiness part way through the film.  This also happens in Plex which means it must be an Nvidia Shield issue.
 
 
The Plex app DOES properly play them, if it matters.

 

EDIT - I wonder if it has to do with subtitles?  I noticed that Infinity War does not have them but the others do.  Is that throwing the Emby client for a loop?

Attached Files


Edited by psuhammer, 11 April 2019 - 11:14 PM.


#2 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 11 April 2019 - 11:45 PM

https://emby.media/c...shield-atv-hdr/

 

https://github.com/g...yer/issues/5096



#3 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 08:05 AM

Thanks!  But my files are not cropped or transcoded, just taking a mux of the original 2160p film. 


Edited by psuhammer, 12 April 2019 - 08:06 AM.


#4 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 12 April 2019 - 10:26 AM

Can you post a screenshot of the media info?

Edited by Doofus, 12 April 2019 - 01:05 PM.


#5 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 02:12 PM

I am assuming you want to see this?  Here is one pic from a UHD mkv movie that is recognized and one that is not in the Emby client.  Keep in mind that both are taken from a Blu Ray disk and just remuxed to an MKV.  No transcoding.  And both handled via the same app (CloneBD).  Also, both play fine in Plex.  

 

5cb0d4d56e048_20190412_135212.jpg

 

 

and the other that does not:

 

5cb0d4ec61766_20190412_135149.jpg


Edited by psuhammer, 12 April 2019 - 02:14 PM.


#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 12 April 2019 - 02:21 PM

If you scroll down, you should see the file details.

#7 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 05:32 PM

Maybe mine is missing something.  Are you saying to scroll down on the screens I posted above?  If I do, there is only chapter, cast and related movies sections.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146562 posts
  • Local time: 08:20 PM

Posted 12 April 2019 - 05:33 PM

Can you open that one in the web app, click the 3-dot menu and refresh the metadata? Then restart the android tv app and see if anything changes. If not, please attach the emby server log. thanks !



#9 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17177 posts
  • Local time: 05:20 PM
  • LocationWashington State

Posted 12 April 2019 - 05:38 PM

The Aquaman screenshot shows Video <Unknown> and no audio track, so it would appear to be a metadata media info issue to me.  Maybe failed ffprobe?


Edited by Happy2Play, 12 April 2019 - 06:10 PM.


#10 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 12 April 2019 - 05:53 PM

The Aquaman screenshot shows Video <Unknown> and no audio track, so it would appear to be a metadata issue to me. Maybe failed ffprobe?


I was thinking something similar.

#11 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 09:01 PM

The Aquaman screenshot shows Video <Unknown> and no audio track, so it would appear to be a metadata media info issue to me.  Maybe failed ffprobe?

 

I am assuming Plex uses something different than FFmpeg as it can see the metadata for the file properly.  Is there a way to resolve this?

 

 

Can you open that one in the web app, click the 3-dot menu and refresh the metadata? Then restart the android tv app and see if anything changes. If not, please attach the emby server log. thanks !

 

 

No bueno.  Here is the log.  For what it is worth, the web client also doesn't recognize the file video or audio.

Attached Files


Edited by psuhammer, 12 April 2019 - 09:01 PM.


#12 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 17177 posts
  • Local time: 05:20 PM
  • LocationWashington State

Posted 12 April 2019 - 09:09 PM

The log shows ffprobe erroring on the file, so I can only assume there is a issue in the header information of the file.  A dev will have to comment further.

2019-04-12 20:55:52.274 Error App: Error in ffprobe
	*** Error Report ***
	Version: 4.0.3.0
	Command line: C:\Users\robcr\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 12
	Program data path: C:\Users\robcr\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\robcr\AppData\Roaming\Emby-Server\system
	System.Exception: System.Exception: ffprobe failed for file:"G:\Movies\Aquaman 4k.mkv" - streams and format are both null: 
{
	
	
ffprobe version 4.0.2-emby_2018_12_09-g5abbb1430d+238 Copyright (c) 2007-2018 the FFmpeg developers
	  built with gcc 8.2.1 (Rev1, Built by MSYS2 project) 20181207
	  configuration:  --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --disable-debug --enable-ffnvcodec --enable-nvdec --enable-gmp --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwavpack --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libaom --enable-version3 --enable-libzvbi --enable-gnutls --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv
	  libavutil      56. 14.100 / 56. 14.100
	  libavcodec     58. 18.100 / 58. 18.100
	  libavformat    58. 12.100 / 58. 12.100
	  libavdevice    58.  3.100 / 58.  3.100
	  libavfilter     7. 16.100 /  7. 16.100
	  libswscale      5.  1.100 /  5.  1.100
	  libswresample   3.  1.100 /  3.  1.100
	  libpostproc    55.  1.100 / 55.  1.100
	The tags at index 6 refer to a non-existent track 7.
	[dvdsub @ 000001c8837b2000] [IMGUTILS @ 0000002b555ff2d0] Picture size 0x0 is invalid
	[matroska,webm @ 000001c88379e880] Failed to open codec in avformat_find_stream_info
	Input #0, matroska,webm, from 'file:G:\Movies\Aquaman 4k.mkv':
	  Metadata:
	    title           : Main feature #3
	    ENCODER         : Lavf57.3.100
	  Duration: 02:23:19.39, start: 0.000000, bitrate: 59560 kb/s
	    Chapter #0:0: start 0.000000, end 668.292622
	    Metadata:
	      title           : chapter 1
	    Chapter #0:1: start 668.292622, end 1330.620956
	    Metadata:
	      title           : chapter 2
	    Chapter #0:2: start 1330.620956, end 1810.016533
	    Metadata:
	      title           : chapter 3
	    Chapter #0:3: start 1810.016533, end 2427.716956
	    Metadata:
	      title           : chapter 4
	    Chapter #0:4: start 2427.716956, end 3023.645622
	    Metadata:
	      title           : chapter 5
	    Chapter #0:5: start 3023.645622, end 3674.754400
	    Metadata:
	      title           : chapter 6
	    Chapter #0:6: start 3674.754400, end 4136.090289
	    Metadata:
	      title           : chapter 7
	    Chapter #0:7: start 4136.090289, end 4900.270356
	    Metadata:
	      title           : chapter 8
	    Chapter #0:8: start 4900.270356, end 5689.433733
	    Metadata:
	      title           : chapter 9
	    Chapter #0:9: start 5689.433733, end 5976.428778
	    Metadata:
	      title           : chapter 10
	    Chapter #0:10: start 5976.428778, end 6571.815244
	    Metadata:
	      title           : chapter 11
	    Chapter #0:11: start 6571.815244, end 7295.538244
	    Metadata:
	      title           : chapter 12
	    Chapter #0:12: start 7295.538244, end 7818.894400
	    Metadata:
	      title           : chapter 13
	    Chapter #0:13: start 7818.894400, end 8599.132200
	    Metadata:
	      title           : chapter 14
	    Chapter #0:14: start 8599.132200, end 8599.392000
	    Metadata:
	      title           : chapter 15
	    Stream #0:0: Video: hevc (Main 10), yuv420p10le(tv, bt2020nc/bt2020/smpte2084), 3840x2160 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 23.98 tbc (default)
	    Stream #0:1(eng): Audio: truehd, 48000 Hz, 7.1, s32 (24 bit) (default)
	    Metadata:
	      title           : English
	    Stream #0:2(eng): Audio: dts (DTS-HD MA), 48000 Hz, 5.1(side), s16p
	    Metadata:
	      title           : English
	    Stream #0:3(eng): Audio: ac3, 48000 Hz, 5.1(side), fltp, 448 kb/s
	    Metadata:
	      title           : English
	    Stream #0:4(eng): Audio: ac3, 48000 Hz, 5.1(side), fltp, 448 kb/s
	    Metadata:
	      title           : English
	    Stream #0:5(eng): Subtitle: dvd_subtitle
	    Metadata:
	      title           : English
	[dvdsub @ 000001c883c97240] [IMGUTILS @ 0000002b555ff5e0] Picture size 0x0 is invalid
	Could not open codec for input stream 5
	
	
	   at Emby.Server.MediaEncoding.Encoder.MediaEncoder.GetMediaInfoInternal(String inputPath, String primaryPath, MediaProtocol protocol, Boolean extractChapters, String probeSizeArgument, Boolean isAudio, Boolean forceEnableLogging, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo.ProbeVideo[T](T item, MetadataRefreshOptions options, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Manager.MetadataService`2.RunCustomProvider(ICustomMetadataProvider`1 provider, TItemType item, String logName, MetadataRefreshOptions options, RefreshResult refreshResult, CancellationToken cancellationToken)
	Source: Emby.Server.MediaEncoding
	TargetSite: Void MoveNext()
	   at Emby.Server.MediaEncoding.Encoder.MediaEncoder.GetMediaInfoInternal(String inputPath, String primaryPath, MediaProtocol protocol, Boolean extractChapters, String probeSizeArgument, Boolean isAudio, Boolean forceEnableLogging, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo.ProbeVideo[T](T item, MetadataRefreshOptions options, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Manager.MetadataService`2.RunCustomProvider(ICustomMetadataProvider`1 provider, TItemType item, String logName, MetadataRefreshOptions options, RefreshResult refreshResult, CancellationToken cancellationToken)


#13 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 09:34 PM

Interesting.  And yet, MediaInfo is able to see the information without error.  



#14 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 12 April 2019 - 09:52 PM

It's probably a bad mux. But back to the original issue. If the file is directly played, whatever is playing it shouldn't be subject to the server metadata. It's handled by the player. But.... because of a bad mux, that may actually be why it doesn't play correctly. Try running it through mkvtoolnix. And try another scan.

#15 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 12 April 2019 - 10:07 PM

Will do.  I am still perplexed why this will play correctly in different players.



#16 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13395 posts
  • Local time: 05:20 PM

Posted 12 April 2019 - 10:24 PM

Will do.  I am still perplexed why this will play correctly in different players.

 

That's the thing with weird muxes, some players will be ok, others won't. I've come across so many files made with makemkv that are weird muxes, who knows why???? 



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146562 posts
  • Local time: 08:20 PM

Posted 12 April 2019 - 11:35 PM

Strange. We're about to release emby server 4.1. can you try this again once available? Thanks.

#18 psuhammer OFFLINE  

psuhammer

    Newbie

  • Members
  • 8 posts
  • Local time: 09:20 PM

Posted 13 April 2019 - 09:14 AM

Strange. We're about to release emby server 4.1. can you try this again once available? Thanks.

 

 

Sure will, thanks!



#19 spants OFFLINE  

spants

    Newbie

  • Members
  • 1 posts
  • Local time: 02:20 AM

Posted 24 July 2019 - 03:41 PM

Still has a problem with 4.1.1.0

 

I think it is specifically a problem with the parsing of 4k HEVC (Main 10 HDR) films - they all fail but play ok on Plex.

Attached are clips of plex and emby - the latter shows no video info.


 

Attached Files



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146562 posts
  • Local time: 08:20 PM

Posted 24 July 2019 - 03:46 PM

Still has a problem with 4.1.1.0

 

I think it is specifically a problem with the parsing of 4k HEVC (Main 10 HDR) films - they all fail but play ok on Plex.

Attached are clips of plex and emby - the latter shows no video info.

 

 

Hi there @spants, please attach the information requested in how to report a media playback issue. thanks !







Also tagged with one or more of these keywords: HDR, UHD

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users