Jump to content

Duplicate Library showing on clients


Go to solution Solved by Luke,

Recommended Posts

Windows server 2012 r2

HP dl360e G8

Xeon E5-2430 @ 2.2Ghz x 2

48GB Ram

5x raid 5 10k rpm system drives

2x raid 1 ssd database/metadata drive

QNAP 1635 NAS @ 96TB Useable for media

Emby v4.0.3.0

 

I am newish to Emby, hoping to move to it over Plex because Emby handles live tv far better.  But i'm having a few problems that are preventing me from making the switch.  I'll create separate posts for each major issue.

 

I added several libraries, one of which is TV Shows.  While i was adding it, i clicked the final "OK" button to actually add the configured library and waited.. nothing at all happened for perhaps 20 seconds so i thought maybe i missed the ok button. so i clicked it again.. 

 

It finally progressed and low and behold i now i have THREE TV Shows libraries...  i'm assuming this happened because i hit ok twice, which is a very 1990's web form issue, if this is indeed the cause i'd highly recommend a  simple document.this.disabled onclick event on that submit button, or even better depending on what library you guys use a fancy title swap to say "Adding Library..." and disable submit button so this issue doesn't happen and us poor users with huge libraries can know that it registered our click.

 

The real problem at this point is that i was able to delete one of the extra libraries fine, but it's not letting me delete the remaining extra library because it only shows ONE in the library list in the administration side.. but shows 2 in the client view of libraries.  i REALLY don't want to have to have it rescan all my tv shows.. it took 2 days to do it the first time.

 

Here is the view from clients showing 2 TV Shows libraries.5caa6539ed5b6_emby1.png

 

and here is the admin view of libraries showing only 1:

5caa6587027bd_emby2.png

 

is there anything i can do to remove that extra one from the client without removing both? i'm comfortable editing a sql database directly if that is necessary.

 

Thank you very much for any guidance, i really want to get emby working for my needs.

Link to post
Share on other sites
  • Solution

Hi, you may have hit OK multiple times when adding the library. The upcoming 4.1 release will not let you do this anymore.

 

To remove the duplicate, remove the library from Emby library setup, then run two full library scans. Once they complete, then please add it back. Please let us know if this helps. Thanks !

  • Like 1
Link to post
Share on other sites

Thanks for the reply Luke, that is one major reason why i REALLY want to move to emby, the support here makes Plex's look like a joke.. well plex makes plex's look like a joke too =]

 

I'll give it a shot and report back.

Link to post
Share on other sites

i went ahead and removed the tv shows library, did the double library scan and restarted emby and it did in fact remove both tv show libraries from the user view. thanks.

Link to post
Share on other sites
  • 1 month later...

Hi Luke,

 

this just happened to me as well on the latest beta 4.2.0.5.

 

I am switching server and used the backup plugin to transfer the settings of the server, so far so good.

The first time the scheduled scan ran my libraries began to be shown twice.

Following your instruction in post #2 seems to have solved the issue though.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...