Jump to content

EmbyCon : Old support thread


cayars
 Share

Recommended Posts

Kodi version 18 RC 5.2 (Android ARMV7A 32 bit)

Emby Server Beta 4.1.0.3 (Win 10)

 

Since auto update of server to 4.1.0.3  EmbyCon unable to connect to server

Note: it worked OK for 4.1.0.2 on 23 January but after update to 4.1.0.3 on 26 January have had no luck

 

Updated EmbyCon to 1.8.3 using search function

It would have been nice if we pressed the update button on the old Add-on version and it updated properly!

 

When Kodi starts, EmbyCon on Select User screen has an automatic and a manual option to select. Neither works.

 

Changed user/password on Server, used these credentials on Select User manual entry - does not work.

 

Log Details:

13:23:46.674 T:18446744072288995096  NOTICE:   load skin from: /data/data/org.xbmc.kodi/cache/apk/assets/addons/skin.estuary (version: 2.0.19)
13:23:48.013 T:18446744072304946384   ERROR: EmbyCon.resources.lib.downloadutils|ERROR|HTTP response error: 400 Bad Request
13:23:48.024 T:18446744072304946384   ERROR: EmbyCon.resources.lib.downloadutils|ERROR|HTTP response error 401 auth error, removing any saved passwords for user: 81b8a1b77068d06e1c8190825253066f
13:23:48.063 T:18446744072304946384   ERROR: EmbyCon.resources.lib.downloadutils|ERROR|HTTP response error: 401 Unauthorized
 

Any sugggestions? Should I downgrade server updates?

Link to comment
Share on other sites

 

Any sugggestions? Should I downgrade server updates?

 

 

Rolling back to the previous server version fixed it for me. I'm sure embycon will get updated soon tho. 

Link to comment
Share on other sites

OK I'll bite! How do you roll back to the previous version?

Help much appreciated!

 

See also all the discussion at 4.1.0.3 local users with blank password can't login through FireTV app - Emby Server - Emby Community

 

All I did was.... Stop emby server. Go to it's folder & the system.old is the previous. Move delete or whatever the system folder & rename the system.old to system. You'll be back to the version before you upgraded. Start emby server. 

 

Reading that thread... yuppers... prolly the cause.

Edited by riffy
Link to comment
Share on other sites

When I use the play all on a album it gives a error

21:29:01.138 T:1673438064  NOTICE: EmbyCon.resources.lib.functions|INFO|Sending embycon_play_action : {'auto_resume': '-1', 'audio_stream_index': None, 'force_transcode': False, 'subtitle_stream_index': None, 'item_id': '202540', 'media_source_id': ''}
21:29:01.232 T:1681830768  NOTICE: EmbyCon.resources.lib.play_utils|INFO|Received embycon_play_action : {u'auto_resume': u'-1', u'audio_stream_index': None, u'force_transcode': False, u'subtitle_stream_index': None, u'item_id': u'202540', u'media_source_id': u''}
21:29:01.275 T:1681830768   ERROR: EmbyCon.resources.lib.downloadutils|ERROR|HTTP response error: 500 Internal Server Error

kodi log

http://ix.io/1wV7
 

Here is the part of a debug log from the point I clicked on the Play All context menu item

http://ix.io/1wW4

 

From the server log

2019-01-27 21:44:03.444 Info HttpServer: HTTP POST http://192.168.3.78:7096/emby/Items/202540/PlaybackInfo. UserAgent: 
2019-01-27 21:44:03.447 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 4.0.1.0
	Command line: C:\Emby\System\EmbyServer.dll -noautorunwebapp
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 12
	Program data path: C:\Emby
	Application directory: C:\Emby\System
	System.InvalidCastException: System.InvalidCastException: Unable to cast object of type 'MediaBrowser.Controller.Entities.Audio.MusicAlbum' to type 'MediaBrowser.Controller.Entities.IHasMediaSources'.
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetStaticMediaSources(BaseItem item, Folder[] collectionFolders, Boolean enablePathSubstitution, User user)
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetPlayackMediaSources(BaseItem item, User user, Boolean allowMediaProbe, Boolean enablePathSubstitution, CancellationToken cancellationToken)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(BaseItem item, User user, Boolean allowMediaProbe, String mediaSourceId, String liveStreamId)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(GetPostedPlaybackInfo request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.Post(GetPostedPlaybackInfo request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: System.Collections.Generic.List`1[MediaBrowser.Model.Dto.MediaSourceInfo] GetStaticMediaSources(MediaBrowser.Controller.Entities.BaseItem, MediaBrowser.Controller.Entities.Folder[], Boolean, MediaBrowser.Controller.Entities.User)
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetStaticMediaSources(BaseItem item, Folder[] collectionFolders, Boolean enablePathSubstitution, User user)
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetPlayackMediaSources(BaseItem item, User user, Boolean allowMediaProbe, Boolean enablePathSubstitution, CancellationToken cancellationToken)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(BaseItem item, User user, Boolean allowMediaProbe, String mediaSourceId, String liveStreamId)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(GetPostedPlaybackInfo request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.Post(GetPostedPlaybackInfo request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	
2019-01-27 21:44:03.448 Info HttpServer: HTTP Response 500 to 192.168.3.59. Time: 4ms. http://192.168.3.78:7096/emby/Items/202540/PlaybackInfo
Edited by agentxan
Link to comment
Share on other sites

Well, now EmbyCon connects for Movies BUT DOES NOT WORK FOR TVSHOWS! And worse, going back to 4.1.0.2 no longer solves that problem. It looks like 4.1.0.4 changes something on the server side permanently.

 

Can you please describe your problem in more detail? Please remember the beta builds are for those who want to help test. Please see how to report a problem. Thanks !

Link to comment
Share on other sites

I am not sure if the issue I ran into tonight is Kodi related or Embycon related but thought I would post here to see if you see anything in my logs that point to an issue.

 

Basically, I was watching a movie and at some point playback stopped and Kodi completely crashed and closed. 

 

I am on Kodi 18.0 on the Nvidia Shield, Embycon 1.8.4, Emby Server version 4.0.1.

 

In the kodi log it looks like there is an Embycon error at 18:12. I don't know what  logs are helpful to you so I am including the Kodi and Emby logs. If there is something else you need let me know. I just set all this up today trying to test out Kodi instead of the Emby app on my Nvidia Shield device.

 

embyserver_log.txt

 

kodi_log.txt

Link to comment
Share on other sites

Few questions.

 

1. I've been getting an error lately popping up constantly... any clue what/why?

2, Up Next supposed to work with embycon by now isn't it? It'll pop up for the next show only once & then nothing for the one after. 

3. Trailers are still crashing me to desktop... any news one this? Been a couple of months of this now.

 

Log

Link to comment
Share on other sites

was that log from when you saw an error pop up, I dont see anything in there ERROR related from EmbyCon

 

you are using v1.8.7, there was a small bug in that version when you viewed a single season Tv Show and you had the "Flatten single season" feature turned on you would see an error. The latest beta should fix that if that was your issue..

 

Woot! Love an easy fix! :-)

 

Not sure about this one, I dont know anything about the next up addon

 

I'll ask in the Up Next tread then.

 

Sounds like a Kodi crash, if you can get a crash dump perhaps post it on the Kodi forum and they might be able to shed some light on why Kodi is crashing.

 
I did that a few months ago. The general consensus is it's embycon & possibly a link to the trailer button in the estuary skin. Since I can get the trailer to play with the contextual menu or threw the extended info youtube video links but instant crash on the trailer button. Was even told to stop using embycon by a few people over there. :-(
 
BTW... I hit the trailer button for a fast exit from Kodi on that log. :-D 
Edited by riffy
Link to comment
Share on other sites

Have you tried the default estuary skin and selecting the trailer from the context menu?

 

It works in ever skin doing that. Hitting the trailer button crashes Kodi. As a side note... TV Shows don't crash only Movies.

Link to comment
Share on other sites

Here is a reply to someone with the same issue that I linked my other posts in.

 

Same user name on Kodi forums. :-p

Edited by riffy
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...