Jump to content
Sign in to follow this  
Pseudomax

Emby for Kodi: parental control

Recommended Posts

Pseudomax

Hi

 

I am wondering if there is a way to use Emby for Kodi so that the parental control feature is active but does not require the user to enter the Emby settings to change the user from child to adult? I use Kodi with Emby server as I use on multiple Rasberry Pi devices (Librelec) but also wish to enable parental controls. If this is not available then I wonder whether it could be a feature request?

 

I was using PinSentry but this was not ideal and it no longer works ... so I am in need to a simple solution.

 

Thanks in advance

Share this post


Link to post
Share on other sites
Luke

@@Angelblue05 can confirm but you might need to resync after changing it.

Share this post


Link to post
Share on other sites
Angelblue05

With Emby for Kodi, you need to use one emby user per Kodi profile. There is no switching. You’d have to reset the database and resync.

 

I am looking into possible improvements in this area in the future. I do not like Kodi’s profile system. It is clunky. It is being reworked for Kodi 19.

 

I recommend looking into Embycon to support additional users.

Share this post


Link to post
Share on other sites
Pseudomax

First off, thank you all for the helpful responses!

 

Particularly to @ as I have to say Embuary is a great skin! Very impressed!

 

However, on using EmbyCon I get the fast switching option, but when I login, I have to add my password each time ... would prefer to use Emby PIN only (and only for the adult profile). Additionally, there are still bugs as when I login under the child account and try to play a movie with a high rating (I assume they are meant to be listed?) then the whole of Kodi crashes?!

 

If this is a known bug or something I am doing incorrectly then please let me know ... (happy to try to troubleshoot too if that was of interest ...)

Share this post


Link to post
Share on other sites
Pseudomax

The high rated movies should not be shown, if you are using just EmbyCon when you log in with your child's account only low rated movies should be visible.

 

Kodi crashing is not expected.

 

This suggests that something is not correctly configured ... I uninstalled Emby for Kodi app and just using EmbyCon but maybe something needs to be resynced? Additionally the version of Kodi I am using is Kodi 18 but installed on Windows machine that hosts the Emby Server a well. Is there something additional I need to do beyond uninstall Emby for Kodi and install EmbyCon?

Share this post


Link to post
Share on other sites
Angelblue05

Install Emby for Kodi, then open > at the bottom of the list you’ll find reset local database. Or you can select manage library > remove libraries and remove your synced library.

 

Then you can uninstall emby for kodi.

  • Like 1

Share this post


Link to post
Share on other sites
Pseudomax

Hi

 

Apologies, but I am struggling to get things working after multiple attempts!

 

It seems that EmbyCon won't connect properly to the server (even though they both reside on the same machine (Windows 10 Pro 64-bit).

 

I have tried to take all the advice above, including reinstalling Kodi, Emby for Kodi and EmbyCon (I reset all Emby setting, including the Kodi database via Emby for Kodi). However, I remain with the same error...

 

Basically, when starting Kodi with Embuary I am prompted to choose a user. I do so without an error notification, and all my media loads as expected. However, I immediately have an alert on the server for a failed login. Then if I try to change the user I get alerts generated as failed logins for whichever user I choose. I attach logs. The most recent failed login occurred at 00:32 30/03/2019

 

I imagine the failed logins are why the parental control is not working. Part of what caused me to delve into this is a recent Windows upgrade that has caused Windows firewall to stop storing custom settings. However, I have changed to a different firewall because of this and thought it might be part of the problem. However even when I turn off the firewall I still get this issue. That said, although I have a new firewall (Comodo Firewall) and it is listed in the Windows settings, I still have randomly had to approve a rule in the original Windows Firewall pop-up that suggests somehow the Windows Firewall remains active ....? ... only saying as much in case you think it might be more relevant...

 

Thank you...

 

 

Emby Logs.txt

Share this post


Link to post
Share on other sites
Pseudomax

Kodi logs attached...

kodi.log

Share this post


Link to post
Share on other sites
Pseudomax

yes... every time I need to add a username and password. they are correct though as I can use them to sign into the server successfully ... (just not with EmbyCon???)

Share this post


Link to post
Share on other sites
Pseudomax

Hi, I have played a little more and it seems that the issue (for me at least) was about having the accounts as 'local accounts'? My Emby Connect account seemed to cause a problem but when I reset up the accounts as local accounts it all seemed to start working. Not sure if that is helpful, but I have the system working now. Thanks for your help none-the-less ...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...