Jump to content


Photo

Anyone here using Emby DLNA with Hi-Fi Cast Android app ?


  • Please log in to reply
16 replies to this topic

#1 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 20 February 2019 - 12:40 PM

I am having an issue that I cannot resolve and unsure if it is Emby or Hi-Fi Cast app.

 

I can browse the entire Music library without issue and play from most entry point except Genre.

When I try to Play and/or Play/Shuffle the app throws a 401 error that it cannot read from server.

 

Anyone experience the same issue ?


Edited by Tester, 20 February 2019 - 12:47 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 20 February 2019 - 02:43 PM

Hard to say. Where do you see that error?

#3 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 20 February 2019 - 02:50 PM

The app throws up the error for a second or so.  If I then select an album/song within the Genre it plays it.

It seems that it only happens from the high level differentiation ( songs, albums. playlist, genre, ect).

I will post in the app forums but wanted to run it by your guys first.



#4 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 25 February 2019 - 10:45 AM

Hey Luke, got this response from the app developer

 

Hi,
I think it is a server bug. The UPnP/DLNA response returned by the server indicates that these containers are searchable and so Hi-Fi Cast is using the UPnP search action to retrieve the tracks. But it seems that some of these containers are not actually searchable and so are either returning zero results or the error message.  I don't think there's anything you can do on the server side to fix it :(
 
 
Any thoughts ?


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 25 February 2019 - 12:14 PM

Yeah we haven't fully implemented upnp search yet.

#6 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 25 February 2019 - 01:20 PM

Ahh.. that makes sense then.

 

Is this on the near future to do list ?



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 25 February 2019 - 02:21 PM

We'll get to it, yes.

#8 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 25 February 2019 - 03:14 PM

Fair enough, thx



#9 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 31 March 2019 - 11:39 AM

Interestingly enough, everything I outline above that does not work seems to work with BubbleuPnP so now not so sure what is causing the problems with Hi-Fi cast.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 02 April 2019 - 04:05 PM

We'll look at improving this, thanks.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 07 April 2019 - 03:11 PM

We've made a fix for the hifi cast app that will be in the next release of the server, thanks.



#12 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 08 April 2019 - 02:34 PM

Awesome, thanks for letting us know and looking forward to it.



#13 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 23 April 2019 - 06:09 PM

Luke, can you confirm which version will have the said fixes ?



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 23 April 2019 - 09:02 PM

4.1+.



#15 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 26 April 2019 - 08:37 AM

I am on Version 4.1.0.26 and unfortunately same function with both apps.



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 126941 posts
  • Local time: 09:21 AM

Posted 26 April 2019 - 12:15 PM

We tested with this app and search is working fine for us.

#17 Tester OFFLINE  

Tester

    Advanced Member

  • Members
  • 244 posts
  • Local time: 08:21 AM

Posted 26 April 2019 - 03:54 PM

Search and then play also ?

Go to Genres, then simply play one of them from the hamburger selection on the lower right of each genre.

You can also select a genre and then play it from within.. 

 

Either of these causes the failure for me.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users