Jump to content


Photo

Sämtliche Dateien werden als Movie erkannt


Best Answer CChris , 11 February 2019 - 05:19 PM

Ich vermute mal, dass das auch dein Problem sein wird :)

"The dvd folder recognition is a little more strict now"
Ich habe selber noch nicht mit DVD Ordnern in Emby gearbeitet, aber versuche mal bitte folgendes:

Erstelle einen Unterordner: "VIDEO_TS"
Und kopiere dort hinein deine ganzen Film-Dateien, sodass du letztendlich die folgende Struktur hast:

Volume1 \ DVD \ 
Ice Age 2 - Jetzt taut's (2006) \ VIDEO_TS \ VIDEO_TS.VOB

5c61e6c5b6182_dvd_files.png

Go to the full post


  • Please log in to reply
9 replies to this topic

#1 oli.muenger OFFLINE  

oli.muenger

    Newbie

  • Members
  • 4 posts
  • Local time: 04:18 PM

Posted 11 February 2019 - 02:49 PM

Hallo zusammen,

ich habe da ein Problem, dass erst seit kurzer Zeit auftritt.

Ich habe sämtliche Movies in einem Ordner der den jeweiligen Namen trägt.

Zum Beispiel Ordnername:

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)

Bis anhin hat dies super funktioniert. Nun zeigt es mir nicht mehr nur den Film in der Bibliothek an, sondern erstellt aus sämtlichen Dateien, die in diesem Ordner sind einen Film.

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VIDEO_TS.VOB

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VIDEO_TS.IFO

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VTS_01_0.IFO

und so weiter...

 

Unter Filme funktioniet deshalb nichts mehr, unter Verzeichnisse werden die Filme richtig angezeigt.

 

Emby läuft über den Synology Server.

 

Kann mir da jemand weiterhelfen?

Vielen Dank!



#2 CChris OFFLINE  

CChris

    Advanced Member

  • Members
  • 52 posts
  • Local time: 04:18 PM

Posted 11 February 2019 - 03:09 PM


/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VIDEO_TS.VOB

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VIDEO_TS.IFO

/volume1/DVD/Ice Age 2 - Jetzt taut's (2006)/VTS_01_0.IFO

und so weiter...

Hi, also diese IFO Dateien sollten eigentlich nur die Meta-informationen sein, welche Emby abspeichert.
Diese kann man in den Einstellungen der entsprechenden Bibliothek ein oder ausschalten.

Allerdings kann ich nicht glauben, dass diese dafür verantwortlich sind, dass in der Auswahl "filme" nichts mehr richtig funktioniert.
Das dürfte denke ich eher generelle Probleme mit der Ablagestruktur haben, dass diese ggf. nicht dem Namensschema entspricht, welches Emby erwartet?

Hierzu wären aber ein paar mehr Infos hilfreich :)



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 119080 posts
  • Local time: 10:18 AM

Posted 11 February 2019 - 03:18 PM

Hi, is there a VIDEO_TS sub-folder?

 

The dvd folder recognition is a little more strict now. You will need to have that. Thanks.



#4 oli.muenger OFFLINE  

oli.muenger

    Newbie

  • Members
  • 4 posts
  • Local time: 04:18 PM

Posted 11 February 2019 - 04:31 PM

Vielen Dank für die sehr schnellen Rückmeldungen!

 

Es gibt keinerlei Unterordner in meiner Struktur.

Es besteht nur der Ordner /volume1/DVD/Ice Age 2 - Jetzt taut's (2006) und darin sind die verschiedenen Dateien vom Film.

Und jede Datei in diesem Ordner wird als Film angeschaut und mit Metadaten die natülich nicht stimmen versehen.

Ich habe auch schon einmal das Verzeichnis wo die Movies abelegt sind gelöscht und wieder neu angelegt - leider ohne Erfolg.

Ich suche schon einige Tage und finde einfach keine Lösung dafür.
Bitte gebt mir Bescheid, wenn ich noch zusätzliche Infos für eine Lösungsfingung geben kann.

Vielen Dank.



#5 CChris OFFLINE  

CChris

    Advanced Member

  • Members
  • 52 posts
  • Local time: 04:18 PM

Posted 11 February 2019 - 05:19 PM   Best Answer

Ich vermute mal, dass das auch dein Problem sein wird :)

"The dvd folder recognition is a little more strict now"
Ich habe selber noch nicht mit DVD Ordnern in Emby gearbeitet, aber versuche mal bitte folgendes:

Erstelle einen Unterordner: "VIDEO_TS"
Und kopiere dort hinein deine ganzen Film-Dateien, sodass du letztendlich die folgende Struktur hast:

Volume1 \ DVD \ 
Ice Age 2 - Jetzt taut's (2006) \ VIDEO_TS \ VIDEO_TS.VOB

5c61e6c5b6182_dvd_files.png


  • Luke and oli.muenger like this

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 119080 posts
  • Local time: 10:18 AM

Posted 12 February 2019 - 02:38 PM

Yes that is correct !



#7 oli.muenger OFFLINE  

oli.muenger

    Newbie

  • Members
  • 4 posts
  • Local time: 04:18 PM

Posted 15 February 2019 - 02:12 AM

Hallo zusammen,

 

Ich hatte gestern wieder mal Zeit mich Emby anzunehmen.

Wie von CChris vorgeschlagen habe ich meine Ordnerstruktur angepasst und es hat auf anhieb funktioniert!  :)

Ich habe auch mal probiert den Ordner "VIDEO_TS" umzubenennen zu "FILMDATEIEN" und habe festgestellt, dass dieser Ordner NICHT funktioniert.

Somit MUSS anscheinend der Ordner mit allen zum Film gehörenden Dateien "VIDEO_TS" heissen.

 

Vielen Dank für Eure schnelle Hilfe! ;)



#8 CChris OFFLINE  

CChris

    Advanced Member

  • Members
  • 52 posts
  • Local time: 04:18 PM

Posted 15 February 2019 - 05:53 AM

Ich nehme an, das liegt daran, dass Emby erkennt, dass die Ablage eine DVD Struktur hat - und hier haben sich die Namen VIDEO_TS und AUDIO_TS als Standard etabliert.

Daher wird für diese Art der Ablage eben auch diese Namenskonvention verlangt.

Würde Emby hier frei definierte Namensstrukturen erlauben, dann wäre es denke ich kaum zu Bewerkstelligen, jede erdenkliche Kombination "korrekt" anzuzeigen :)



#9 oli.muenger OFFLINE  

oli.muenger

    Newbie

  • Members
  • 4 posts
  • Local time: 04:18 PM

Posted 15 February 2019 - 06:52 AM

Vor rund einem Monat hat meine alte Struktur (ohne "VIDEO_TS") noch funktioniert.

Ich denke mal Emby hat mit einem Update einige Probleme/Verbesserungen auf kosten der freien Strukturwahl behoben...

Es war doch noch einige Arbeit, sämtliche Filme mit der neuen Ordnerstruktur anzupassen.

Da es nun wieder funktioniert, bin ich wieder happy :)



#10 CChris OFFLINE  

CChris

    Advanced Member

  • Members
  • 52 posts
  • Local time: 04:18 PM

Posted 15 February 2019 - 07:28 AM

Ja, das hat Luke ja geschrieben.
Mit der neuen version ist die Ordnerstruktur strikter geworden - da es generell einfach immer wieder zu viele Fehlerkennungen gab.

Erlaubt man eine freiere Struktur, ist es nahezu unmöglich, jede von einem Benutzer angelegte Struktur korrekt erkennen zu können.
Beim einen funktioniert es, bei zwei anderen nicht... usw. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users