Jump to content
section

Photos in subdirectory problem

Recommended Posts

section

Hi

Emby is great.

 

But I habe a problem with photos in subdirectories.

 

Using the app everything is fine an I have the preview of the photos an can select them.

 

But with a browser like Firefox or Safari, Photos in subdirectories are corrupted (other photos are shown that are not in the directory !)

 

Photos in the first directory are everytime fine, but not in the subdiretories.

 

Please fix or help.

 

Greg

Share this post


Link to post
Share on other sites
Luke

Hi there, what do you mean by corrupted?

Share this post


Link to post
Share on other sites
section

Hi,

 

With corrupted I mean the wrong photos are shown (from another directory).

With app and with browser on IOS it is ok.

But not with firefox or safari on desktop computers .

It is a problem with subdirectories, so the structure is corrupted I think.

Share this post


Link to post
Share on other sites
Luke

Can you please go over an example? thanks.

Share this post


Link to post
Share on other sites
section

Yes.

 

Example directory structure

/photos/holiday/pic1a.jpg

/photos/holiday/pic2a.jpg

/photos/holiday/croatia/pic1b.jpg

/photos/holiday/croatia/pic2b.jpg

/phitos/holiday/croatia/pic3b.jpg

 

The first 2 are fine.

3,4,5 always show pic1b.jpg in the directory to select

This error occurs only in subdirectories like croatia within /photos/holiday

The error only occurs in desktop browsers like safari and firefox.

On iOS it does not occur.

On apps it does not occur

Share this post


Link to post
Share on other sites
Luke

Hi there, can you show a screenshot to demonstrate the issue? thanks.

Share this post


Link to post
Share on other sites
section

With my description made I can describe it best.

What question remained?

Share this post


Link to post
Share on other sites
section

/photos/holiday/pic1a.jpg —> pic1a

/photos/holiday/pic2a.jpg. —> pic2a

/photos/holiday/croatia/pic1b.jpg —> pic1b

/photos/holiday/croatia/pic2b.jpg —> pic1b

/phitos/holiday/croatia/pic3b.jpg. —> pic1b

Share this post


Link to post
Share on other sites
section

Always pic1b even if the other directory is choiced

Share this post


Link to post
Share on other sites
section

It is a bug to be fixed

 

I have lifetime licence for emby

Share this post


Link to post
Share on other sites
Luke

/photos/holiday/croatia/pic1b.jpg —> pic1b

/photos/holiday/croatia/pic2b.jpg —> pic1b

/phitos/holiday/croatia/pic3b.jpg. —> pic1b

 

On which screen is this happening?

Share this post


Link to post
Share on other sites
section

On macos mojave with safari.

On linux with firefox

 

It is not in iOS with safari.

Share this post


Link to post
Share on other sites
Luke

What screen in the web app?

Share this post


Link to post
Share on other sites
section

It is in „My media“, then videos and photos, then listed in „directory“

I

Share this post


Link to post
Share on other sites
Luke

Can you try clearing browsing data?

Share this post


Link to post
Share on other sites
section

I have tried a lot of things, also clearing cache.

 

If I click on the subdirectory to get all the photos in there, all the subdirectories redirects only to the same directory. That is the bug.

Has to be fixed.

 

I also tried Windows IE in the meantime. The same again.

 

Only works on iOS

Share this post


Link to post
Share on other sites
Luke

Have you updated to Emby server 4.0.2?

Share this post


Link to post
Share on other sites
section

Yes, but the same issue.

 

I recognized in the meantime this:

If i click on the subdirectory to show the photos in there, it opens another directory (with other photos in there)

This issue is with several subdirectories. So it seems that all the subdirectories have the same content.

 

With iOS app or IOS Safari all is fine.

Share this post


Link to post
Share on other sites
Luke

What is the url in the browser address bar?

Share this post


Link to post
Share on other sites
section

with desktop PCs

 

main directory

https://emby.xyz.de/web/index.html#!/list/list.html?parentId=70296&serverId=1f139082461d45bba12fcd7613e6c376

 

then several subdirectories open with

https://emby.xyz.de/web/index.html#!/list/list.html?parentId=74888&serverId=1f139082461d45bba12fcd7613e6c376

 

instead of different parentID each subdirectory chosen

these are correct with iOS Safari interestingly

 

that is the issue

otherwise your emby is great, but this issue is important for me

Edited by section

Share this post


Link to post
Share on other sites
Luke

What version of firefox?

Share this post


Link to post
Share on other sites
section

Firefox newest available

IE newest available

OSX Safari newest available

Share this post


Link to post
Share on other sites
section

I have just tried your suggestion.

It is the same issue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...