Jump to content


Photo
Fixed

TV Shows pooling



  • Please log in to reply
54 replies to this topic

#1 nhsman OFFLINE  

nhsman

    Member

  • Members
  • 22 posts
  • Local time: 10:37 AM

Posted 08 February 2019 - 09:37 AM

Hi just wanted to let you know that pooling stopped working for me since I updated Emby for Kodi to version 4.0.5.

 

@Angelblus05 would you be able to have a look. Has something obvious has changed in the latest version?

 

I tried to library repair but no luck.

 

Please let me know if you need any logs.

 

Thanks you.

 

 



#2 nhsman OFFLINE  

nhsman

    Member

  • Members
  • 22 posts
  • Local time: 10:37 AM

Posted 09 February 2019 - 04:52 PM

So I guess it's just me having issues with pooling. Anyone have any ideas how to troubleshoot it?

 

Thanks.



#3 bb165 OFFLINE  

bb165

    Member

  • Members
  • 17 posts
  • Local time: 10:37 AM

Posted 09 February 2019 - 05:47 PM

Only way I managed to resolve it is to roll back the updates.

 

Currently running Emby 3.5.3, with Emby for Kodi 3.0.34 and the 0.11 version of the dependencies.

 

I haven't tried version 3.0.34 with the latest 4.0.1.0 server. The above works fine. Only thing I miss is the Kodi companion.



#4 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 10 February 2019 - 01:24 AM

Yeah, I'm seeing the same issue as well. Something must have changed after the big update.



#5 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 10 February 2019 - 03:34 AM

@nhsman

 

No it's not just you having issues with series pooling. I have series pooling, however haven't seen this issue personally which makes it hard to troubleshoot.

 

Someone pointed out an error in log that seems related "Integrity error". Which makes it sound like there's conflicting episodes are being added at one point. But why or how? No idea.

 

I think if someone would be so kind as to setup a guest account for me to sync to see the issue myself, would be the quickest way to get this resolved. Just PM me.



#6 bb165 OFFLINE  

bb165

    Member

  • Members
  • 17 posts
  • Local time: 10:37 AM

Posted 10 February 2019 - 06:47 AM

Hi @Angelblue05, can you try to recreate the issue by placing different episodes from a single into different folders and then try to sync

e.g
C:/User/Folder1/The Office/Season 1/S01E01.mkv

C:/User/Folder2/The Office/Season 1/S01E02.mkv

Edited by bb165, 10 February 2019 - 06:47 AM.

  • Angelblue05 and NightwingDG like this

#7 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 10 February 2019 - 07:15 AM

Ok I will try this and let you know. Thanks for the suggestion.


  • bb165 likes this

#8 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 13 February 2019 - 03:10 PM

@bb165

 

I finally got around to testing this. I have split episodes between separate folders like in your example and series pooling works here.


  • bb165 likes this

#9 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 13 February 2019 - 10:54 PM

I think I misunderstood the issue. I thought you meant different drives, not folders. This issue is still present on Kodi 18 and Emby for Kodi 4.0.5

 

If I may ask though, why would a file be in different folders if it's in the same drive?


  • bb165 likes this

#10 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 14 February 2019 - 08:09 AM

I would really like to fix this issue, but I can't seem to replicate it on my side. Series pooling is applying correctly regardless of what I've tried so far. 


  • bb165 likes this

#11 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 14 February 2019 - 02:31 PM

It's only happening on Emby for Kodi (Stable) on my end. I tried database reset and it's still happening. Pooling works on the web client though.

 

Curious, do they appear like this in Metadata Manager on your end?

 

 

Attached Files



#12 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 14 February 2019 - 02:36 PM

Hi @Angelblue05, can you try to recreate the issue by placing different episodes from a single into different folders and then try to sync

e.g
C:/User/Folder1/The Office/Season 1/S01E01.mkv

C:/User/Folder2/The Office/Season 1/S01E02.mkv

 

Check in Library and make sure this is checked.

Attached Files



#13 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 14 February 2019 - 02:38 PM

Like this yes.

 

5c65b567c701e_pooling.png



#14 bb165 OFFLINE  

bb165

    Member

  • Members
  • 17 posts
  • Local time: 10:37 AM

Posted 14 February 2019 - 04:19 PM

Check in Library and make sure this is checked.

 

Hi, that option is checked. Not having any problems on the web client, only in Emby for Kodi 4.0.5. I'm currently running Emby for Kodi 3.0.34 with no issues.



#15 bb165 OFFLINE  

bb165

    Member

  • Members
  • 17 posts
  • Local time: 10:37 AM

Posted 14 February 2019 - 04:26 PM

I would really like to fix this issue, but I can't seem to replicate it on my side. Series pooling is applying correctly regardless of what I've tried so far. 

 

May I ask, what you have tried so far?



#16 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 14 February 2019 - 04:44 PM

I have setup series pooling. season in different series folder. I've tried like you suggested, episodes from the same season in different series folder. All appear correctly in Emby for Kodi.



#17 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 14 February 2019 - 04:47 PM

Like this yes.

 

 

Ok. I also noticed there is a new way of naming folders now to make it easier with the 4.0 update. Could it have something to do with it?

 

https://github.com/M...-Access-Control

 

Hi, that option is checked. Not having any problems on the web client, only in Emby for Kodi 4.0.5. I'm currently running Emby for Kodi 3.0.34 with no issues.

 

This leads me to believe that something must have changed and it's not on my end.



#18 NightwingDG OFFLINE  

NightwingDG

    Advanced Member

  • Members
  • 39 posts
  • Local time: 05:37 AM

Posted 14 February 2019 - 04:51 PM

I have setup series pooling. season in different series folder. I've tried like you suggested, episodes from the same season in different series folder. All appear correctly in Emby for Kodi.

 

Do you have the same settings for these?

Attached Files



#19 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13379 posts
  • Local time: 04:37 AM

Posted 15 February 2019 - 07:29 AM

Can you provide me your Kodi databases? I'll load them on my side and hopefully see why this is happening. It would be better if I was able to see this first hand. No one has provided any logs.

 

https://github.com/M...report-an-issue

 

Create a backup, zip up the database files. PM.

https://github.com/M...ore-from-backup


Edited by Angelblue05, 15 February 2019 - 07:30 AM.


#20 bb165 OFFLINE  

bb165

    Member

  • Members
  • 17 posts
  • Local time: 10:37 AM

Posted 15 February 2019 - 12:53 PM

Can you provide me your Kodi databases? I'll load them on my side and hopefully see why this is happening. It would be better if I was able to see this first hand. No one has provided any logs.

 

https://github.com/M...report-an-issue

 

Create a backup, zip up the database files. PM.

https://github.com/M...ore-from-backup

 

I have PM'ed you my kodi.log







Also tagged with one or more of these keywords: Fixed

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users