Jump to content

Server host name being replaced with IPv6 address (which fails)


grangerg
 Share

Go to solution Solved by grangerg,

Recommended Posts

Emby for Roku is not saving the "host" information that I enter when I manually connect to my Emby Server. It appears to be replacing it with the IPv6 address of the Emby Server instead. It used to be working as expected (same server, same Roku, same network). However, due to illness, we haven't been using Emby as much in the last 2-3 months, so I don't know exactly when things stopped working.

 

I'm on v3.0.134 of Emby for Roku at present. Emby for Roku is on a Roku Streaming Stick. The Emby Server is running on a Windows 10 box that has been running great for over a year now. The network is controlled by a Comcast gateway/modem that serves both IPv4 and IPv6 over DHCP. (I can't stop the Comcast modem from serving IPv6 and if I disable IPv6 on the Emby Server box, Emby for Roku still gets the IPv6 assigned by the Comcast modem.)

 

 

Steps I can use to reproduce 100% of the time:

  1. Start Emby for Roku
  2. Choose to manually select Emby server
  3. Select the option to change the host.
  4. Enter the IPv4 address of the Emby server.
  5. Connect, pick user, enter password, watch movies or whatever... works great as long as I stay in the app.
  6. Press the Roku's Home button or otherwise exit Emby for Roku.
  7. Re-start Emby for Roku.
  8. You are now presented with the Emby Connect screen---as if you hadn't connected to a server before.
  9. Go back to the main connection menu and choose the Emby server you connected to earlier.
  10. You will be presented with an error dialog that says "-6: Could not resolve {IPv6 address of Emby Server} (Domain name not found)".

Why isn't Emby for Roku saving the IPv4 address I entered?

 

Let me know if there's something else I can get to help troubleshoot. I've likely forgotten some critical detail in all of this.

 

Link to comment
Share on other sites

[sOLVED]

 

I just noticed that Emby Server has a new version (4.0.1.0). I also noticed that the previous version (v3.x; can't remember now) listed the IPv6 address in the Url for "In-Home (LAN) access:" spot on the settings-dashboard page ( /web/index.html#!/dashboard.html ) After I upgraded to v4.x, that spot now uses the IPv4 address. And now the Emby for Roku app works as it did previously!

 

So I guess that means that Emby for Roku overwrites its host/port settings with what the server says it should be? That sure was unexpected.

  • Like 1
Link to comment
Share on other sites

  • Solution

[sOLVED]

 

I just noticed that Emby Server has a new version (4.0.1.0). I also noticed that the previous version (v3.x; can't remember now) listed the IPv6 address in the Url for "In-Home (LAN) access:" spot on the settings-dashboard page ( /web/index.html#!/dashboard.html ) After I upgraded to v4.x, that spot now uses the IPv4 address. And now the Emby for Roku app works as it did previously!

 

So I guess that means that Emby for Roku overwrites its host/port settings with what the server says it should be? That sure was unexpected.

 

So, it just started happening again. The Roku stopped being able to connect just a bit ago.

 

I went into the server and noticed that the "In-Home (LAN) access:" was no longer the IPv4 address that it was before. Instead, it had changed to the IPv6 address (and, apparently, Roku's don't support IPv6).

 

So I went and looked around the server, and I found a new fix. Under Expert >> Advanced, I entered the IPv4 address of the box in the "Bind to local address" box, then bounced the server. And now the LAN address is what I want, and the Roku connects again.

 

It would be nice to have a better way to stop the Roku from using a different "host" than what I enter.

Link to comment
Share on other sites

It would be nice to have a better way to stop the Roku from using a different "host" than what I enter.

 

You just found it :).  It is much better to control this at the server instead of having to potentially update all apps in order for these things to be correct.

Link to comment
Share on other sites

You just found it :).  It is much better to control this at the server instead of having to potentially update all apps in order for these things to be correct.

 

Umm... so what's your solution for an Emby server that's on a NIC with multiple LAN IPs bound to it (e.g. 2 IPv4 and 2 IPv6)? What about multiple DNS zones in a LAN, or even split DNS? In my experience, the server isn't very good at accurately determining what is best for any given client to use when connecting. But, whatever; that stuff is possible, but not common. 

 

The simplest solution appears to be to change the Roku client so that it doesn't try to use IPv6 addresses---since it's not supported by the Roku. The other, simple solution would be to make it so when someone manually connects, that the Roku client actually saves what was manually entered, instead of changing it to something that the server hopes is usable.

Link to comment
Share on other sites

The server should be the master of its address. This is just the most reasonable approach here - instead of making users have to tend to things on the app end when something on the server side changes.

 

Our solution to the things you mentioned is just what you found above - you configure on the server what address it should publish to the apps - but the server should be in control here - not the app.

Link to comment
Share on other sites

  • 3 weeks later...

@@grangerg are you still having connection problems from Roku?

 

I am not. After I made the change on the server to override the address that it advertises to the Roku, I haven't had further issues. (I hope I remember that next time I move or I reconfigure my network.)

Link to comment
Share on other sites

  • 2 months later...

This same thing happened to me just over night. I did what was suggested to put the IP address of the server in the "Bind to local IP address" and it resolved the issue for me. Thanks grangerg!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...