Jump to content
explex

Plex Refugee dazed and confused...

Recommended Posts

explex

Hi,

 

Brand new Plex refugee here. Enter Emby. Same folders, same setup as Plex. Emby will not display my movies, period. Followed Emby naming protocol that worked like a charm in Plex. I've always pointed my iTunes Media folder to Plex. This way, all media is available to iDevices directly, and can stream via Plex Emby directly to our Roku TV. I have added/removed movie folder many times in media library. It sees the movies in the metadata manager, and it shows the miniature movies in the Library view of Emby Web Settings, but will display only TV shows in Home overview. Furthermore, emby app will not play from Roku TV. It sees the server (manually entered), shows the TV shows, but then 'retrieving' and.....nothing. A very frustrating experience so far. I'm only interested in local media streaming. I have no need for online retrieval of tags, titles, subtitles etcetera. I don't want .nfo files added to folders. All images, data and what not are already contained within each .mp4/.m4v file. I'm using Emby only because I have my iTunes purchases on my Mac and want to view them on my Roku TV.

 

Setup is Mac with Emby Server install (latest/greatest), hardwired via MoCa adapter to Roku TV, Emby app. Server is recognized but nothing will play. Media is stored on external Hard Drive connected to Mac. Is this a DRM issue?

 

I have installed and reinstalled Emby but previous settings remain in place on reinstall. This post is a last ditch effort to get this to work, before I cave and go the Apple TV route. I'd prefer to get this working. Thanks!

post-420920-0-27225400-1549303618_thumb.png

post-420920-0-51066800-1549303631_thumb.png

Edited by explex

Share this post


Link to post
Share on other sites
legallink

That was a lot of text.  Hopefully I parsed it correctly:

 

1. Inevitably, you will get the instructions to follow in reporting problems: https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

2. How long ago did you install emby?  Has it completed it's initial library scan?

3. Local streaming shouldn't be an issue, but you are totally missing out with the online tags, titles, artwork retrieval.  I don't know if that in any way limits things beyond display.  However, if you are blocking internet access to the server, you won't get imagery.

4. Emby doesn't impose any DRM, so it isn't/wouldn't/shouldn't be that.  However, I don't know if the Roku TV Emby app is a premiere app, which may be a different issue...but you would get a "trial" warning or a "Get Premiere" ad if that was the issue. 

5. Have you tried other ways of playing media? aka, have you tried a browser (the default and 1st test case)?

 

I guess start there and we'll see where we go. 

Share this post


Link to post
Share on other sites
explex

1. Noted.

2. I installed Emby yesterday, multiple times. I've manually done a scan. Can't tell if it is in progress or not. Unlike Plex, where I'm used to seeing 'update files' in menu bar icon, then moving gibberish whilst scanning is in progress. No such progress window in Emby, other than the Scan Library green progress bar. Since all movies show up in the metadata manager, I would assume a scan is complete. There are only 80 some files.

3. Imagery is already contained in all my files, as are subtitles, chapters, the works. These are complete media files with all info and imagery embedded.

4. Never got a trial warning or 'premiere' ad. I think this is unlikely.

5. It doesn't even show up in the web app. I'd try that first and foremost. I just circles and circles in the home view. If I wait long enough, eventually it will show 'next step' and display my tv shows, that's it. These TV shows subsequently fail to load on Roku TV, despite being displayed. I just hangs there, 'retrieving'. This is not a connectivity issue. Plex had no issues.

Share this post


Link to post
Share on other sites
ebr

Hi.  Does your file structure follow our conventions?

 

How did you define the library (using what type)?

Share this post


Link to post
Share on other sites
explex

Hi.  Does your file structure follow our conventions?

 

How did you define the library (using what type)?

 

 

Yes. Movies are located in their own individual folders, name as 'Movie Title (Year of Release)'

defined as Movies.

 

Again, the movies are all recognized in the metadata manager, so are the images - visible only in the overview of the movie library folder, see screenshot original post.

Edited by explex

Share this post


Link to post
Share on other sites
ebr

Can you please provide more details?

 

Exactly what libraries did you create? Pointing to what folders and using what media type?

 

Thanks.

Share this post


Link to post
Share on other sites
explex

Can you please provide more details?

 

Exactly what libraries did you create? Pointing to what folders and using what media type?

 

Thanks.

 

5c588bd0395d1_ScreenShot20190204at125903

 

These are .mp4 files. Content as in screenshot. Movies for Movie folder, TV shows for TV show. Complete path /volumes/blue/itunes media/movies or -tvshows, where blue is external HD

Edited by explex

Share this post


Link to post
Share on other sites
legallink

I would read the link of how to report a problem.  One of the first things it asks for is a server log so they can see what went wrong.

 

Plex vs Emby as far as access is very different, as plex forces you to go through their portal and Emby allows you to do whatever you want.  Just because you had connectivity with Plex does not mean you will have connectivity with Emby.  That being said, if you are local, you don't need to be doing much.

 

If the web app isn't loading things up, then something is amiss.  I'd post the server log and go from there.

Share this post


Link to post
Share on other sites
explex

So suddenly, movies are starting to show up in the home screen. There are about 10-15 now. It takes a very long time to index all movies, I guess? Is there a place where I can see a progress report or percentage completed? Streaming works now for the couple of shows that are visible. Coming from Plex, Emby takes a lot longer to do all the indexing. Is this normal behavior or do I need to adjust a few settings? Thank you to all who have answered my questions.

Share this post


Link to post
Share on other sites
arrbee99

I should imagine it would still help to attach a log - might show whats taking so long, some delay somewhere fetching metadata or something

Share this post


Link to post
Share on other sites
Luke

So suddenly, movies are starting to show up in the home screen. There are about 10-15 now. It takes a very long time to index all movies, I guess? Is there a place where I can see a progress report or percentage completed? Streaming works now for the couple of shows that are visible. Coming from Plex, Emby takes a lot longer to do all the indexing. Is this normal behavior or do I need to adjust a few settings? Thank you to all who have answered my questions.

 

There's an issue in the current release server causing movie libraries to take a lot longer to scan than they should. We'll be getting out a release this week to address that. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...