Jump to content

Enabling Intel Quick Sync Video using UnRaid Docker


techie1298
 Share

Recommended Posts

techie1298

Hello all,

 

I've been a long time emby premier user, and I'm trying to "upgrade" my setup a bit. Here's the basics of what I have:

 

Supermico X9SCL-F Motherboard

Xeon E3-1275 V2 Processor

Unraid 6.6.6

Emby 4.0.1.0 using the Emby Docker from the Emby Repo in Unraid

 

I can't find any info regarding compatibility of IQSV and the mobo (I've reached out to Supermico via email, who knows how long their reply will take), I know the processor has the ability, in emby, I can't get IQSV to work. On the transcoding page, if I choose Advanced under enable hardware acceleration, no options show up. If I have it on Yes, I see software decoding in the dashboard and all my cores are at 98%+.

 

I'm reaching out to the community here to see if there's any way I can get IQSV to work to ease the burden of transcoding since I'm upgrading my video library to a lot of 4K content, and want to continue to be able to watch it from outside my home on my phone or laptop (I use Kodi in my home, so there's absolutely no need for IQSV for local viewing). I'm a bit of a novice when it comes to anything outside of the GUI, but am comfortable messing with CLI if I have instructions.

 

I'm not sure if I posted this in the right place or if I need to provide any additional information, if anybody can give me some direction it would be greatly appreciated!

Link to comment
Share on other sites

lightsout

Hello all,

 

I've been a long time emby premier user, and I'm trying to "upgrade" my setup a bit. Here's the basics of what I have:

 

Supermico X9SCL-F Motherboard

Xeon E3-1275 V2 Processor

Unraid 6.6.6

Emby 4.0.1.0 using the Emby Docker from the Emby Repo in Unraid

 

I can't find any info regarding compatibility of IQSV and the mobo (I've reached out to Supermico via email, who knows how long their reply will take), I know the processor has the ability, in emby, I can't get IQSV to work. On the transcoding page, if I choose Advanced under enable hardware acceleration, no options show up. If I have it on Yes, I see software decoding in the dashboard and all my cores are at 98%+.

 

I'm reaching out to the community here to see if there's any way I can get IQSV to work to ease the burden of transcoding since I'm upgrading my video library to a lot of 4K content, and want to continue to be able to watch it from outside my home on my phone or laptop (I use Kodi in my home, so there's absolutely no need for IQSV for local viewing). I'm a bit of a novice when it comes to anything outside of the GUI, but am comfortable messing with CLI if I have instructions.

 

I'm not sure if I posted this in the right place or if I need to provide any additional information, if anybody can give me some direction it would be greatly appreciated!

I don't know anything about unraid so this may not pertain at all. But I recently had the same issue on my server running windows 10, I  had to plug in a monitor to get quicksync to be available. Running headless it wouldn't show up.

Link to comment
Share on other sites

techie1298

Well, yes and no. Supermicro responded quite a bit faster than I thought they would, and my the motherboard doesn't support QSV, so I'm out of luck. My setup does the job for 95%+ of my viewing needs, so I'm probably going to leave it as is for a while. The software transcoding is fast enough to get the job done, 4.0 seemed to improve that quite a bit as well.

 

Thanks for the guidance, if I had supported I'm sure I would be able to get it to work with the provided help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...