Jump to content

External subtitles shown as unknown language on Kodi Emby


zMeckx
 Share

Go to solution Solved by zMeckx,

Recommended Posts

Hello,

 

After the recent updates it doesn't recognize my subtitles (Dutch).

I never had an problem before the recent updates but it's just showing external subtitles - unknown.

Tried everything but it's just not working.. Any fix for this?

 

~zMeckx

Link to comment
Share on other sites

Folder structure: Movies / [movie name] (year) /

 

i.e. Movies/A Star Is Born (2018)/ 

 

A Star Is Born (2018).mkv

A Star Is Born (2018).srt

 

--- Old setup which always worked tho...

 

I've tried...

 

A Star Is Born (2018).mkv

A Star Is Born (2018).Dutch.srt

 

A Star Is Born (2018).mkv

A Star Is Born (2018).dutch.srt

 

A Star Is Born (2018).mkv

A Star Is Born (2018).dut.srt

 

A Star Is Born (2018).mkv

A Star Is Born (2018).nl.srt

 

A Star Is Born (2018).mkv

A Star Is Born (2018).forced.srt

 

A Star Is Born (2018).mkv

A Star Is Born (2018).dutch.forced.srt

 

None of the above worked.

Edited by zMeckx
Link to comment
Share on other sites

Did you do a refresh of the movie entry in Emby to ensure it picks up on the change?

Refresh did the trick. But before the update 4.0 I didn't have to do that, so why now?

  • Like 1
Link to comment
Share on other sites

You've always had to add the language tag for the subtitle stream to be labelled correctly. But glad it's working now. Maybe you just didn't notice before? I've had subs in my library for a very long time and the ones that had no language tag always were undefined in Emby.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

You've always had to add the language tag for the subtitle stream to be labelled correctly. But glad it's working now. Maybe you just didn't notice before? I've had subs in my library for a very long time and the ones that had no language tag always were undefined in Emby.

 

I'm sorry to be a pain in the butt. To be honest it was really working without the label before 4.0, but I don't wanna argue with you ofc, hehe.

But.. I thought I had it working.. Well ya.. For one movie. All the others it doesn't pick up my *.srt file..

What I do notice though is those movies have english subtitles in them and when I play them it show's the english insted of my  .dutch.forced.srt file..

 

Double checked, triple check, quadriple checked everything in my settings and the subtitles it has been set to a preference of Dutch.

Any suggestions?

Edited by zMeckx
Link to comment
Share on other sites

No problem, I suggest you ask in the server forums to get the final answer. I'm not an Emby dev, just speaking from experience.

 

In Kodi, if you play and change the track. Then stop playback. Try playing the content again, is it the right audio/subs?

Link to comment
Share on other sites

I can't change the track there it's just one (1/1) subtitle and that's English. It seem's to me it totally ignores the srt file.

 

Greets

Edited by zMeckx
  • Like 1
Link to comment
Share on other sites

Log added. 

 

If you have the Flicka movie it has 2 internal subs. English and Spanish.

Edited by zMeckx
Link to comment
Share on other sites

what do you mean by not providing?

 

Bah, sorry for the false alarm Luke. I've retested using Krypton and the same movie in my library and subtitles show there.

Edited by Angelblue05
Link to comment
Share on other sites

@@zMeckx

 

I'll ping you later today to continue troubleshooting this if you don't mind. In your logs, I saw something, Where the same title played in a row, first attempt has subtitles, second doesn't. I'm not sure why.

  • Like 1
Link to comment
Share on other sites

@@zMeckx

 

I'll ping you later today to continue troubleshooting this if you don't mind. In your logs, I saw something, Where the same title played in a row, first attempt has subtitles, second doesn't. I'm not sure why.

 

You have any solution yet? I'm gonna try a few things today :)

  • Like 1
Link to comment
Share on other sites

I've got it working and weird enough it's a little thing.

 


Not working:

 

.mkv

.dutch.forced.srt 

 

Working: 

 


.mkv

.Dutch.forced.srt 



 

 

// It only works for me with capitalizing the language, can you try the same?  Or does it also works on your end with all lowercase letters?
  • Like 1
Link to comment
Share on other sites

It doesn't make a difference in my situation. It sees the subtitles in both situation after I refresh the entry in Emby.

 

Can you confirm, in the webclient > movie > media info at the bottom, Emby sees all your subtitles? Keep me posted.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...