Jump to content

Can't sync music with 3.1.46a and Kodi 18

Go to solution Solved by Saviq,

Recommended Posts

I've updated my Kodi install to Leia and tried to reset the local database. Movies and TV synced fine, but music fails every time:

15:31:06.496 T:3743732592  NOTICE: EMBY.library -> ERROR:: no such table: versiontagscan
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/library.py", line 508, in add_library
                                                FullSync(self, library_id, update=update)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 62, in __init__
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 158, in start
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 215, in process_library
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/helper/wrapper.py", line 38, in wrapper
                                                result = func(self, dialog=dialog, *args, **kwargs)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 366, in music
                                                obj = Music(self.server, embydb, musicdb, self.direct_path)
                                              File "/storage/.kodi/userdata/addon_data/plugin.video.emby/emby/objects/music.py", line 39, in __init__
                                                self.disable_rescan(self.objects.objects['music'].split('MyMusic')[1].split('.db')[0], 0)
                                              File "/storage/.kodi/userdata/addon_data/plugin.video.emby/emby/objects/kodi/music.py", line 29, in disable_rescan
                                            OperationalError: no such table: versiontagscan

I'll PM the full log.

Link to comment
Share on other sites


Thanks for reporting, don’t forget to provide me with the complete log, thanks.


Edit: just saw your pm. Thx.

Edited by Angelblue05
Link to comment
Share on other sites

  • Solution

Nevermind, my database must have been corrupted through a previous attempt at upgrading to Leia. Having removed the database files everything is back in working order. Thanks!

  • Like 1
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...