Jump to content


Photo

Music Videos Guidance


  • Please log in to reply
6 replies to this topic

#1 nagetech OFFLINE  

nagetech

    Advanced Member

  • Members
  • 311 posts
  • Local time: 10:17 AM

Posted 11 January 2019 - 05:25 PM

Howdy Everyone!

 

Just looking for a quick nudge in the right direction. I finally decided to use emby for my music as well. I already added my music collection and let the library scan run. It has found everything with little to no need for manual intervention. Luckily, I had already been organizing my music for years using music brainz picard, so I'm sure it made it easy for emby to import everything.

 

Now this is where I'm a bit lost. I also figured, screw it, lets add the music videos as well. I have them organized as such:

 

Music Videos (Root Folder) ==> Artist (folder) ==> Artist - Name of Song (folder) ==> Artist - Name of Song.mkv

 

I added the Music Videos to the emby library (and yes I selected music videos for the folder treatment). It scans and finds everything, but this is where I get lost. When I click on Music Vidoes, it shows the folders, but it detects them as FOLDERS (as denoted by the folder icon on the top right hand side of each artist folder) When you go into it, it will display the music videos and it appears the IMVDB plugin was able to detect them properly. The weird part is, when I click on the artist name, it will take me to the page with the Bio and all the albums I own for them, but under the Music Videos Section, it shows nothing.

 

I have tried manually editing the meta data for each video and giving it the artist and album name, but still, under the artist name it will never display any of the music videos.

 

What am I missing? Is there a better way to setup the Music Videos?

 

Looking forward to any help!



#2 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3371 posts
  • Local time: 03:17 PM
  • LocationWarrington,UK

Posted 11 January 2019 - 05:42 PM

First - what server version?

 

 

With Beta

 

i have \MusicVid\ArtistName\nameofSong\nameofsong.mp4

 

each video has only four tags

AlbumArtist

Artist

Genre

Title

 

I use the IMVDB plugin - your videos need to be an exact match by name to what IMVDB has so Artist-Nameofsong will not work

 

I manually add in the Album name to the metadata once scanned into Emby

 

So i get this

5c390d5ea2ed8_Capture.jpg

 

5c390d6c96459_Capture2.jpg

 

5c390d7bb5256_Capture3.jpg

 

How my dirs look

5c390e66529b2_Capture4.jpg

 

5c390e735c79e_Capture5.jpg


Edited by PenkethBoy, 11 January 2019 - 05:45 PM.


#3 nagetech OFFLINE  

nagetech

    Advanced Member

  • Members
  • 311 posts
  • Local time: 10:17 AM

Posted 11 January 2019 - 05:44 PM

Sorry, forgot to mention that. I am on 3.5.3 , haven't made the leap to v4 yet.

 

I am toying around with it right now. Even when I manually put in all the information, it still doesn't seem to associate with the artist.

 

were there major changes/improvements made to v4 that perhaps handles music videos better?



#4 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3371 posts
  • Local time: 03:17 PM
  • LocationWarrington,UK

Posted 11 January 2019 - 05:49 PM

With all the changes in 4.0 yes early on there were some changes

 

But the above worked with 3.5.3 as i did not change the files or the structure

 

4.0 presents the library differently - and i think the videos not showing on the artist page was an issue - but as its 4 months ago cant be sure

 

I would go for it on 4.0 as its almost there and any extra final tweaks will get added and your server will update as it normally does



#5 nagetech OFFLINE  

nagetech

    Advanced Member

  • Members
  • 311 posts
  • Local time: 10:17 AM

Posted 11 January 2019 - 05:50 PM

Forgot to add before, oddly after I manually provide the metadata to my test vidoes, if I click the link to the album I specified, it will take me to the correct album (in this case I'm testing this with the 3 Doors Down Song, Kryptonite). But, as I said before, when I go to 3 doors down, it shows everything BUT the music videos. That part is always blank :(



#6 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3371 posts
  • Local time: 03:17 PM
  • LocationWarrington,UK

Posted 11 January 2019 - 05:56 PM

did you read my last post?



#7 nagetech OFFLINE  

nagetech

    Advanced Member

  • Members
  • 311 posts
  • Local time: 10:17 AM

Posted 11 January 2019 - 07:54 PM

did you read my last post?


Just looked at it. Ah so maybe I am fighting a bug. I’ll wait for 4.0 before I keep toying around with the music videos. Thanks for the help guys!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users