Jump to content

no such table: movie

Go to solution Solved by Angelblue05,

Recommended Posts


I'm on the latest beta, and I reset my database and tried to sync and I repeativly get this crash

17:47:29.148 T:3834639088  NOTICE: EMBY.full_sync -> starting sync with [u'57703e1cea529d7d07ec197b8fb217ef', u'Boxsets:57703e1cea529d7d07ec197b8fb217ef', u'1936c337f4d60279d1f0c0ef7d365fce', u'Boxsets:1936c337f4d60279d1f0c0ef7d365fce', u'a4f992b298a695e23dd4772b5716f9df', u'Boxsets:a4f992b298a695e23dd4772b5716f9df', u'7c6b1294b30d4c722993e4036d0425ac', u'7420614390edd3b1d53096584a86cf7d', u'60c6bb241c9195d4b536e84e02b31783']
17:47:29.196 T:3834639088  NOTICE: EMBY.helper.wrapper -> Processing Kids Movies: 57703e1cea529d7d07ec197b8fb217ef
17:47:29.599 T:3834639088  NOTICE: EMBY.database -> ERROR:: type: <class 'sqlite3.OperationalError'> value: no such table: movie
17:47:32.663 T:3834639088  NOTICE: Previous line repeats 1 times.
17:47:32.663 T:3834639088  NOTICE: EMBY.full_sync -> ERROR:: full sync exited unexpectedly
17:47:32.677 T:3834639088  NOTICE: EMBY.library -> ERROR:: no such table: movie
                                            Traceback (most recent call last):
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/library.py", line 493, in add_library
                                                FullSync(self, library_id, update=update)
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 62, in __init__
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 158, in start
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 215, in process_library
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/helper/wrapper.py", line 38, in wrapper
                                                result = func(self, dialog=dialog, *args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/full_sync.py", line 254, in movies
                                                obj.movie(movie, library=library)
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/helper/wrapper.py", line 97, in wrapper
                                                return func(*args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/helper/wrapper.py", line 110, in wrapper
                                                return func(self, item, e_item=e_item, *args, **kwargs)
                                              File "/home/osmc/.kodi/addons/plugin.video.emby/resources/lib/helper/wrapper.py", line 167, in wrapper
                                                return func(self, item, *args, **kwargs)
                                              File "/home/osmc/.kodi/userdata/addon_data/plugin.video.emby/emby/objects/movies.py", line 68, in movie
                                                obj['MovieId'] = self.create_entry()
                                              File "/home/osmc/.kodi/userdata/addon_data/plugin.video.emby/emby/objects/kodi/movies.py", line 36, in create_entry
                                            OperationalError: no such table: movie
17:47:34.549 T:3619689200  NOTICE: EMBY.entrypoint.default -> path: ?content_type=video params: {
                                                "content_type": "video"

I'm on OSMC, Vero 4k leia, latest emby everything. Thanks

Link to comment
Share on other sites

  • Solution

I linked the wrong thread, so you are right, it doesn't help fix it right now. I can't find the thread right now, anyway.


Here what you can do, in the kodi userdata folder > addon_data > plugin.video.emby > objects > open obj_map.json in notepad and edit the video line to reflect 114.db instead of 113.db


Or you can just wait, I should have a new build out later today to fix it (an hour or two max).

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites


This should be fixed with  3.1.38. Restart Kodi, then it should work. I made some adjustments, and added some warnings. Hopefully it never truly breaks like this from now on... :)

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...