Jump to content

Missing Movies in Library


Tekdawg
 Share

Go to solution Solved by ebr,

Recommended Posts

Greetings All

 

Hope this is not a duplicate post.

 

I have an issue where all the movies are not showing up "My Media" library. I have ran scan several times with no luck.

I setup on a different computer with the same issue. It seems to be the same files that are being displayed.

 

Any thoughts?

 

Thank you,

Rick

Link to comment
Share on other sites

Hi

 

I have a folder where all my movies are stored. When I set up the Emby server and add a Media Library I noticed that not all the movies are being displayed in "My Media" movie library. Say I have 100 movies but only 75 show up were I can click to play them.

I have even try creating its own nfo file with art work but still will not display as a movie to watch in the library.

 

Hope this helps as I really like this interface. I used to use Kodi and when looking for some add-ins I found yours but have since switched your web interface only.

 

Thank you,

Rick

Link to comment
Share on other sites

Hi.  Exactly how did you setup the library?  What content type did you give it?

 

How are your files named and what are their formats?

 

Do they adhere to our standards? Movie naming

 

Do you have any collections defined?  Have you turned on the option to combine movies into collections?

 

What about parental controls?  Did you define any?

 

If you search for one of the "missing" items, does it find it?

Link to comment
Share on other sites

There are a lot of fixes related to this in the upcoming 3.6 server release, so assuming you're on 3.5 it will probably be resolved then.

Link to comment
Share on other sites

  • Solution

Also, pay particular attention to the naming conventions for multi-part and multi-version items.  What may be happening here is that some of your items are being interpreted as one of those.

Link to comment
Share on other sites

What content type did you give it? Movies

 

How are your files named and what are their formats? movie name.avi or movie name.mp4.  A couple of the movies I noticed so far seem to .mp4 type.

 

Do they adhere to our standards?  Yes

 

Do you have any collections defined? No, but I have since starting setting them up which is how I found more than one was missing.

 

What about parental controls?  Did you define any? Not using

 

If you search for one of the "missing" items, does it find it? Does not find it, only the one I already see.

 

Also, pay particular attention to the naming conventions for multi-part and multi-version items. I have the Star Wars Saga using the names:

Star Wars Episode I The Phantom Menace.mp4

Star Wars Episode II Attack Of The Clones.mp4

Star Wars Episode III Revenge of the Sith.mp4

Star Wars Episode IV A New Hope.mp4

Star Wars Episode V The Empire Strikes Back.mp4 - not showing up

Star Wars Episode VI Return Of The Jedi.mp4 - not showing up

Star Wars Episode VII The Force Awakens.mp4 - not showing up

Star Wars Episode VIII The Last Jedi.mp4

 

This is the same for other collections.

Link to comment
Share on other sites

Greeting Support

 

I found a resolution.

 

I am working on the the movie collection: "The Hunger Games". The first two movies show up fine but... the last two Mockingjay Part 1 and Part 2 are the issue

 

If I have all four movies in the "Movie" folder only Part 1 will be displayed. If I take out Part 1 then Part 2 will be displayed. Thinking there is an issue with character length I shortened them and removed all pic's & nfo files.

When I did a manual scan where it found both movies files but because I shortened them it could not determine the movies, i had to manually edit the metadata ids and add the pics.

 

Here is what the names are.

Original names:

The Hunger Games Mockingjay - Part 1

The Hunger Games Mockingjay - Part 2

 

New Name that works

Hunger Games Mockingjay1

Hunger Games Mockingjay2

 

So looks like your app has a limit on the characters length it can read.

 

Thank you all the fast support.

 

Rick

Link to comment
Share on other sites

Actually, these are our naming conventions for multi-part media:

 

The Hunger Games Mockingjay - Part 1

The Hunger Games Mockingjay - Part 2

So i think what actually happened is it grouped them together.

Link to comment
Share on other sites

Deathsquirrel

Greeting Support

 

I found a resolution.

 

I am working on the the movie collection: "The Hunger Games". The first two movies show up fine but... the last two Mockingjay Part 1 and Part 2 are the issue

 

If I have all four movies in the "Movie" folder only Part 1 will be displayed. If I take out Part 1 then Part 2 will be displayed. Thinking there is an issue with character length I shortened them and removed all pic's & nfo files.

When I did a manual scan where it found both movies files but because I shortened them it could not determine the movies, i had to manually edit the metadata ids and add the pics.

 

Here is what the names are.

Original names:

The Hunger Games Mockingjay - Part 1

The Hunger Games Mockingjay - Part 2

 

New Name that works

Hunger Games Mockingjay1

Hunger Games Mockingjay2

 

So looks like your app has a limit on the characters length it can read.

 

Thank you all the fast support.

 

Rick

 

No, that's not the problem.  EBR highlighted the problem.  Those movies were tripping the multi-part movie scanner so were treated as one item.

 

There are a lot of different ways to organize your media that will work.  The naming wiki goes over them.  That said, there is a best option.  I'm defining best as producing the absolute fewest naming issues.  That is to put each movie in its own folder and name it and the folder exactly as your primary metadata provider labels it.  For example, I'm in the US and my primary provider is themoviedb.  Based on that the movie Conan the Barbarian should be named \\movieshare\Conan the Barbarian (1982)\Conan the Barbarian (1982).mkv.  That exactly matches what TMDB calls it.  Using this naming convention I have literally never had a movie recognition issue outside of my own typos.

Link to comment
Share on other sites

I'm missing TV Shows and Movies.  I've upgrade to Version 3.6.0.84 beta hoping it would correct the problem.  I'm missing 9 out of 61 in TV Shows. The list is attached as well as the log and the directory listing from DOS.

 

This has been going on for awhile, I've been using Plex to watch the shows and movies that won't show up in EMBY.  BTW Plex has never failed to list all shows and movies.

MissingShows.txt

DirectoryListing.txt

embyserver.txt

Edited by rkirchhof
Link to comment
Share on other sites

Hi there, how have your determined that they are missing? Can you please discuss the folder structure? Thanks.

Link to comment
Share on other sites

Yes, I know that are missing BC I can see them in the file system, but they are not displayed in the library.  You may observe the folder structure yourself. Please view directoryListing.txt (Previous Post) or Tree.txt this post.

Tree.txt

Link to comment
Share on other sites

Yes, I'm sure it complted. I was monitoring it's status in the Management console.  The Search Feature does not find any of the missing content.

Link to comment
Share on other sites

Any other idea's?  Is there any way to force it or add it manually?

Edited by rkirchhof
Link to comment
Share on other sites

Any other idea's?  Is there any way to force it or add it manually?

 

What program creates your metadata?  Emby does not create series or Movie xml files any more and requires a plugin to read them.

 

example from Magnum P.I

01/07/2019  09:37 AM             2,280 series.xml
01/07/2019  09:37 AM             2,053 tvshow.nfo

Can you zip those two metadata files and post.

Link to comment
Share on other sites

does this look normal?

 

2019-01-08 15:59:35.458 Info LibraryMonitor: TV Shows (G:\TV Shows) will be refreshed.
2019-01-08 15:59:39.314 Info HttpClient: GET https://www.thetvdb.com/api/GetSeries.php?seriesname=Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED&language=en
2019-01-08 15:59:39.687 Info HttpClient: GET https://www.thetvdb.com/api/GetSeries.php?seriesname=Les.Miserables&language=en
2019-01-08 15:59:40.065 Info HttpClient: GET https://api.themoviedb.org/3/configuration?api_key=f6bd687ffa63cd282b6ff2c6877f2669
2019-01-08 15:59:40.278 Info App: MovieDbProvider: Finding id for item: Les.Miserables
2019-01-08 15:59:40.376 Info HttpClient: GET https://api.themoviedb.org/3/search/tv?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=Les.Miserables&language=en
2019-01-08 15:59:40.673 Info HttpClient: GET https://api.themoviedb.org/3/search/tv?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=Les+Miserables&language=en
2019-01-08 15:59:40.970 Info HttpClient: GET https://api.themoviedb.org/3/tv/81224?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=credits,images,keywords,external_ids,videos,content_ratings&language=en&include_image_language=en,null
2019-01-08 15:59:41.305 Info HttpClient: GET https://www.thetvdb.com/api/B89CE93890E9419B/series/354256/all/en.zip
2019-01-08 15:59:41.887 Info HttpClient: GET https://webservice.fanart.tv/v3/tv/354256?api_key=5c6b04c68e904cfed1e6cbc9a9e683d4
2019-01-08 15:59:42.386 Info App: Creating Season Season Unknown entry for Les Misérables
2019-01-08 15:59:42.408 Info App: Creating virtual unaired episode Les Misérables 1x3
2019-01-08 15:59:42.411 Info App: Creating Season Season 1 entry for Les Misérables
2019-01-08 15:59:42.505 Debug MediaEncoder: Ffprobe -i file:"G:\TV Shows\Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED\les.miserables.2018.s01e01.internal.repack.1080p.hdtv.x264-failed.mkv" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2019-01-08 15:59:42.505 Info MediaEncoder: ProcessRun 'ffprobe' Execute: C:\Users\Robert\AppData\Roaming\Emby-Server\system\ffprobe.exe -i file:"G:\TV Shows\Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED\les.miserables.2018.s01e01.internal.repack.1080p.hdtv.x264-failed.mkv" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2019-01-08 15:59:42.756 Info MediaEncoder: ProcessRun 'ffprobe' Started.
2019-01-08 15:59:42.864 Info MediaEncoder: ProcessRun 'ffprobe' Process exited with code 0
2019-01-08 15:59:42.952 Info App: Removing virtual season Les Misérables null
2019-01-08 15:59:42.952 Info App: Deleting item, Type: Season, Name: Season Unknown, Path: , Id: 166805
2019-01-08 16:00:43.152 Info LibraryMonitor: Season 1 (G:\TV Shows\Les Misérables\Season 1) will be refreshed.
2019-01-08 16:00:43.257 Info App: Deleting item, Type: Episode, Name: Episode 1, Path: G:\TV Shows\Les Misérables\Season 1\Les Misérables(2018).S01E01.Episode 1 HDTV-1080p.mkv, Id: 165546
2019-01-08 16:01:43.255 Info LibraryMonitor: Season 1 (G:\TV Shows\Les Misérables\Season 1) will be refreshed.

Link to comment
Share on other sites

does this look normal?

 

2019-01-08 15:59:35.458 Info LibraryMonitor: TV Shows (G:\TV Shows) will be refreshed.

2019-01-08 15:59:39.314 Info HttpClient: GET https://www.thetvdb.com/api/GetSeries.php?seriesname=Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED&language=en

2019-01-08 15:59:39.687 Info HttpClient: GET https://www.thetvdb.com/api/GetSeries.php?seriesname=Les.Miserables&language=en

2019-01-08 15:59:40.065 Info HttpClient: GET https://api.themoviedb.org/3/configuration?api_key=f6bd687ffa63cd282b6ff2c6877f2669

2019-01-08 15:59:40.278 Info App: MovieDbProvider: Finding id for item: Les.Miserables

2019-01-08 15:59:40.376 Info HttpClient: GET https://api.themoviedb.org/3/search/tv?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=Les.Miserables&language=en

2019-01-08 15:59:40.673 Info HttpClient: GET https://api.themoviedb.org/3/search/tv?api_key=f6bd687ffa63cd282b6ff2c6877f2669&query=Les+Miserables&language=en

2019-01-08 15:59:40.970 Info HttpClient: GET https://api.themoviedb.org/3/tv/81224?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=credits,images,keywords,external_ids,videos,content_ratings&language=en&include_image_language=en,null

2019-01-08 15:59:41.305 Info HttpClient: GET https://www.thetvdb.com/api/B89CE93890E9419B/series/354256/all/en.zip

2019-01-08 15:59:41.887 Info HttpClient: GET https://webservice.fanart.tv/v3/tv/354256?api_key=5c6b04c68e904cfed1e6cbc9a9e683d4

2019-01-08 15:59:42.386 Info App: Creating Season Season Unknown entry for Les Misérables

2019-01-08 15:59:42.408 Info App: Creating virtual unaired episode Les Misérables 1x3

2019-01-08 15:59:42.411 Info App: Creating Season Season 1 entry for Les Misérables

2019-01-08 15:59:42.505 Debug MediaEncoder: Ffprobe -i file:"G:\TV Shows\Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED\les.miserables.2018.s01e01.internal.repack.1080p.hdtv.x264-failed.mkv" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data

2019-01-08 15:59:42.505 Info MediaEncoder: ProcessRun 'ffprobe' Execute: C:\Users\Robert\AppData\Roaming\Emby-Server\system\ffprobe.exe -i file:"G:\TV Shows\Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED\les.miserables.2018.s01e01.internal.repack.1080p.hdtv.x264-failed.mkv" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data

2019-01-08 15:59:42.756 Info MediaEncoder: ProcessRun 'ffprobe' Started.

2019-01-08 15:59:42.864 Info MediaEncoder: ProcessRun 'ffprobe' Process exited with code 0

2019-01-08 15:59:42.952 Info App: Removing virtual season Les Misérables null

2019-01-08 15:59:42.952 Info App: Deleting item, Type: Season, Name: Season Unknown, Path: , Id: 166805

2019-01-08 16:00:43.152 Info LibraryMonitor: Season 1 (G:\TV Shows\Les Misérables\Season 1) will be refreshed.

2019-01-08 16:00:43.257 Info App: Deleting item, Type: Episode, Name: Episode 1, Path: G:\TV Shows\Les Misérables\Season 1\Les Misérables(2018).S01E01.Episode 1 HDTV-1080p.mkv, Id: 165546

2019-01-08 16:01:43.255 Info LibraryMonitor: Season 1 (G:\TV Shows\Les Misérables\Season 1) will be refreshed.

 

This doesn't look right as Emby currently does not support episodes outside of Show folders.  But none of your other text files appear to show this structure,

"G:\TV Shows\Les.Miserables.2018.S01E01.INTERNAL.REPACK.1080p.HDTV.x264-FaiLED\les.miserables.2018.s01e01.internal.repack.1080p.hdtv.x264-failed.mkv"

So can you show a screenshot of the folder structure for a specific series that is missing.  Does G:\TV Shows only contain Show folders?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...