Jump to content
fanfan.li

Help: Why must server transcode when playing HEVC/H.265?

Recommended Posts

fanfan.li

Hello everyone, I installed Emby Server (3.5.3.0) on my DS3617 and installed the app on both iPhone and AndroidTV.

 

When I use my phone or TV to play video files in H.264 format (I am at home, LAN connection, video files are about 5GB), the video will not be transcoded by emby server, drag the playback progress during playback. The article is very sensitive and there is no such thing as a Caton.

 

But when I use the phone or AndroidTV to play the HEVC/H.265 format video file (1.6GB), the file is forced to be transcoded by the emby server. At this time, I drag the playback progress bar to buffer for a while (because The server is transcoding the video file, and my DS3617 CPU usage is almost 100%.

 

When I try to use the Kodi app on AndroidTV to play video files in the HEVC/H.265 format at Emby server, it can be played directly.

 

Can we not transcode when playing video files in HEVC/H.265 format by setting some options?

 

Thank you for your answers.

Share this post


Link to post
Share on other sites
Charlie117

I don't think it should transcode HEVC for your Shield TV unless you have set a bitrate limit in the app settings. Can you tell to what bitrate setting the Emby for Android TV is set?

Edited by Charlie117

Share this post


Link to post
Share on other sites
fanfan.li

Hi:

 

I just saw the AndroidTV app settings, it is 100Mbits/s, this value should be enough, my video file is only 1.6GB (about 60 minutes)

Share this post


Link to post
Share on other sites
fanfan.li

I don't think it should transcode HEVC for your Shield TV unless you have set a bitrate limit in the app settings. Can you tell to what bitrate setting the Emby for Android TV is set?

 

 

Hi:

 

    thanks for your help.

    I just saw the AndroidTV app settings, it is 100Mbits/s, this value should be enough, my video file is only 1.6GB (about 60 minutes)

Share this post


Link to post
Share on other sites
fanfan.li

Hi luke:

 

Thank you for your reminder.

I have read the guidance document "How to submit a bug", but I don't think it is necessary to provide a log.

This is a very obvious problem. When I play a video file in hevc format, I am Unable to prevent the server from transcoding him.

Share this post


Link to post
Share on other sites
Luke

I'm sorry but I need to look at an example in detail in order to accurately answer the question. Thanks !

Share this post


Link to post
Share on other sites
fanfan.li

Hi Luke:

 

Can this picture illustrate the problem?

 

My phone is iPhone8 plus, using the latest version of the emby client on Appstore. It can be seen from the figure that the HEVC encoded video is converted into a H.264 encoded video. This transcoding action should be performed on the server side. Is the emby app unable to decode H.265 format video?

Edited by fanfan.li

Share this post


Link to post
Share on other sites
Luke

Yes the app can decode HEVC. 

Share this post


Link to post
Share on other sites
fanfan.li

Sorry, I can't upload an image with my phone. I will upload the screenshot with my computer later.

Share this post


Link to post
Share on other sites
fanfan.li

This is a screenshot of my iPhone,using the app downloaded from the Appstore.

Share this post


Link to post
Share on other sites
Luke

Currently 10-bit HEVC is excluded from direct play. We need to improve that to allow it on iOS devices that support it. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
fanfan.li

Hi Luke:

 

Thank you for your answer, AndroidTV should not support HEVC10 direct playback also?

 

Can you tell me when the premium version of $119 will be discounted

Share this post


Link to post
Share on other sites
Luke

We'll look at this for the next update to the iOS app.

 

As far as Android TV goes, this depends on whether or not your device supports HEVC. Does it? What device?

Share this post


Link to post
Share on other sites
FoulFoot

Hello --

 

I'm getting this, too.  I'm on a FireTV 4k Stick.  Almost all my movies are HEVC encoded, and most (all?) are transcoding.  This transcoding (I assume) is also playing havoc with the audio sync; the audio is 1-2 seconds ahead of the video.  

 

The error listed in the transcode is "DirectPlayError,ContainerBitrateExceedsLimit".  Later errors are "Packet header is not contained in global extradata, corrupted stream or invalid MP4/AVCC bitstream".

 

Logs attached.  For some reason, it's giving me multiple "remux" logs, followed by a "transcode" log.

 

Foul

server.txt

remux.txt

transcode.txt

Share this post


Link to post
Share on other sites
Luke

It looks like the app tried to direct play, but the video player reported an error and then it automatically switched to transcoding. If i had to guess, the reason for the video player having trouble with the file is probably similar to the reason for ffmpeg having trouble with it on the server.

 

@@softworkz do you have any insight?

Share this post


Link to post
Share on other sites
3djc

Just for info, I have quite a few 4k 10 bits x265, they all play without trancoding on my nVidia shield

Share this post


Link to post
Share on other sites
FoulFoot

Just to make it more complicated -- I recently upgraded to the 4k stick from the FireTV Gen 2; I don't recall having these transcoding issues on the Gen 2 (or at least, there was no lipsync problem, so I might not have noticed that it was transcoding).  I'll try and verify that today, by hooking the Gen 2 back up and viewing the logs.

 

Foul

Share this post


Link to post
Share on other sites
Luke

Thanks let us know how you get on.

@@softworkz

Share this post


Link to post
Share on other sites
Nvdgraaf

Hi,

 

I am not really sure if i can post my question here but i have the same issue on my LG Smart TV Emby app. My smart tv from 2018 can play H.265 content.

 

But when i select H.265 content the server is transcoding it back to H.264.

 

My questions are:

 

1. In a previous answer, in this topic, it was stated that the Emby app, on ios, was not ready to play H.265. Does the same apply for the emby app for the LG smart tv, 2018 version?

 

2. If so, do you have any idea when this app will be updated so that it will play H.265?

 

 

Thanks,

 

Niels

Share this post


Link to post
Share on other sites
Luke

Hi,

 

I am not really sure if i can post my question here but i have the same issue on my LG Smart TV Emby app. My smart tv from 2018 can play H.265 content.

 

But when i select H.265 content the server is transcoding it back to H.264.

 

My questions are:

 

1. In a previous answer, in this topic, it was stated that the Emby app, on ios, was not ready to play H.265. Does the same apply for the emby app for the LG smart tv, 2018 version?

 

2. If so, do you have any idea when this app will be updated so that it will play H.265?

 

 

Thanks,

 

Niels

 

Hi there, the Emby LG app already plays h265. Did you explore the server dashboard during playback to learn why it was transcoding? Or did you use the video player stats feature to check this?

Share this post


Link to post
Share on other sites
Nvdgraaf

Hi there, the Emby LG app already plays h265. Did you explore the server dashboard during playback to learn why it was transcoding? Or did you use the video player stats feature to check this?

 

I used the video player stats to check this.

 

Later this evening I shall check it again, just to be sure. And post a picture.

Share this post


Link to post
Share on other sites
Luke

I used the video player stats to check this.

 

Later this evening I shall check it again, just to be sure. And post a picture.

 

And what did it say?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...