Jump to content

Watched status not not working


dwayneson
 Share

Recommended Posts

Hi,


 


I reinstalled emby using the first option (dhcp=on) in the link below because I was having issues with playing media through the web app, and watched status issues.


https://emby.media/community/index.php?/topic/60971-new-freenas-package-for-testing/page-7&do=findComment&comment=619899


 


I am now able to play media files on the web app. The problem is now just through the emby kodi addon on my wetek hub. Only some movies and shows record status properly while some just mark the whole media as watched regardless of where it is stopped, and strangely enough some seem to record an incorrect percentage complete. Further to this I was unable to use the latest stable emby for kodi because it kept asking for my emby log in details every time i turned it on. Lastly, I keep getting a "Skin help service error" regularly. Please see my log in the link below for the skin help service error and the episode errors.


https://paste.kodi.tv/losiwayepu


 


Please see the link below for the movie errors


https://paste.kodi.tv/wahebuhono


 


Here is a link to my original problem that has been half solved thanks to Luke.


https://emby.media/community/index.php?/topic/65914-playback-error-on-web-app/


 


Let me know if there is anything I can do to help you help me :)


 


Thank you


Link to comment
Share on other sites

I forget now Sorry, I was thinking the log would reveal that. I will test it again, repost the log and post the file/s that do not mark as watched in the morning. Thank you

Link to comment
Share on other sites

Hey, so I have tested another episode and uploaded the log. I only tried one episode and it was Vikings S05E01. When I stopped it midway through Kodi marked it as watched, cleared it from the Emby - Next Episodes list and S05E02 popped up. The log is below.

https://paste.kodi.tv/qoyaceluqo

Then I went to check what happened on my Emby server. Season 05 episodes 1-8 were all marked as watched already. I cross checked this with Kodi and it has episodes 2-4 still unwatched, with 1 and 5-8 marked as watched. I marked 2-4 as watched on Kodi, then tested episode 9 as both my emby server and kodi had is as unwatched. I skipped midway through and stopped it. The watched status worked correctly on Kodi for a few seconds, but then reset to unwatched. See log below. The status remained unwatched on Emby server.

https://paste.kodi.tv/bitohokito

 

FYI the skin helper service error I get is when I am on the home screen and I press left to access the menu shortcuts. I am using Titan 3.7.56

 

Thank you for your help

 

Update - I changed the skin back to the default Estuary and retested episode 9 by stopping midway through it again. It marked the status correct on both kodi and the emby server. Perhaps this is a skin issue?

Edited by dwayneson
Link to comment
Share on other sites

Yep sure do. I have attached it.

 

This gets stranger.. Using the Estuary skin still, I started watching Talladega Nights on Kodi but it didn't register as being watched on the emby server. I stopped it mid way through and the watched status worked on Kodi but still nothing recognising it as being partially watched on the server. Kodi log below. This should also be (or not be) in the attached emby log.

 

https://paste.kodi.tv/asadebujar

 

Sorry if it is something stupid on my behalf!

Thank you 

embyserver.txt

Edited by dwayneson
Link to comment
Share on other sites

@@dwayneson

 

Do you see it progress correctly in your server dashboard when this happens?

 

Edit: For your Talladega Nights, I don't even see any OnPlay event prior to playing the file. Where are you playing the file from? Library? Widget? The add-on didn't register it as playing, because there's no Kodi OnPlay event. Quite strange.

Edited by Angelblue05
Link to comment
Share on other sites

I was playing it from the home screen on Estuary skin, so widget?

 

UPDATE! I reset local kodi database and the playback status issue seems *fingers crossed* to be fixed.. the server dashboard is recognising when I play files and recording the correct status.

 

OK so before I posted the 2 sentences above I got a problem again... It seems to be random. This time, I started Jurassic World and skipped to about 1/4 of the way through, then to 1/2 way through, and stopped. Both kodi and emby server only recognised it as being 1/4 way through. Log below.

https://paste.kodi.tv/efaqogayay

 

Then i resumed it from 1/4 through and skipped to 1/2 way through and stopped it. This time they both recognised it as being 1/2 way through.

Then, from the emby recently added movies widget menu on the home page i selected mark as watched. It recognised it on kodi but not on emby server. It seems to be random because I had done this with 3-4 other movies / episodes prior to this one and it worked for them. See log below.

https://paste.kodi.tv/uqogewagig

 

Meanwhile - the emby in progress movies widget isn't working (not showing any movies regardless of watch status on kodi and emby server), I am still getting the skin helper service error though, and I can't edit a lot of the settings in skin settings. I have uninstalled and reinstalled the skin with no improvement.

 

Sorry this is probably a mess. Let me know if there is anything else I can test or show you.

 

Thank you

Edited by dwayneson
  • Like 1
Link to comment
Share on other sites

Can’t help you with skin helper errors. It’s not maintained. I recommend using a different skin, like embuary and uninstalling skin helper.

 

As for the in progress, it’s not something I’ve seen happen personally. I appreciate all the logs but as they contain multiple play attempts, etc. you don’t specify which title is played or mark as watched. Can you also provide this info, to make your actions easier to be found?

  • Like 1
Link to comment
Share on other sites

Thank so much for your advice. I will uninstall the skin and skin helper. Yep I will provide more info with each log. Typically the that is having a problem is the last one in the log but I'll make sure to mention it so it's clear. Thanks again.

  • Like 1
Link to comment
Share on other sites

Can’t help you with skin helper errors. It’s not maintained. I recommend using a different skin, like embuary and uninstalling skin helper.

 

As for the in progress, it’s not something I’ve seen happen personally. I appreciate all the logs but as they contain multiple play attempts, etc. you don’t specify which title is played or mark as watched. Can you also provide this info, to make your actions easier to be found?

 

I've not encountered any errors so far and I'm using it. What do you mean not maintained? I see no reference in here: https://forum.kodi.tv/showthread.php?tid=235676#

 

And also there's an unoficial alpha to download:

 

https://raw.githubusercontent.com/marduklev/repository.marduk/master/script.skin.helper.service/changelog.txt

Edited by djhifi
Link to comment
Share on other sites

Hi all,

 

So I've got a bit of an update. I am now using embuary. Thank you for the tip, I did not know it existed before! The skin helper error is gone however I am still having some issues with syncing.

I have 2 wetek hubs running LibreELEC, connected to my emby server on FREENAS. It seems to be random as to whether the show I watch on one hub is reflected as watched on the other hub.

For example, I watched Outlander S01E16 and S02E01 on my LibreELECLounge device the other night and then turned off the device. The next morning I turned on the device and it showed them both as watched, however when I turned on my LibreELECLiving device it showed S01E16 as next up. This is shown in the attached photos of my home screen on the 2 different devices. You will also notice that there is something funny happening with one device showing Vikings as next up after Outlander while the other device is showing Grand Designs. *Note I am not sure what the watched status was for these episodes on the server*.

 

Below are the links to the logs from startup of each device. I am hoping this helps you see why the LibreELECLiving device did not recognise the outlander episodes as being watched.

LibreELECLounge - https://paste.kodi.tv/eruwicexog

LibreELECLiving - https://paste.kodi.tv/ugobuwowum

 

The funny thing is, when I marked Outlander S01E16 as watched on my LibreELECLiving device, it then skipped straight to S02E02 as next up. So it knew that S02E01 had already been watched. I wonder if the issue is;

sometimes the server does not recognise when I watch a file on a host, or

sometimes the host does not reflect the watched status of a file from the server

 

Just before posting this I thought I would check the outcome from watching a movie tonight on my LibreELECLounge device. I watched First Man from start to finish, however it did not record as being watched on my server. So perhaps this is the issue, rather than the host not reading the watched status correctly from the server. Sorry I do not have a log from watching this, however I have gone back through my activity on the emby server and it shows me connecting to the device, and disconnecting from the device, with nothing to do with watching the movie. I am not sure what all the successfully authenticated messages in between are though.... I can try to repeat it, and capture the log if that will help?

 

Thank you!

 

A separate but related query I have is, does Kodi Companion work for 2 devices? Or should I disable it?

post-139391-0-06006500-1544874362_thumb.jpg

post-139391-0-33287000-1544874370_thumb.jpg

post-139391-0-72326400-1544875309_thumb.png

Link to comment
Share on other sites

Was the LELiving on when the content was marked as watched?

 

The server reflects the true value of the watched.status. Do try to repeat the test with First Man, but slower to see if it makes a difference. You have to give it a few seconds before stopping playback if you are fast forwarding/skipping, so the add-on can register it with the server.

 

As for the disconnect/reconnect, in your current logs, I'm not seeing this issue. If you are able to replicate this and provide a new kodi log, that'd be great.

 

Kodi companion works for all. It simply records server events, so that when Kodi is offline and comes back online, it'll know the changes that happened since.

  • Like 1
Link to comment
Share on other sites

I can't tell you sorry.

 

Tonight I watched Outlander SE02E04 on LELounge. It is recorded as watched on LELounge but the server didn't show it being watched in the recent activity and it is not recorded as being watched on the server. LELiving was not on at the time. The log for this is https://paste.kodi.tv/vuxufezaba

 

Ok thank you for letting me know. I just wasn't sure if when one kodi host comes online and reads the data from kodi companion it disappears so that when the other kodi host comes online there is no data to read.

  • Like 1
Link to comment
Share on other sites

Thanks for the log. I am not seeing any log lines to track playback at all, which is strange. Can you do a test, just in case something abruptly got messed up in the Kodi database? Launch the add-on > video add-ons > open the context menu on your tv library and do a repair. Then once completed, try to play a title. Does it show up under Active devices in Emby? Let me know, thanks.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...