Jump to content


Photo

Emby Full Screen


  • Please log in to reply
7 replies to this topic

#1 technobrad OFFLINE  

technobrad

    Newbie

  • Members
  • 1 posts
  • Local time: 07:12 PM

Posted 07 December 2018 - 09:36 PM

Hi Guys,

 

Hoping you could help me with a full screen issue.

I have an Intel NUC (NUC6i5SYH) connected to a display via HDMI and have Emby theater maximised.

 

If I turn the display off and back on again 10 seconds later the application is no longer in full screen.

This happens almost everytime I do so.

 

The problem cannot be replicated on VGA.

 

Any advise?

 

Regards,


Edited by technobrad, 07 December 2018 - 09:41 PM.


#2 pmac OFFLINE  

pmac

    Advanced Member

  • Members
  • 600 posts
  • Local time: 03:12 PM
  • LocationOntario, Canada

Posted 23 January 2019 - 01:23 AM

I have the same issue with my HTPC connected to my Panasonic Viera 65GT30 with HDMI. I've thought about just mapping "Alt-Enter" to my remote, but that's a bit of a hack...

#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121600 posts
  • Local time: 03:12 PM

Posted 23 January 2019 - 01:52 PM

A lot of apps will do this when the display mode changes due to something like turning on or off your receiver.



#4 richt OFFLINE  

richt

    Newbie

  • Members
  • 3 posts
  • Local time: 03:12 PM

Posted 26 February 2019 - 10:00 PM

I'm seeing this with an Intel NUC as well.  I have also used multiple home theater apps over the years and Emby Theater is the only one that does this repeatedly.  There has to a solution for this.  Any ideas on what we can try? 

Along this line, I was also looking for a command line switch or some other means to make sure Emby Theater starts up in full screen mode.  I haven't found one yet and it seems to start up in whatever mode it was in when last closed.  



#5 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10602 posts
  • Local time: 12:12 PM

Posted 26 February 2019 - 10:09 PM

Welcome to the HDMI 19th pin fiasco. It's the control pin. On some systems, it notifies Windows that the display is turned off, so as Luke is saying, the display mode changes. There are some devices out there that get around this. Like monitordetectkiller


Edited by Doofus, 26 February 2019 - 10:12 PM.


#6 richt OFFLINE  

richt

    Newbie

  • Members
  • 3 posts
  • Local time: 03:12 PM

Posted 26 February 2019 - 10:26 PM

Agreed, however I have been running other software on the exact same hardware that didn't exhibit this behavior so I cannot see how it could be a hardware & Windows only issue.  SageTV never exhibited this behavior and while Plex did it was rare.  I just started using Emby Theater this week and am hoping for a solution.  If not directly resolving it, then the ability to set and unset full screen mode when not playing a video would be helpful as I could program that into my remote. 



#7 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10602 posts
  • Local time: 12:12 PM

Posted 26 February 2019 - 10:30 PM

I've had this happen with simple OS windows. It isn't Emby. I've fought this battle for years. With my present configuration, I actually don't have this issue.



#8 zubalea OFFLINE  

zubalea

    Newbie

  • Members
  • 1 posts
  • Local time: 03:12 PM

Posted 15 March 2019 - 06:26 AM

This fix worked for me on a Windows O/S HTPC.

 

It requires a registry update:

 

Run regedit.exe

Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\???\00\00

Where ??? is different between systems.   Mine started with the word SIM.... 

 

In first "00" folder change the resolution using "Decimal" values:

PrimSurfSize.cx = 1920
PrimSurfSize.cy = 1080

 

In second "00" folder change the resolution using "Decimal" values:
ActiveSize.cx = 1920
ActiveSize.cy = 1080

 

Reboot.   

 

I used 1920x1080 resolution, but yours may be a different resolution.
 


Edited by zubalea, 15 March 2019 - 06:26 AM.

  • serpi likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users