Jump to content
germanicus

ANSWERED No resume on any video

Recommended Posts

germanicus

Hello all,

 

So far I really love Emby. It has provided 95% of the solutions I need for multiple users in my home however, there is one really nagging issue that is kind of a deal breaker. I bought premium for one month to see if it's worth it and the only thing holding me back now from purchasing a lifetime membership is this one issue.

 

No videos will resume playing if I leave that video's screen. It correctly marks where I left off and when I go to play it from where I left off it quickly loads to that marker and then the slider moves to the beginning of the file and pauses. If I hit play, it just does nothing. My only option is to go back to the show's page and hit play rather than resume and then manually go back to where I left off. This only seems to happen on my PC's (all running Arch, both Chrome and Firefox), it works fine on my Android devices.

 

I would really appreciate any insight on how to fix this. Just let me know if you need any log files and I'll upload them.

Share this post


Link to post
Share on other sites
germanicus

Sorry, when looking for posting guidelines I was looking for a pinned post in this sub-forum since it seemed most relevant.

 

I think these should be the most relevant log files, I wasn't sure if it was direct streaming or transcoding but the direct stream logfile had the most recent timestamp as it related to my replicating the issue.

 

Edit: If you search for timestamp "2018-11-25 20:23:54.994" this is when I last purposefully replicated the issue.

embyserver.txt

ffmpeg-directstream-28d02cf4-d521-441d-a26f-e0c6befe74b8.txt

Edited by germanicus

Share this post


Link to post
Share on other sites
Luke

Was there an ffmpeg log to match this?

2018-11-25 20:23:49.539 Info App: FFMpeg exited with code 0
2018-11-25 20:23:49.573 Info App: /usr/bin/ffmpeg -ss 00:29:54.000 -noaccurate_seek -f matroska,webm -i file:"/home/germanicus/Media/TV/Survivor/Season 37/Survivor.S37E06.720p.WEB.x264-TBS/survivor.s37e06.720p.web.x264-tbs.mkv" -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 copy -bsf:v h264_mp4toannexb -copyts -vsync -1 -codec:a:0 copy -copypriorss:a:0 0 -f segment -max_delay 5000000 -avoid_negative_ts disabled -map_metadata -1 -map_chapters -1 -start_at_zero -segment_time 6 -segment_time_delta -1794 -individual_header_trailer 0 -break_non_keyframes 1 -segment_format mpegts -segment_list_type m3u8 -segment_start_number 299 -segment_list "/var/lib/emby/transcoding-temp/b29a18955b9cfe4d97eb22c551c4c76a.m3u8" -y "/var/lib/emby/transcoding-temp/b29a18955b9cfe4d97eb22c551c4c76a%d.ts"
2018-11-25 20:23:49.741 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.5.3.0
	Command line: /usr/lib/emby-server/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartexitcode 3
	Operating system: Unix 4.19.2.1
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /var/lib/emby
	Application directory: /usr/lib/emby-server
	System.Exception: Error starting ffmpeg
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.StartFfMpeg(StreamState state, String outputPath, EncodingOptions encodingOptions, CancellationTokenSource cancellationTokenSource, Boolean acquireResources)
	   at Emby.Server.MediaEncoding.Api.Hls.DynamicHlsService.GetDynamicSegment(StreamRequest request, String segmentId)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	System.Exception
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.StartFfMpeg(StreamState state, String outputPath, EncodingOptions encodingOptions, CancellationTokenSource cancellationTokenSource, Boolean acquireResources)
	   at Emby.Server.MediaEncoding.Api.Hls.DynamicHlsService.GetDynamicSegment(StreamRequest request, String segmentId)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	

Share this post


Link to post
Share on other sites
germanicus

I think this one is it but I'm not 100% positive.

 

Edit: for some reason it won't upload that one so here it is on pastebin https://pastebin.com/MZeXD90X

Edited by germanicus

Share this post


Link to post
Share on other sites
Luke

No that's not it. It would be short most likely.

Share this post


Link to post
Share on other sites
germanicus

I'm not sure what part of that to grep to find which ffmpeg file to include. Whenever I try finding any of that particular text in the log files it's only found in embyserver.txt. So, I've just zipped up all the logs in that directory and put them on one of my servers for you to download.

 

http://107.173.70.111/emby-logs.zip

Share this post


Link to post
Share on other sites
Luke

What kind of storage are these videos on? It almost looks like an I/O stall.

Share this post


Link to post
Share on other sites
germanicus

4TB external drive, connected via USB3, formatted EXT4.

 

It should be noted that I don't have a resume issue in Kodi playing from the exact same source.

Share this post


Link to post
Share on other sites
softworkz

He's using an ffmpeg version (4.1) that we do not support.

Share this post


Link to post
Share on other sites
germanicus

I'm on Arch. Which version of ffmpeg should I downgrade to?

Share this post


Link to post
Share on other sites
Luke

4.0.2. In the near future we'll be shipping our custom ffmpeg with the server. Arch linux is currently the only platform we are not doing that for.

  • Like 1

Share this post


Link to post
Share on other sites
softworkz

Once you have downgraded and still got problems:

 

In your first post you mentioned about resuming videos that have been paused during playback. About what time frame are we talking here between pause and resume?

Share this post


Link to post
Share on other sites
germanicus

The downgrade seems to have worked.

 

Once you have downgraded and still got problems:

 

In your first post you mentioned about resuming videos that have been paused during playback. About what time frame are we talking here between pause and resume?

 

Just for reference, it varies between 10 minutes to 40 minutes (this has just been my sample size videos.)

 

Thank you all for the great support. This is all the reason (well and great features) I need to continue paying for a membership. I think, just to support you guys a little more I'm going to continue paying month to month for a bit before buying the lifetime membership. You all deserve it.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...