Jump to content

How to solve Scan media library failed problem


JanKol
 Share

Recommended Posts

Hello,

I have a problem with scanning my library from the beginning of using Emby. As i found Plex and Kodi absolutely unusable for me, I have ended with Emby, where I done all settings and found all features I need. I am running portable version Emby on Windows 7 dedicated desktop computer, copied on non system magnetic hardrive, where also all my media are stored. As I am running Emby under non admin Windows account I have used NSSM to run emby as service under this account.

 

My last reamaining problem is with scaning media. I have a lot of media divided into four libraries. Two for videos/movies, other two for photos/pictures. Everytime I start scaning, it fails. Average scan time is 15mins. As I do not care about watch data, I have deleted library.db and started Emby server again, but without luck. I have read some topics related to this problem, but I have not find solution there.

 

I think there is some problem with my media, but as I have lot of media, it is not easy to check it all. Is there any feature how to find root casuse of problem? I have attached datalogs, but I am not able to find anything saying something like: Error while scaning file.... So I have no idea how to debug this.

 

Thank you in advance with this issue.

 

Log.txt

Log_scan.txt

 

 

 

 

 

 

Link to comment
Share on other sites

The error is resolved for the next release. If you need immediate relief you can always use the beta channel. Thanks.

Link to comment
Share on other sites

Hello @ebr  and @@Luke,

I have decided to disable current Emby version by disabling Windows service of my current portable version and Install beta version to another location, add same libraries and check if this will work. I will let you know.

 

Jan

Link to comment
Share on other sites

Hello,

I have finally fully switched to the actual beta version and all my problems are away.

 

When I removed Windows service responsible for running Emby server and restarted computer, I found out that Emby  is still running. I forgot Emby shortcut in folder "Start up" (Sorry I am using Czech windows and do not know extact English Name of Folder. Word to word translation is "After start-up" or something like that.) But as result, Emby was somehow executed two times, but I have never detected some collisions. Maybe there is a mechanism which not allow to run Emby two times. But I tried if this solves my problem, because in that case was Emby executed as an application, not as a service. But result was the same. So I had to Install Beta version.   

 

When I wanted to download beta version, I could not find beta portable version. Does it exist?

 

I had to download and install Emby normally, where I could not set installation path. I am also running emby as a service again. My server has system SSD and data HDD. So now I have all Emby data on SSD. Stable version I was used to use is portable because I wanted to have Emby and his files to HDD not on SSD. Is there any risk or possible problems to have Emby data on SSD? In another topic there was user who had dedicated SSD for Emby. I understand that having Emby data on SSD leads to faster operations with database, but I am afraid of my SSD lifetime, as I do not know how mutch data Emby writes in time.

 

Is there a way how to change Emby paths and copy all actual data to another location without any data lost? I see in server Dash Board section Paths, but I am not able to click on it. Changing paths is a Premiere feature? I would like donate this project. If I buy Premiere for one month, will paths remain after my premiere expires? (In case paths can be changed with Premiere)

 

@@Luke has been talking about "beta channel". I am not familiar with this on Emby. Is this something more than Beta version of Emby server application?

 

Regards,

Jan

Link to comment
Share on other sites

Hi, we don't currently have a portable beta on the website but it's something we can consider for the future.

 

Changing paths does not require Emby premiere. The server's cache, metadata and transcoding temporary files are all configurable. Thanks.

Link to comment
Share on other sites

Hello,

I have spent several days monitoring of Emby. I tried to find where are path settings. I found in another topic here that each path is configurable in the different settings menu. I have decided to keep Emby data on SDD keep important data on data HDD. I have also found another solution for change Emby data location. It is based on moving Emby data desired location and in original Emby folder create folder shortcuts to the new files location. There is said that folder shortcut is transparent for applications. Can you also recommend this solution?

 

My second question is related to Emby update. I have still Beta version and there is a new beta version But I am not able to find update option. (I mean update from Beta to Beta). Is it possible to download the latest beta setup file and just execute it? Will my settings and user data kept during update? Or is there another optrion?

 

Thanks.   

Link to comment
Share on other sites

Hi, for the first one, unfortunately I do quite understand what you're asking. What do you mean about shortcuts?

 

For the newer beta, I would just install the latest on top of your existing version. Thanks.

Link to comment
Share on other sites

Hi,

I have successfully updated beta version of Emby over existing beta without any problem.

 

Here is a post explaining what I mean by "shortcut":

 

 

Posted 26 January 2016 - 06:28 PM

shutdown emby server

move appdata\emby-server to eg. d:\emby-server using eg. explorer

from command prompt in \appdata

mklink /d emby-server d:\emby-server

start emby server

 

the result as viewed in explorer is a "shortcut" called "emby-server" in \appdata which takes you to d:\emby-server.

 

you could do the same with individual subfolders..to spread out the load of the application data accross multiple disks... (where there is not an option in web client)

 

 

ive never tried it, but it must work as links are invisible to applications.


Edited by ginjaninja, 26 January 2016 - 06:30 PM.

 

I have not tried this yet, but I think this could work. Sorry for misunderstanding.

Link to comment
Share on other sites

ginjaninja

Ok, i haven't tried that either, but @@ginjaninja may be able to provide additional insight. Thanks.

 

symbolic links are invisible to applications, so *should* work with emby, i still have not tried myself

I would not recommend using this method without a very good reason (in the the interests of simplicity).

 \AppData\Roaming\Emby-Server is best on SSD, and from i can tell you have that already so i wouldnt change.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...