Jump to content
bl4ck4dd3r

Stereo only from all sources

Recommended Posts

bl4ck4dd3r

Migrating from RasPlex and like what I have experienced so far with Emby but have one problem that I cannot resolve.

 

using emby-theater-rpi_3.0.4.zip I cannot get audio other than Stereo from any source , the Pi is connected to my a/v amp over hdmi and with Rasplex I can get audio to work as expected by choosing my speaker setup (5.1) and ticking all the passthru selections for ac3, dts etc. 

Making the same selections within emby-theater does not yield the same results.

is there something perhaps in config.txt that I need to enable ? 

I see there are differences in config.txt from the rasplex install to the emby install but am ignorant as to what changes (if any) should or could be made.

 

given that the hardware setup is identical in either case and the only change is the media player software it has to be a configuration issue.

after each change I have restarted the Pi and re-checked to make sure the settings have 'stuck' and they have so no matter what I have changed so far has not made any difference to the result.

 

any clues as to where I may have missed something ?

 

 

Edited by bl4ck4dd3r

Share this post


Link to post
Share on other sites
Luke

Hi, what have you configured in the app's audio settings?

Share this post


Link to post
Share on other sites
bl4ck4dd3r

speaker layout - 5.1

☑️ ac3

☑️ eac3

☑️ DTS

☑️ DTS-HD

☑️ True HD

 

dynamic rang compression - none

 

exclusive audio - off

upmix audio channels - off

Share this post


Link to post
Share on other sites
Luke

Does the stats feature in the video player say that it is direct playing?

Share this post


Link to post
Share on other sites
bl4ck4dd3r

yes , DirectPlay

 

here is a (poor quality) photo if the 'stats for nerds' page

post-377260-0-50411200-1542880028_thumb.png

Share this post


Link to post
Share on other sites
Luke

Hmm that's strange. Not sure why mpv is choosing stereo. In my own testing it has just worked.

Share this post


Link to post
Share on other sites
bl4ck4dd3r

is there anything different in your config.txt to the one supplied in the install zip ?

I had to add

hdmi_group=1

hdmi_mode=16

to get my tv to display 1080p @ 60Hz as the stock config was setting the screen to 1080i

 

mpv does not trigger any resolution / refresh changes on my setup , no matter the source material . 

 

Could it be that there is no  recognition of the capabilities of the destination devices? 

I don't have an unusual setup. Pi -> A/V amp -> TV in a HDMI chain with the amp used as an input switch for Sat , Console and Media player.

 

perhaps there is a way to force mpv to output the signals I need ?

Share this post


Link to post
Share on other sites
Luke

 

 

mpv does not trigger any resolution / refresh changes on my setup , no matter the source material . 

 

Well this option is actually only implemented on windows for right now, but the audio passthrough should work.

Share this post


Link to post
Share on other sites
Guest asrequested

Hmm that's strange. Not sure why mpv is choosing stereo. In my own testing it has just worked.

 

It just reports them as stereo. AC3, EAC3, DTS etc, these are reported as stereo when bitstreamed. It's a result of how they implement them. In the Git builds, you'll see the same thing with DTS-MA HRA. It's still bitstreamed, correctly. 

 

Here's an example from a log.

[   0.019][i][cplayer]  (+) Video --vid=1 (*) (h264 1920x808 23.976fps)
[   0.019][i][cplayer]  (+) Audio --aid=1 --alang=eng (*) (dts 6ch 48000Hz)

[   0.568][v][ad] Codec list:
[   0.568][v][ad]     spdif_dts_hd (dts) - libavformat/spdifenc audio pass-through decoder
[   0.568][v][ad] Opening decoder spdif_dts_hd
[   0.568][v][ad] Selected codec: spdif_dts_hd (libavformat/spdifenc audio pass-through decoder)

[   0.572][v][cplayer] Starting playback...
[   0.573][v][ad] In: profile=20 samplerate=48000
[   0.574][v][af] [in] 48000Hz stereo 2ch spdif-dts
[   0.574][v][af] [userspeed] 48000Hz stereo 2ch spdif-dts
[   0.574][v][af] [userspeed] (disabled)

[   0.685][v][af] [convert] (disabled)
[   0.685][v][af] [out] 48000Hz stereo 2ch spdif-dts

5bf87e7438d48_Snapshot_87.jpg

 

5bf87eed8fc0c_Snapshot_88.jpg

 

Unless you're only hearing stereo, I wouldn't worry about it. 

Share this post


Link to post
Share on other sites
Luke

Ah ok, so that's all this is, is just an issue on the stats display?

Share this post


Link to post
Share on other sites
Guest asrequested

If you disable audio passthrough, then you would see how many channels it's decoding.

 

5bf8815fdd403_Snapshot_89.jpg

[   0.625][v][af] [in] 48000Hz 5.1(side) 6ch floatp
[   0.625][v][af] [userspeed] 48000Hz 5.1(side) 6ch floatp
[   0.625][v][af] [userspeed] (disabled)
[   0.625][v][af] [convert] 48000Hz 5.1(side) 6ch floatp
[   0.625][v][ao] Trying audio driver 'wasapi'
[   0.625][v][ao] Using preferred device 'SC-95 (NVIDIA High Definition Audio)'
[   0.625][v][ao/wasapi] requested format: 48000 Hz, 5.1(side) channels, floatp

Share this post


Link to post
Share on other sites
Guest asrequested

Ah ok, so that's all this is, is just an issue on the stats display?

 

I think I might make report to them, and see if I get a response.

Share this post


Link to post
Share on other sites
Guest asrequested

Oddly enough, when using 7.1, it's reported, correctly.

[   0.539][v][cplayer] Starting playback...
[   0.539][v][ad] In: profile=-99 samplerate=48000
[   0.539][v][af] [in] 192000Hz 7.1 8ch spdif-truehd
[   0.539][v][af] [userspeed] 192000Hz 7.1 8ch spdif-truehd
[   0.539][v][af] [userspeed] (disabled)
[   0.539][v][af] [convert] 192000Hz 7.1 8ch spdif-truehd

[   0.840][i][cplayer] AO: [wasapi] 192000Hz 7.1 8ch spdif-truehd
[   0.840][v][cplayer] AO: Description: Windows WASAPI audio output (event mode)
[   0.840][v][af] [convert] (disabled)
[   0.840][v][af] [out] 192000Hz 7.1 8ch spdif-truehd
Edited by Doofus

Share this post


Link to post
Share on other sites
bl4ck4dd3r

i think it is more than a stats display , my a/v amp shows only 2 channels on the front panel and there is definitely only sound from the front two stereo speakers

Share this post


Link to post
Share on other sites
Guest asrequested

i think it is more than a stats display , my a/v amp shows only 2 channels on the front panel and there is definitely only sound from the front two stereo speakers

Then a log will be helpful. I don't have an RPi, so I don't know what the file system is like, but here's how to make log on Windows. I'm sure you can adapt it for RPi

 

https://emby.media/community/index.php?/topic/50975-how-to-enable-mpv-logging-for-theater/?fromsearch=1

Share this post


Link to post
Share on other sites
bl4ck4dd3r

hmm, i will have to look into this so bear with me as

1) i am not using windows

2) mounting the sd card on my desktop does show files but nothing that looks like either emby or mpv so i will probably have to telnet or ftp to the rpi over the network to get a look at the filesystem when booted

Share this post


Link to post
Share on other sites
Guest asrequested

If you can find the MPV.exe, you can put the mpv folder, there.

Share this post


Link to post
Share on other sites
Guest asrequested

Luke, I think it would be a good idea to incorporate mpv logging in the Theater app. 

Share this post


Link to post
Share on other sites
Luke

Yes i would agree.

Share this post


Link to post
Share on other sites
cpschentke

Hi there, also having the same issue, is this suppose to be fixed in 3.0.6?
Set 5.1 and only get Stereo. 
Tried passthru aswell but only Stereo 

 

Is there any configs that need to be changed in order to get this to work?

 

Kind Regards

Share this post


Link to post
Share on other sites
Luke

Are you still running into this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...