Jump to content


Photo

Subtitles showing when they shouldn't


  • Please log in to reply
5 replies to this topic

#1 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2324 posts
  • Local time: 03:40 AM
  • LocationPerth, Australia

Posted 19 November 2018 - 11:20 AM

Not sure when this happened, but it's recently (maybe less than a week)...

 

I have many mkv files with internal subs, but with the default and forced flags both set to no. 

 

For some reason ET has started showing the subs regardless of the internal flag settings. 

 

I tried setting ET's subtitle settings to Default, then Smart and even Forced Only - and the subs always show. 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121600 posts
  • Local time: 03:40 PM

Posted 19 November 2018 - 01:08 PM

They are remembered from previous playback.

#3 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2324 posts
  • Local time: 03:40 AM
  • LocationPerth, Australia

Posted 19 November 2018 - 07:55 PM

They are remembered from previous playback.

 

I thought something weird was going on, as when I check different episodes (all with the same flags) the subtitle would show or it wouldn't.

 

What ET subtitle setting should I be using so only subtitles with the default flag set to "Y" will be displayed?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121600 posts
  • Local time: 03:40 PM

Posted 20 November 2018 - 12:05 AM

I would set your subtitle mode to Default.



#5 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2324 posts
  • Local time: 03:40 AM
  • LocationPerth, Australia

Posted 05 December 2018 - 12:15 PM

I've just figured out what was going on here.

 

I have ET subtitle mode set to "default" - but this is occuring in the Web UI as well. Subtitles were defaulting to "Eng" instead of "off" when the embedded subtitle track flags "default" and "forced" were both set to "no".

 

The issue was that the audio track didn't have a language assigned - once I set the audio language to "eng" and re-scanned the library, both ET and the web UI defaulted subs to "off".

 

Not sure whether this is a bug or a feature - but at least we now know the cause. And I can work around it by making sure videos have their audio track language set.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 121600 posts
  • Local time: 03:40 PM

Posted 05 December 2018 - 12:18 PM

Yes the audio track language does factor into it. Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users